Finally Custom Recovery for 2.2.1 stock phones !!!!!!


  1. alexxseven

    alexxseven Well-Known Member

    i have that same issue!! im going to try something though. if you want to test it first go ahead ;D!

    my plan is to go and flash in the recovery made for 2.2 *hopefully that will overwrite the one there*
    then REflash this one in.

    my guess is flash_image is noticing the files are closely the same and saying "its already there so i won't change this"

    EDIT_____

    tried and it failed. sorry to say but my method of trying to update it didn't work either
  2. new optimus

    new optimus Well-Known Member

    After using his recovery and instructions my recovery works, but like already posted I am not getting the joneidy image either mine says
    Build : RA-thunderc-Metro-v1.2.0-GNM

    I dont know if that background pic in the first post is part of the new image or not but I dont have that, mine is like his original pic
    Though everything is working, which is good.
    I also installed the new rom Love the honeycomb start up, no more metropcs.
  3. alexxseven

    alexxseven Well-Known Member

    i have come to the conclusion that he hasn't reupped the file and linked us to it. lol

    can you link me to the rom by the way? :D
  4. joneidy

    joneidy Well-Known Member

    That was why I said a couple of post above. To everyone who had already download the old recovery to download and flash the new one with a couple of fixes and a new image.
    LOL

    BTW the custom rom is right here

    Edit: My bad people I was linking to the old recovery. Now I`m linking to the new one. Just download it and flashed it and it will look as the picture above.
    alexxseven likes this.
  5. reppard

    reppard Well-Known Member

    How can I use this custom recovery to flash my phone back to the original 2.2.1 stock rom that I rooted my phone with. Id like to go some experimenting but I'd like to have a fail safe to go back to.
  6. alexxseven

    alexxseven Well-Known Member

    lol thx for the link to the rom and for updating the recovery link :D i shall now torture my phone with ADB shell to flash the recovery ^^! lol

    big thanks for this by the way! having a working custom recovery will help get people on 2.2.1 a long way as far as modding goes :D
  7. new optimus

    new optimus Well-Known Member

    Ya I flashed that earlier today I dont see the changes between the versions he has but I do like the options it gives me.
  8. hav0kk

    hav0kk Well-Known Member


    Ok folks. I removed the original custom recovery and image. Redownloaded and finally see the joneidy build.
    and on a side note i'm glad you changed the background. helps confirm we have the right recovery running.

    Update:

    attempting to complete my nand backup and i'm still getting the Error : Run 'nandroid-mobile.sh' via adb!

    should I just do as requested and follow the request to run nandroid-mobile.sh? or is there something i'm missing? Last time I was told it's a space issue.. but I have plenty of space on my sd card 4gigs free.

    the floor is open
  9. new optimus

    new optimus Well-Known Member

    I did 2 backups, prior to flashing this one today. The first went as expected the second said the same error run from adb, I did so and then today after flashing this one I did a back up and it was normal.
  10. hav0kk

    hav0kk Well-Known Member

    I tried a couple times but got the same message. Derno... I've read other forums and it seems there is a lot of speculation as to what the fix is but the bottom line is there seems to be no specific reason.

    1. battery low
    2. no space
    3. randomly works with doing nothing different.
    4. blessing from witch doctor. I think his name is Ted.
  11. garrytipler

    garrytipler Active Member

    got it after 20 mins for those who might be having the same problem don't usb connect just plug in and enter the commands into adb shell and restart
  12. hav0kk

    hav0kk Well-Known Member

    I'm in debug mode when doing this. I don't think you could navigate otherwise in adb

    I'm gonna keep trying and see if it's just tricky or until someone give me another solution to try.

    Update::: This was all done not plugged into the pc.
    4:44p Nandbackup complete (first time I tried)
    4:45p Nandbackup + .android_secure complete (first time I tried)
    4:47p Nandroid + ext (Error MSG : run 'nandroid-mobiel.sh' via adb!)
    4:49p Nandroid + ext backup + .android_secure (Error MSG : run 'nandroid-mobiel.sh' via adb!)

    BTW: On all the other posts I made about this I never once tried the first two... so go figure. If anyone else runs into this... try the first two and if you feel saucey attempt the others and see if you get the same results. If anyone knows what the differences are between the backups please do tell so all knows if this is a priority or not.
  13. cuttingedge110

    cuttingedge110 Well-Known Member

    Thanks so much. Keep up the great work. If you need help with anything I'm more than willing to do what I can.
  14. Deeeepimpact

    Deeeepimpact Member

    Anyone else having problems when trying to mount /sd-ext after partitioning sdcard? I get an error "E:Can't mount /dev/block/mmcblk0p2 (No such device)
  15. alexxseven

    alexxseven Well-Known Member

    well i've had that issue too but for all the options. im not sure exactly the diff in them but i know it has to do with how much info is saved into the backups.

    i did however get a nand backup in adb when connecting my phone to the pc.

    all i did was type "adb shell" then "nandroid-mobile.sh" plus i thin it wanted me to add -b to the second input but it worked none the less. :)
  16. hav0kk

    hav0kk Well-Known Member

    I'm pretty sure the 3rd and 4th only work after you have created partitions which is why it errors out.
  17. andro1d5

    andro1d5 Well-Known Member

    Hey guys, where do I type

    Code (Text):
    1. Open up cmd and get adb shell to work
    2. After the adb shell command type: [COLOR=Red]su[/COLOR] to get root priviledges (the # symbol)
    3.  
    4. After the [COLOR=Red]#[/COLOR] symbol type:
    5.  
    6. # mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system
    7.  
    8. # cat /sdcard/flash_image > /system/bin/flash_image
    9.  
    10. # chmod 755 /system/bin/flash_image
    11.  
    12. # mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak
    13.  
    14. # mount -o remount,ro -t yaffs2 /dev/block/mtdblock5 /system
    15.  
    16. # flash_image recovery /sdcard/recovery-2.2.1-joneidy.img
    I type adb shell in the windows cmd and I get command not recognized?
    Where do I type adb shell? I dont have a terminal on my phone I just finished with the following post and dont have service http://androidforums.com/optimus-m-all-things-root/279318-root-2-2-1-get-data-working-4.html#post2500855
  18. andro1d5

    andro1d5 Well-Known Member

    Ok I got adb shell to work an I got the # sign. Once I enter the first command and hit enter the output it gives me is the same as the input? Is this ok?
    And the second command says No such file or directory?

    [​IMG]

    Uploaded with ImageShack.us
  19. pmb116

    pmb116 Well-Known Member

    Yes sir working as intended, pay no attention to the error and keep going with the steps. You're just about there!
  20. andro1d5

    andro1d5 Well-Known Member

    I just finished the whole process and tried to reboot but anreboot says "su is not available on my phone" I must have to do the whole process again?
  21. lordzaron

    lordzaron Member

    Did you possibly accidentally set AnReboot to deny in Superuser? I've done something similar before and was confused for a bit till I checked there :)
  22. andro1d5

    andro1d5 Well-Known Member

    When I got the service back Superuser was deleted I don't know why? I am still not root, Im going to start again and see what happens Thanks for your help:)
  23. Prime85

    Prime85 Well-Known Member

    Thanks Joinedy :D
  24. andro1d5

    andro1d5 Well-Known Member

    Thank you Joinedy :D I got it working!
  25. Prime85

    Prime85 Well-Known Member

    Just curious, is ext backup and .android_secure important? i tryed to run the option with all and i got Error :run 'nandroid-mobile.sh' via adb.

    just doing Nand backup alone worked perfectly.

    if the others arnt important i wont bother with it

    Its not from lack of space on Sdcard since i have 14Gb free
Loading...

Share This Page