Finally Custom Recovery for 2.2.1 stock phones !!!!!!


  1. new optimus

    new optimus Well-Known Member

    Seems what that means is you do not have the sd card formated to ext
    So no its not important.
    You do not need it formated to ext however some are working on a way to format part of the card to linx style ext2 and ext3 filesystem to allow the phone to use part of the card for internal memory. And virtual memory.
    hav0kk and Prime85 like this.
  2. hav0kk

    hav0kk Well-Known Member


    good question and one i'm also interested in. the more information the better
  3. El Gatez

    El Gatez New Member

    Hey guys,
    I just rooted fine following the directions provided but I can not seem to have the ability to finalize the custom backup..... it errors out stating mtd: not writing bad block at 0x00220000, error closing recovery: no space left on device.....??? i have 54mb's free? Please see pic, I have shut down devices on numerous attempts and pulled battery as well... what am I doing wrong, please assist. The files are extracted at the root of my sd card with 854mb avail.

    Attached Files:

  4. jabbawest

    jabbawest Well-Known Member

    hav0kk, I'm kinda in the same boat.
    I rooted my stock v2.2.1 prior to seeing this thread so I flashed thunder recovery.
    I'd like to flash joneidy's custom recovery and wondered if you'd share how you removed thunder recovery.

    Thanks
  5. joneidy

    joneidy Well-Known Member

    You can just flash my recovery on top of the other. It would work with no errors :)
    jabbawest likes this.
  6. jabbawest

    jabbawest Well-Known Member

    Woo Hoo!
    Thank you for the response joneidy.

    Adding that tid bit, along with a few hundred others, to my Android data repository.
  7. joneidy

    joneidy Well-Known Member

    Your welcome Bro :)
  8. Odis

    Odis Member

    Workx great! Thanks!
  9. jabbawest

    jabbawest Well-Known Member

    I went through the entire rooting process of a second phone without a hitch until I tried to flash the custom recovery img
    I keep getting this error:

    flash_image recovery /sdcard/recovery-2.2.1-joneidy.img
    flash_image: permission denied
  10. joneidy

    joneidy Well-Known Member

    First make sure you get # then make sure that you pushed flash_image. Heres the command
    Code (Text):
    1. # mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system
    2.  
    3. # cat /sdcard/flash_image > /system/bin/flash_image
    4.  
    5. # chmod 755 /system/bin/flash_image
    6.  
    7. # mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak
    8.  
    9. # mount -o remount,ro -t yaffs2 /dev/block/mtdblock5 /system
    10.  
    11. # flash_image recovery /sdcard/recovery-2.2.1-joneidy.img
    And reboot after it just to make sure.

    Hope it helps
  11. puyow18

    puyow18 Well-Known Member

    jabbawest - you need to go back one step to "toggle signature verify"; hit enter and at the bottom it will say "verification disabled". then try flashing again and all should run smoothly.
  12. jabbawest

    jabbawest Well-Known Member

    # toggle signature verify
    toggle signature verify
    toggle: not found

    Is is safe to start this over?
    Frankly, I'm considering the thunder recovery just to get data back and then proceed with trying to flashing joneidy's recovery.
  13. jabbawest

    jabbawest Well-Known Member

    Nevermind, I missed one important command.
    chmod 755 /system/bin/flash_image

    After receiving permission denied I thought it had to do with RW permissions and sure nuff, I complete missed that one command.
    WAY too much coffee this morning.

    Thanks guys!
  14. Armored_Suit

    Armored_Suit New Member

    I'm having an issue. No matter how many times I edit the "environmental variables" to the C:/android-sdk-windows/platform-tools
    I always get "error: device not found"

    My phone is plugged in. I've tried it with the usb storage activated and deactivated.

    I am using admin privileges on CMD prompt.
    I'll even manually change the location to look for "adb shell" into the C:/android-sdk...etc location and it still gets the same error.

    What am I doing wrong? My phone is flashed. But my service is goneeee. I'm pretty upset. I just thought I could get rid of bloatware and be on my merry way. But apparently you need to be a comp whiz to do everything without effing up. :/

    Anyway.
    I have recovery and flash 2.2.1 file in the root directory for the phone. Maybe it's stuck only in the sd root? Idk. I can only open the drive when it's in storage mode. Otherwise it comes up transparent.

    I don't get the
    $ su
    #

    and everyone who gets the answer never seems to fully explain how they did it... It's pretty frustrating.
  15. joneidy

    joneidy Well-Known Member

    OK check you Personal Messages.
    acerl likes this.
  16. Armored_Suit

    Armored_Suit New Member

    I really appreciate all of your help. :)
    You're awesome! ^_^
    YAY NEW ROOTED PHONE!
    No bloatware/adware and customizable stuff. >:D
  17. acerl

    acerl New Member

    NICE :D
    I'll be trying it on
    my old Android 2.2.1
    phone!
  18. paintballer24

    paintballer24 Active Member

    @joneidy,dude everything you have on here works 100% ive installed all the roms and i must say sir; YOU ARE A GOD THANKS ALOT FOR EVERYTHING,KEEP UP THE GOOD WORK :)
  19. lflores6231

    lflores6231 Member

    everything was smooth but the # does not apear so i am stuck here, my phone has no service i type adb shell on the CMD nd a "$" comes up then i type su nd the "#" never apeers if u could help pls
  20. blaxican25

    blaxican25 Well-Known Member

    lflores6231 did you ever get service back?
  21. lflores6231

    lflores6231 Member


    no i have not gotten service:confused:
  22. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

  23. eddie68000

    eddie68000 Member

    How did you get the "#" sign. After i punch in adb shell i get a "$" sign.
  24. blaxican25

    blaxican25 Well-Known Member

    after adb shell hit enter then su enter
  25. eddie68000

    eddie68000 Member

    I did. It read permission denied then gives me the $ dollar sign. I am running it under the cd C:\android-sdk-windows\platform-tools. Then i punch in adb shell. then su then it give me the "permission denised" then it returns to the "$" sign.
Loading...

Share This Page