Finally Custom Recovery for 2.2.1 stock phones !!!!!!


  1. blaxican25

    blaxican25 Well-Known Member

    if your running the commands like this cd C:\android-sdk-windows\platform-tools make sure it's like that in environmental variables and reboot your pc
  2. eddie68000

    eddie68000 Member

    By "environmental variables" you mean that i should make sure that the folder and files i am trying to access are in correct locations?
  3. jabbawest

    jabbawest Well-Known Member

    When you type su, you've have to watch your phones screen because Super User will pop up and you need to hit Allow.

    C:\android-sdk-windows\platform-tools>adb shell
    $ su
    su
    Permission denied (Make sure your screen is on so you can let SU allow, then you'll get the # and not Permission Denied)
    $ su
    su
    #
  4. tlfaughn

    tlfaughn New Member

    when i type "flash_image recovery /sdcard/recovery-2.2.1-joneidy.img" it gives me a message saying "failed to link flash_image CANNOT LINK EXECUTABLE"...PLEASE HELP ME WITH THIS...THIS A GREAT TUTORIAL BTW! THANKS IN ADVANCE!!
  5. zhillz

    zhillz Member

    So when I type in cd C:\android-sdk-windows\platform-tools and hit enter it just pops up again? Is this correct?

    When I type "su" it has an error
  6. rbruce25

    rbruce25 Member

    Hello everyone I am new to this board, and just would like to thank everyone for the support they have put up here, you guys rock. If you need donations please just post to me I can PayPal the donation immediately.

    Okay I have no concerns, I have "rooted" my phone, removed all bloatware, partitioned my 32GB card ( swap=512, ext3=1024, fat32=remaining), move all application in the /data folder on the "sdcard", and have gotten rid of the low memory error for good. I always have 115MB of internal memory no matter how much I download and install apps.

    By the way all new phones from MetroPCS (the LG Series) ship with Andriod 2.2.1 and z4root130.apk willnot work, use GingerBreak-v1.20.apk for all 2.2.1 phones,

    DO NOT TRY
    z4root130.apk it will muck up the phone.

    You will only need this software (GingerBreak, Root Explorer and Terminal) all can be gotten from the app@store, or market, if you need the files post to me and I will give you access to my FTP and you may download them from there.

    Besides that the stock phone is okay but limited. My new rooted, custom phone rocks. I have been able to make my phone a mobile hotspot for my laptop, so when I connect to a WiFi network I can share that connection with other devices. Does not work with the MetroPCS 1xRTT connection as of yet but anyway it is to slow usually 100Kbps to 200Kbps at max generally around 117Kbps or 2 time dialup at best. But that is one reason I bought this phone because I can use Wifi as well as the mobile network at the same time, I can be on a call and surf the internet without dropping a heartbeat.

    I was able to update everything from these postings, and everything worked as laid out. I love this phone, I had the Samsung Caliber and that phone sucked royal. Was going to get the Craft, but I found that the craft is a want-ta-be smartphone.

    Thanks and remember post for donations and or FTP for newbies who need software to root phone.

    Robert
  7. new optimus

    new optimus Well-Known Member

    Hi I would like to point out that having a swap is not always a good thing, I believe the consensus on that is no swap. Other then that looks very good.
  8. rbruce25

    rbruce25 Member

    I know there has been some debate, but for me it works, it maybe for now, and later the consensus might be correct and it will cause me issues. I have tried with swap and without and with swap works better for my application of the phone. So maybe I should have stated that.

    Correction to Last Post

    ( I have 2 - 32GB card ) that I inter change for testing, and the one with swap seems to work better for me in the way I am using the phone. So for all readers go with the consensus and don't add a swap.

    Robert
  9. ginji_ban07

    ginji_ban07 Active Member

    ok so I got to the point of android system recovery
    with

    with all those stuff on that picture... so what's next? Backup/restore?
  10. ClarkeGable

    ClarkeGable Member

    Joneidy, between you and a couple of other guys, all of your advice has not led me wrong, after using this tutorial (I did it all through the terminal, for some reason, the SDK just didn't work right, it seemed to want to accept the commands before I was done typing them...?) but, regardless, rooted thanks to blaxicans' tutorial, and now recovered with this tutorial, and about to get flashed with the sense ui!
    Thank you again, this is where I will be sending all of my friends, regardless of phone type!
    You guys rock!
  11. ClarkeGable

    ClarkeGable Member

    Update:
    Round 2, my lady's Phone, thought I bricked it because I forgot to wipe before flash. ADB console commands not working until I used my AMAZING POWERS OF OBSERVATION and noticed you had included a couple commands. Badda bing badda boom, back to recovery, and reflashed. An hour of fearing the proverbial 'doghouse' and about 15 minutes of work and Sense UI is up and running. Thanks! Again!
  12. buc813

    buc813 Member

    keep on getting installation abort???? any help
  13. ginji_ban07

    ginji_ban07 Active Member

    ok so I installed this and I'm going to return my phone because the crashes won't stop so is there anyway to uninstall this? I already unrooted and stuff and this is the only one that I can't remove. what should I do?
  14. teh_dude

    teh_dude Well-Known Member

    As another item to add to my arsenal of stuff to be able to revert back to stock, does anyone know how I might at some point, if I wanted to, be able to put the original recovery back on the phone? You know, the one that doesn't let you play with anything? Seems to me if I wanted to, I would first use custom recovery to put the stock rom back on. beyond that, would using LGNPST change EVERYTHING back, or would I need to find flash_image and a *.img to reinstall the stock recovery rom?

    EDIT: found this other thread for the LG ally that seems to provide a perfect answer....except not for the MS690. http://androidforums.com/ally-all-things-root/183854-how-flash-stock-recovery.html

    so the answer to my question seems to be getting a copy of the original recovery to flash onto the phone. However that opens up the next question: Unless there's another method, where can I find a copy of the original recovery?
  15. Manbot

    Manbot New Member

    Yes this finally worked for me!
  16. jabbawest

    jabbawest Well-Known Member

    I PMed you a link for a copy of Metro Stock. Within that you will find the original Recovery image.

  17. v_purrrr

    v_purrrr New Member

    Thanks so much boys! I had a bit of technical difficulties at first, but i successfully rooted and restored service to my phone. I shat brix for awhile, but I read through everything carefully and was able to pull it off. Thanks so much to everyone. Especially Joneidy!
  18. lyubimov

    lyubimov Active Member

    I have the same exact problem:( only difference is that I got bad block at 0x00080000
    Could someone help please!
  19. jabbawest

    jabbawest Well-Known Member

    IF you actually have a bad block on the NAND this is a physical problem that is not correctable. It's a similar error that we are use to seeing on hard drives where a sector of the disk is bad.
    The first suggestion I have is to continue trying to flash recovery, you might get lucky and it will eventually bypass or ignore the bad block.

    If the above suggestion doesn't work, you really should consider unrooting and then returning the phone because this is a problem that will not resolve itself.
  20. lyubimov

    lyubimov Active Member

    I was thinking the same thing. Unfortunately, in order to unroot it I am gonna need to unbrick it first :(
  21. FallOutNerd

    FallOutNerd Well-Known Member

    when I try flash_image recovery /sdcard/recoveryimage.img img is not found

    when I try this method
    # cat /sdcard/flash_image > /system/bin/flash_image

    After I enter this command, it reads:

    "cannot create . . . read only file system."
  22. jabbawest

    jabbawest Well-Known Member

    Is it possible you may have missed a command?

    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system

    # cat /sdcard/flash_image > /system/bin/flash_image

    # chmod 755 /system/bin/flash_image

    # mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak

    # mount -o remount,ro -t yaffs2 /dev/block/mtdblock5 /system

    # flash_image recovery /sdcard/recovery-2.2.1-joneidy.img
  23. FallOutNerd

    FallOutNerd Well-Known Member

    ALL my problems have been solved. Now running the Sense ROM. THANK YOU to everyone who helped me, and special thanks to joneidy for the ROM.
  24. pr1ncpanda

    pr1ncpanda Member

    After the # symbol type:

    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system

    # cat /sdcard/flash_image > /system/bin/flash_image

    # chmod 755 /system/bin/flash_image

    # mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak

    # mount -o remount,ro -t yaffs2 /dev/block/mtdblock5 /system

    # flash_image recovery /sdcard/recovery-2.2.1-joneidy.img

    after the bolded command i get a message No such file or directory... I disregarded assuming it worked the same as mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak...but it each time after completion i get the stock recovery system not the custom...hoping to get some help please...thx ^^
  25. pmb116

    pmb116 Well-Known Member



    Shot in the dark but are you typing the # symbol because you. Dont

Share This Page