Finally rooted M865c for Straight Talk


Last Updated:

  1. The MC

    The MC Member

    If you are like me you have been searching for a way to root the Huawei Ascend ii for Tracfone / Straight Talk networks. Well my friends, wait no longer, thanks to the genius of giantpune. His exploit also works on the M865c.
    Here is the link to his original thread.
    Note: While this method should not cause any damage to your phone, I cannot be held responsible for any damages incurred. By rooting your phone you are taking full responsibility for any changes you make.


    Step 1:
    Download the Poot.apk and place it somewhere on you phone, internal storage or sd card, either will work.
    Download Poot-debug.apk from Sendspace.com - send big files the easy way
    (This is the One Touch 910 /ARM5 link on giantpune's thread)

    Step 2:
    Download the ministro-ii.apk and place it somewhere on your phone.
    http://androidforums.com/attachments/elite-all-things-root/38892d1346912490-optimus-elite-root-apk-ministro-ii.apk
    (Again, this is a link from giantpune's thread.)

    Step 3:
    Install both the Poot.apk and ministro-ii.apk. (You will need to make sure that you have enabled "Unknown Sources" under the application settings menu of your phone before you will be able to install these apks.)

    Step 4:
    After both apks are installed open Poot. It will open up ministro and download quite a few libraries that are necessary for the Poot to work. Once it has completed click the button that says "Press here to poot" and hope for the best.

    Step 5:
    Pay attention the the messages displayed on the screen. Most messages should start with a [+], but you should see a couple of [-].
    As long as the only warning messages you receive are the following, you should have successfully rooted.

    [-]current && current != last + 1: 0000ffff 0000ffff
    [-]Haxx has run its coarse. Reboot the device to play again
    A demon materialized while pooting. Error code: 64

    You will receive these messages because Poot does not recognize the M865c kernel and is unable to clean things up without rebooting.
    Again, the three warnings listed above are nothing to worry about.


    Step 6:
    Reboot your phone to save changes and allow the exploit to take effect.

    Step 7:
    Open Poot and click on the button that says Built-in rootcheck to verify that your phone is rooted. As long as Poot is able to find 'su,' and it will display its path along with a corresponding message stating success.

    Step 8:
    Install the superuser app from the google play store. This app is necessary to run other apps as root.

    Step 9:
    You can now uninstall Poot and ministro, if you like. This should save you a little bit of space since the M865c has limited internal storage.

    Step 10:
    Thank giantpune for all of his work and consider donating to him because he did all of the work on this. I am only detailing my experience, he deserves all of the credit.

    Advertisement
    shonda, DarkShadowsX5, foszz and 12 others like this.
  2. The MC

    The MC Member

    Now that you have successfully rooted your phone, you probably want to flash a new rom without all of the annoying bloatware and unwanted apps. I wanted to share my experience thus far. It appears that most roms built for the M865 will work on the M865c. Here are my suggestions.

    1. Install Rom Manager
      Rom manager is an app that can be found in the Google Play Store. It allows you to manage roms and flash them. Some of the advanced features require the paid version, but are not required. (Unfortunately, the option to install a rom from within the app doesn't seem to work on this phone, so you will have to do it manually as outlined below.)
      [*]Install ClockworkMod Recovery
      Open Rom Manager and Select "Flash ClockworkMod Recovery" to install the recovery version for the Huawei Ascend ii M865. (This is for the generic M865, but does seem to work for the M865c)
      [*]Reboot Into Recovery
      Once the new Recovery is installed choose the option to "Reboot into Recovery." This can also me done by holding the volume up (vol. +) button while you hold the power button to turn the phone on.
      [*]Create a a Backup
      While in the recovery use the volume keys to navigate up and down and the power button to select your choice. Select the "Backup and Restore" option. Follow the prompts to create a backup that you will be able to flash in case one of the other roms doesn't work and causes a boot loop.
      [*]Download a new Rom
      Although there a limited number of roms available for the M865, I have found the best place to find roms is over at unleashedprepaids. Here is the forum with all a list of roms for the M865.
      ROMs
      Make sure you have saved the zip for the rom on your sdcard.
      [*]Reboot Into Recovery
      Boot into recovery again and perform the following wipes.
      --wipe data/factory reset
      --wipe cache
      --wipe davlik cache (this can be found after selecting advanced)
      [*]Flash the new Rom
      Now you are ready to flash the new rom. From the recovery menu select the "Install zip from sdcard" option. Follow the prompts and choose the zip that you want to install. Follow any specific instructions from the rom's dev.
      Reboot and enjoy your custom rom.

    Again, in the very rare case that something happens to your phone, you are fully responsible for any damages made to your phone.
    Daniel Smith19 and digimux like this.
  3. eomer000

    eomer000 Member

    I tried flashing CMW Recovery using ROM manager and it killed my recovery, I can still boot the phone okay, but I can't get into the recovery, I'll give it another try and maybe I'll try some of the custom recoveries. I'm glad to hear someone got it working though. I was afraid that the M865 and the M865C were different enough that ROMs and recoveries made for the M865 wouldn't work.
  4. The MC

    The MC Member

    Glad to hear that someone else has joined me in rooting this phone. That's awesome.
    Were you able to install the superuser app from the play store? I wasn't able to get Rom Manager to work properly until after I installed superuser or supersu. Are you receiving an error message, is the app crashing? Does rom manager show that any recovery is installed? Have you tried rebooting into recovery from the rom manager app?

    One other thought, you could try downloading the recovery manually from the clockworkmod site. Not sure it would make a difference, but here's a link.
    http://download2.clockworkmod.com/recoveries/recovery-clockwork-4.0.1.5-ascend2.img
  5. Androte

    Androte New Member

    I just got finished rooting my phone myself and was experiencing the same issue with trying to root in recovery mode. I was messing around in the rom manager app trying to figure it out and decided to tap on the flash Clock Work Mod and flash Clock Work Mod touch features again then tried one more time to boot in recovery mode and it worked. Hope that this helps you out.
  6. allpcmacrepair

    allpcmacrepair New Member

    I would really like to know which rom you used? Is it fully functional? I am a little weary with this large selection you linked me to. Let me know which one worked for you on your 865C! Thanks for all of your help!
  7. The MC

    The MC Member

    This is actually my wife's phone and so I don't have it on me right now, but I tried a couple of different roms and I am fairly confident this is the one on the phone right now.
    ICS ASCENDED AND UNLEASHED

    The only issue she has noticed is a glitch with the voicemail. To listen to the voicemail she has to dial her phone number. I have a couple of hunches how to fix it, but haven't been able to get it back from her (she is too busy using her phone now since it isn't as slow and laggy)

    If I remember right, I also tried the duckmod and noticed some issues with making calls. I think it was just an issue with the build.prop. Regardless, I just flashed a new rom to check out the others.

    As long as you have a backup saved on your sd card and something goes wrong you can just use the recovery bring it back. Enjoy.
  8. The MC

    The MC Member

    If you do decide to use the rom that I linked to earlier, I do have a fix for the voicemail issue.
    You will need to edit the build.prop file, which if edited incorrectly would probably cause you to flash the rom again. It's not a big deal though, just gives you more practice flashing roms. :)

    Here is what I suggest:
    1. Install Rom Toolbox
      Download Rom Toolbox Lite from the Google Play Store. The free version is all you need. (This is also a great app if you want to overclock your cpu a little bit. It provides a safe method for overclocking.) Once installed open it up.
    2. Open Root Browser from Rom Toolbox
      From the main screen in Rom Toolbox scroll down to root browser. You may be prompted to install a few extra dependencies for root browser. Navigate to the system folder and then select the build.prop file.
    3. Edit build.prop
      Choose to edit the file and scroll about halfway down the file until you find the following line:
      ro.cdma.voicemail.number=*99
      Replace the *99 with your phone number. So, in other words, it might look like:
      ro.cdma.voicemail.number=5555555555
      Choose to save your changes and then exit out of the editor by pressing the back button.
    4. Test the voicemail
      Reboot you phone and then hold the 1 button to check your voicemail. (Note: It did not work for me the first time. I had to hang up and then try it again, but it has worked every time since.)
  9. PlayfulGod

    PlayfulGod Well-Known Member Developer

    fastboot not work on the m865c?
  10. The MC

    The MC Member

    Yeah, weirdest thing, no fastboot on the straight talk version. All of the cricket users seem to be able to boot into fastboot, but volume down doesn't work for us. I've tried every other combination on bootup without any luck; the only thing we can boot in to is recovery. I have been able to use fastboot on any other android I've had, but it seems to be missing on this one. I am able to use adb once the phone is running, but can't seem to find fastboot. If you have any ideas though, I am open for suggestions. It would be nice to have that as an additional backup.
  11. PlayfulGod

    PlayfulGod Well-Known Member Developer

    tried adb reboot bootloader?
  12. The MC

    The MC Member

    Yeah, I remember trying that but forgot what the results were, so I just tried it again. It boots into recovery instead of fastboot.
  13. phaedruscny

    phaedruscny Member

    I have a Straight Talk Huawei Ascend Y, model M866c. Tried this method to no avail using the One Touch 910 / ARM5 version of Poot. Any ideas on a workaround?
  14. The MC

    The MC Member

    Out of curiousity have you checked the other apks from giantpunes original post?
    http://androidforums.com/elite-all-things-root/612914-optimus-elite-root-apk.html

    There are two other apks that you could try. Although, I am not sure if the same exploit will work. You may need to contact giantpune directly.

    I honestly don't know what giantpune looks for to know what phones this exploit works on, but I know he asks for the output of "ls -l /dev" when connected via adb.

    Is this your phone?
    http://www.phonearena.com/phones/Huawei-Ascend-Y_id7549
    phaedruscny likes this.
  15. phaedruscny

    phaedruscny Member

    Yes, that is the phone.

    I tried both of the other .apk files. No luck, kept getting error code: 87. I suppose I will try to message him directly with all the applicable info and go from there. But thanks for the quick reply.
  16. eomer000

    eomer000 Member

    Well I got it working. I tried re-flashing CWM Recovery but it still didn't work, what I finally did before it started working was go into the settings of ROM Manager (menu button - Settings) and selecting the "Erase Recovery" option, this erases the old recovery before writing the new one.
    I was also able to flash the CM7 Ultimate ROM. It's working great so far, but I don't really do anything with the cell end of this thing so I haven't tested any calling, texting or anything like that.
  17. digimux

    digimux New Member

    this my help sine i had to do this. my phone was acting weird not letting me do anything since it force close the android keypad on start up. it was working when i was trying to root but the force close has been happening before so this root is not the problem. but the force close didn't leave me a choice but hard reset my phone.
    -hard reset
    -Installed Poot and ministro and the binary's
    -attempt to root
    -installed superuser
    -turn off phone then back on
    -installed a root checker
    this is the only way it work for me im using
    straight talk hawei Ascend 2 2.3.6 m865c
    now i can have this phone rooted :) lol
  18. revenantx3

    revenantx3 New Member

    I'm new here, and I've read a lot of articles and information, where I don't quite get all of the info. I just had a few questions, in relation to this...

    Firstly, if I wanted to go back from rooting, the OS (2.3.6) is all I need to have on the phone to make it work with Straight Talk? There's no basic package that I'd need to put on the phone to tell it to connect to the Straight Talk towers, and not Crickets, for instance?

    Second, as far as roms go, some of them are working effectively, and some not? I do normally use the phone section of my telephone, so a rom that has working texting, calling, voicemail, etc is pretty much needed. But I rooted for my Ram issues, for the fact I heard there was a dev-made video driver update to the chip, and because I wanted to enable dualtouch. I can only pick one rom at a time?

    And finally if I root the phone, should I copy and paste the entire contents of the internal memory and the external memory to a folder on my computer? I don't want to lose my texts, videos and pictures, or whatever contacts may have somehow found their way onto the phone and not onto Gmail like I usually sync them with. I just want to know if there's any kind of backup I could do to literally return the phone to the way I have it right now, or if I'd have to blow it all away and reinstall from stock so to speak?
  19. kennethk

    kennethk New Member

    Hi, is this still valid for Android 2.3.6?
  20. The MC

    The MC Member

    Rooting the phone does not actually change any of the wireless settings. All it does is enable superuser privileges, which on any linux based device allows you to have elevated privileges so that you can run additional commands and aren't restricted to the default settings. As far as going back, it can be as easy as removing the su binary and superuser app if you haven't made any major changes, but this hasn't been tried on the m865c yet since we just recently rooted it. Not to mention the fact that we don't have access to fastboo. However, I would recommend making a backup using clockworkmod.

    You can use the stock rom while rooted and not have to worry about anything. Just install something like romtoolbox lite from the google play store, which will allow you to safely tweak a lot of your settings including apps2sd.


    As mentioned before I would make a backup using the clockworkmod recovery; you can install it following the directions in the second post. It basically takes a snapshot of your system, apps, settings, etc. and saves it on you sdcard. Also, it would hurt to copy any documents or files from your sd card to your computer just to be safe. I also have used sms backup to backup texts if you want to keep them.
    revenantx3 likes this.
  21. The MC

    The MC Member

    Yeah, I was on 2.3.6 when I used it.
  22. revenantx3

    revenantx3 New Member

    Awesome! Thanks for the detailed reply, I couldn't find a systematic breakdown of what exactly was fair game and what wasn't. Thanks also to KennethK for asking if it works on 2.3.6, also. I appreciate the help! I'll be trying to root it tonight. Happy Thanksgiving!
  23. Dragnous

    Dragnous Member

    Thank you for the help on this however i am having an issue. No matter what i try the phone will not boot into recovery.
  24. revenantx3

    revenantx3 New Member


    Same here, and now, the phone constantly reboots. It will not start, nor enter into the shell, it just repeatedly reboots the phone. I have tried holding volume down and power, volume up and power, and holding a menu key also. I can't get the phone started, if anyone can help I would appreciate it.




    Fixed it, apparently I left the battery out and had to reset it by putting it back in and waiting for another reboot.

    I can get it into CMR, but nothing else.
  25. revenantx3

    revenantx3 New Member

    Also, is there any roms for the Straight Talk Ascend 2 (M865c) that anyone can reccomend works on theirs? I'm up to the point to where a rom would help. I'd really like to unlock multitouch on my phone, and improve ram performance.

    I'm currently looking at this one.
    CM9 HAWEI ASCEND 2 M865

    But I'm wondering if it'll be what I'd like since the most recent version is just getting bluetooth activated.

    No suggestions?

Share This Page