1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

Firmware confusion... And a new issue!

Last Updated:

  1. XanGabriel

    XanGabriel New Member

    Here we go again... *facepalm I've grown more accustomed to working on the lucid 2, but overall, I'm still no where near as tech savvy as I could wish... Primarily with the ADB interface, but I suppose I'll get to that in a second.

    I was getting rid of some of the embedded apps on my phone and lo and behold, I got rid of one that brought the brick upon me. This was my opportunity to pursue flashing VS87010A onto the device so that I could utilize the loki modded kernel and get rid of those apps the CORRECT way >,<

    Well, I didn't pay enough mind (as usual) and I flashed VS87011A. Since then, I've been completely in the dark as to how to re-root the phone. The OUDHS root tool for the spirit listed in the stickies did nothing, motochopper did nothing (the console states that the commands "cannot 'stat'". No such file or directory as "busybox", "su", "Superuser.apk" etcetcetc. It also states it's "unable to chmod" any of the directory commands... The batch is being run as admin in W7x64... I was able to root the VS87010B on the first stab before, so I flashed VS87010B back onto the phone... Here's the kicker:
    Emergency/Download mode states in the corner that the phone is already rooted. Root checker app states the phone isn't rooted right. Busybox installer (which is consistently failing with any version I attempt to install) says that the phone is rooted. ROM Toolbox states it can't get root access. Superuser installed from Play Store doesn't do anything at all! LoL Confused yet? I know I am.
    Between every FW flash, I've done factory/hard resets, "recovery mode" resets (little android with the wireframe sphere). I'm pretty much at a loss as to what I messed up, much less how to fix it.

    So here's the run down:
    • The rooting consoles find the phone and everything, but keep giving me essentially invalid command responses
    • Emergency mode and busybox installer state the phone is rooted
    • Root checker states the phone isn't rooted properly and ROM Toolbox fails to obtain root access

    Debug mode is on, I've tried the MTP, Internet (Ethernet/Modem) USB conns... nothing is working >,<

    Is this familiar to anyone? I truly have no clue where to go to correct this thing back to full root status... I'm currently sitting on a very confused Lucid 2 wearing VS87010B. I'm thinking that MAYBE my answer lies in utilizing the ADB in some way, but I'm not sure exactly what to do or how to use it. I'm hoping someone can shed some light on what is to be done here...

    Thank you in advance for putting up with this, and for any light you can shed upon my case.
    Also, thank you to this community for all the pushing you're doing to get the development toward a less limited Lucid 2 unit...

    PS Attached is the screencap of the root console.

    Attached Files:

  2. XanGabriel

    XanGabriel New Member

    It appears I may have it narrowed down to the su binaries not being installed on my device properly? Yet it's still read as being rooted? How might I install them? Everything I've found points to utilizing supersu and busybox, but I can't even get busybox to install....?

    Edit/Update: After some scrounging, I found a trail that ultimately led to the fix I needed!! If anyone else has had my issue like this, give this a shot; there is an apk called Framaroot that gives you the options of cleaning/unrooting, installing superuser with the su binary, or installing supersu with the su binary. It does so with the choice of 2 exploits, one called Aragorn, the other being Gandalf.
    I selected to install Supersu via gandalf exploit... and it worked! Busybox installed, supersu controls accesses, rom toolbox gains root access...!

    I hope maybe by this I've helped guide someone now or in the future to a fix for this or a similar issue. The Lucid 2 isn't listed in the compatibility lists... I need to let the dev know it works..!

    Edit/Update 2: Not sure if this was supposed to go into the actual kernel thread or not, I wasn't sure if maybe I'd be crossing any lines of irritability (seeing as to how it's gone back and forth about discrepancies...)... So I figured it'd be just as applicable in this trainwreck of a scenario!
    I applied GT's modded kernel to my VS87010B, and proceeded to remove amazon, google, and VZW apps ... Success! There were comments about how some said it DID work on B, and others said it didn't... Perhaps it has something to do with what version of the su binaries is applied to the device? I'm not certain how to check the details on such, bu seeing as to how I had to jump through a couple rings my phone laid out for me, I may have a slight variation from the root tools form....????
  3. hkbladelawhk

    hkbladelawhk Active Member

  4. Nikguy

    Nikguy Well-Known Member

  5. lgrootnoob

    lgrootnoob Well-Known Member

    I fixed this problem.

Share This Page