1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

firmware malfunction


  1. pplatz87

    pplatz87 Member

    I have an HTC Sensation 4g for T-mobile. I was running Cyanogenmod 7 (update-cm-7.1.0-SelfKANG10-Sensation-signed). I wanted ICS so I restored to my backup and factory reset. I could not update to ICS because my phone was rooted S-OFF. I decided to try Android Revolution HD. I read everything on the home page. I followed the instructions and attempted to update firmware. This was not successful. It is now stuck in a boot loop. When I enter the bootloader, it does not wait for me to make any selections and gives me the following error:
    HBOOT - SD Checking... Loading...[PG58DIAG.zip] No image! Loading... [PG58DIAG.nbh] No image or wrong image! Loading...[PG58IMG.zip]
    Then, HBOOT CID incorrect! Update Fail! Press <power> to reboot.
    When I remove the SD card, I can enter Clockwork Recovery. From there I reinserted the sd card and attempted to update the firmware. This was unsuccessful. After this did not work, I used Clockwork to run the SUPER_WIPE and this completed successfully. I installed Android_Revolution_HD-Sensation_6.6.5_XE using Clockwork. Then it would boot, but after it made it to the unlock screen and I unlocked it, it would freeze and restart.
    I am hoping to return this phone to some working order. Thanks for the assistance.

    Advertisement
    :
  2. scotty85

    scotty85 Guides Guide

    You have a couple options:

    1)superCID your phone so that firmware will flash.

    2)just run the the ruu for t mobile ics. This will get you ics compatible firmware. You can then reinstall recovery and reflash your Rom.
  3. yahhboy

    yahhboy Well-Known Member

    Firmware is updated from bootloader not recovery, as above poster said use T-Mobile firmware or supercid from fastboot
  4. pplatz87

    pplatz87 Member

    I found a guide to supercid, but I can't find the files I need. The site they all point to isn't responding. I can't post any links

    When I tried to update firmware with bootloader, I received the error

    Can I update the firmware from my PC? that's how I updated the radio

    Thanks for the help
  5. yahhboy

    yahhboy Well-Known Member

    You're getting an error because there is a cid mismatch, that it why you need to supercid or find the T-Mobile firmware.
    I'd post the fastboot drivers but I'm on my phone. Try rootzwiki if its not working out for you on xda.
    If you want to update through computer you could use a ruu. You'd have to be sure to flash the correct one for tmobile, however it will put you on stock ics and recovery, also it will wipe everything.


    Personally id update firmware using the correct tmobile one then flash an ics Rom right afterwards. Then later you could try and supercid.
  6. scotty85

    scotty85 Guides Guide

    I.can post some links in a couple hours,but I'm on my phone as.well.

    If you're anxious,the ics .exe is linked in the thread below(I tried to.root.my phone,but....)

    You'll need to.start it with your phone in fastboot if it.won't boot
  7. scotty85

    scotty85 Guides Guide

    ok,if you want to keep your t mobile CID,heres your firmware:
    PG58IMG_firmware_ICS_TMOUS_3.32.531.14_Radio_11.69A.3504.00U_11.23.3504.07_M2.zip
    md5: 625fba1e56a49bfcb56b65fa22b69828


    *please double check your md5s. a bad radio or hboot flash can permanetly brick your device,and the firmware files contain both.

    download,rename PG58IMG and flash in hboot. that should get your current rom booting and functional. note that if you need to go back to GB,you cannot,without restoring GB firmware.

    gingerbread firmware:
    PG58IMG-firmware-for-1.50.531.1.zip
    md5: 609e5fea7661f884bcbba57631d4d50e


    if you wish to superCID:

    download this:
    mini-adb.zip
    it contains adb,fastboot and an md5sums utility

    -extract it,place the unzipped folder on the root of your C drive

    -open a cmd window(win 7,clock start button,type "command" or "cmd" in search box)

    -change to mini-adb directory by typing,or copy/paste in the cmd window:
    cd c:\mini-adb you should see your promt change to c:\mini-adb>

    -place phone in charge only mode,plug in(im assuming you have rooted via revolutinary and have drivers.if not use revolutioary drivers)

    -in cmd:
    adb devices

    -if you get your serial number back,boot to bootloader:
    adb reboot bootloader

    -check for connectivity
    fastboot devices

    -if you get a serial number back,check your cid first,in case you want to restore it later
    fastboot getvar cid
    or
    fastboot getvar all (will return other variables as well :))

    -change CID
    fastboot oem writecid 11111111 (eight ones)

    -reboot bootloader
    fastboot reboot-bootloader

    -check CID again
    fastboot getvar cid
    or
    fastboot getvar all

    -verify CID=11111111

    -reboot
    fastboot reboot
    raklm and pplatz87 like this.
  8. pplatz87

    pplatz87 Member

  9. pplatz87

    pplatz87 Member

    That information was fantastic. Exactly what I needed! Thanks for your help!
    scotty85 likes this.
  10. scotty85

    scotty85 Guides Guide

    awsome. glad it was helpful :)
Loading...

Share This Page