1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

firmware package update?General


Last Updated:

  1. cooldudezach

    cooldudezach Well-Known Member

    Joined:
    Jun 27, 2011
    Messages:
    556
    Likes Received:
    194
    The only error I have is 3g not connecting after the update, but that could very well be one of the issues I'm having with my account at the moment.

    The update is pretty stable. I might have 3g issues, but can't tell because I don't have the money to restart my plan which ended yesterday -_-
    I don't see many changes. So far the only noticeable change is that Google Magazines is now installed.

    So far, no consensus. If you can get the update to work after you root, the root does stay.

    Power off the phone, then hold Vol-Up(Vol-Down?) + Power button.
     

    Advertisement
    jae_63 likes this.
  2. SuppliedRelic

    SuppliedRelic Well-Known Member

    Joined:
    Feb 26, 2012
    Messages:
    76
    Likes Received:
    6
    Is it safe to apply the update via recovery with a rooted phone?
     
  3. db2

    db2 Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    258
    Likes Received:
    54
    That's not how it works, stock recovery is useless for anything but wiping data.
     
  4. SuppliedRelic

    SuppliedRelic Well-Known Member

    Joined:
    Feb 26, 2012
    Messages:
    76
    Likes Received:
    6
    That sucks
     
  5. lostinmemory

    lostinmemory New Member

    Joined:
    Feb 9, 2013
    Messages:
    1
    Likes Received:
    1
    I was rooted before the update and I'm still rooted after. I haven't had any problems with the phone or the update. All of my system apps are still on the phone (Activate, Live, etc.) I only rooted so I could use adaway. I can also confirm that this fixes the USSD vulnerability. Overall, the phone feels a little snappier and more stable. This gives me hope for an eventual Jelly Bean update.
     
    SuppliedRelic likes this.
  6. sethseth

    sethseth Member

    Joined:
    May 27, 2012
    Messages:
    6
    Likes Received:
    0
    HEY GUISE. I am new here. I updated my Rise today with that firmware update (I'm rooted) I have several rooted apps and I don't believe I've uninstalled any stock apps. It updated just fine. No problems except I get duplicate text messages now, which I posted a new thread for. So if you have any advice on that please answer or if you're having the problem.
     
  7. dibblebill

    dibblebill Well-Known Member

    Joined:
    Feb 21, 2012
    Messages:
    2,105
    Likes Received:
    355
    Mine still won't update... Maybe on my next rise (I have two)
     
  8. daffyducknj

    daffyducknj Well-Known Member

    Joined:
    May 24, 2012
    Messages:
    655
    Likes Received:
    196
    Mine's updated, but I can't root it... ARRR!!!! :mad: I tried Bin4ry's method... am contemplating doing a factory reset, but then I found the no PC method around here. Might try that later.
     
  9. LightyKD

    LightyKD Well-Known Member

    Joined:
    Feb 28, 2011
    Messages:
    72
    Likes Received:
    9

    Really? I was rooted but then the phone restarted and forced the update on me and now I dont have root access (even thou I can still navigate the root via my file browser) :(
     
  10. db2

    db2 Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    258
    Likes Received:
    54
    root as in / and root as in su are not the same thing.
     
  11. LightyKD

    LightyKD Well-Known Member

    Joined:
    Feb 28, 2011
    Messages:
    72
    Likes Received:
    9

    root as in su because both superuser and root checker are saying that I don't have proper root. Has anyone tried to root their device after the update?
     
  12. db2

    db2 Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    258
    Likes Received:
    54
    If you open Terminal Emulator and type 'su' does it work?
     
  13. sethseth

    sethseth Member

    Joined:
    May 27, 2012
    Messages:
    6
    Likes Received:
    0
    I just unrooted my phone and restored because I was fricking sick of getting double messages and no one could help me. It fixed the problem and I lost all my precios texts from friends. Now I can verify it will not root correctly with root with restore bin4ry or whatever it is. Root browser works, nothing else does that is a root app.
     
  14. Trevon360

    Trevon360 Well-Known Member

    Joined:
    Dec 28, 2012
    Messages:
    62
    Likes Received:
    3
  15. daffyducknj

    daffyducknj Well-Known Member

    Joined:
    May 24, 2012
    Messages:
    655
    Likes Received:
    196
    http://androidforums.com/rise-all-things-root/686996-new-root-method-no-pc.html

    Try this! Seriously, it does work. Guess maybe I should post some screen shots later, but in any case it works for me. Sorry to see that you lost your texts. That's never good. :( I tried Bin4ry's method first as well, until I stumbled across this new method. I was contemplating rooting the phone manually. For me, this has worked out really well.

    I've applied the egl tweak, and have overclocked the CPU to 1024 GHz using No Frills CPU CLASSIC. It's not possible to go any higher at the moment, as the kernels that the Rise uses don't support higher speeds. I don't really care at the moment, as the phone is so much more enjoyable and responsive to use after a few tweaks.

    :five:
     
  16. db2

    db2 Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    258
    Likes Received:
    54
    1.024 is stock speed, the biggest advantage of being able to control it is to set it to use the Conservative governor which should improve battery life.
     
  17. SuppliedRelic

    SuppliedRelic Well-Known Member

    Joined:
    Feb 26, 2012
    Messages:
    76
    Likes Received:
    6
    So you can confirm this root method works after updating?
     
  18. LightyKD

    LightyKD Well-Known Member

    Joined:
    Feb 28, 2011
    Messages:
    72
    Likes Received:
    9
    I can confirm that Superuser will say that you have Root access while your root checker will say that you do not have root... so yeah... im just as confused as anyone else because Poot gives me a daemon error.
     
  19. daffyducknj

    daffyducknj Well-Known Member

    Joined:
    May 24, 2012
    Messages:
    655
    Likes Received:
    196
  20. db2

    db2 Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    258
    Likes Received:
    54
    If su is in system/bin you may have to symlink it to /system/xbin too. Or the other way around. I had to do that on my TF101 to make sure all the root-capable apps could find su.
     
  21. LightyKD

    LightyKD Well-Known Member

    Joined:
    Feb 28, 2011
    Messages:
    72
    Likes Received:
    9
    do you think you could type down a quick tutorial. that would be super helpful!
     
  22. Trevon360

    Trevon360 Well-Known Member

    Joined:
    Dec 28, 2012
    Messages:
    62
    Likes Received:
    3
    https://www.youtube.com/watch?v=0HUt5inuVtc&feature=youtube_gdata_player
     
  23. db2

    db2 Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    258
    Likes Received:
    54
    You'll need to install Terminal Emulator from the Play Store.

    Open Terminal Emulator and type:
    su

    Superuser should ask for permission for it. If it doesn't come back and say so right off.

    Then type:
    ln -s /system/bin/su /system/xbin/su

    If that gives you an error about the target existing then do this one:
    ln -s /system/xbin/su /system/bin/su

    Then type exit twice to get out of Terminal Emulator.

    After that try to use a root app that failed before. It should work now.
     
    radford and sneaky_1 like this.
  24. SuppliedRelic

    SuppliedRelic Well-Known Member

    Joined:
    Feb 26, 2012
    Messages:
    76
    Likes Received:
    6
    I have successfully updated to the latest firmware and still have root access.
     
  25. Raymond_w3

    Raymond_w3 New Member

    Joined:
    Feb 17, 2013
    Messages:
    1
    Likes Received:
    1
    Okay, so I've never tried a root or anything but today when I restarted my phone it forced the update. Like sethseth mentioned I am getting duplicate text messages also. Anybody got a fix for this? It's pretty damn annoying
     
    Princess2313 likes this.

Share This Page

Loading...