1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

firmware update for samsung galaxy spica gt i5700Support


  1. faixan.6x

    faixan.6x Member

    i bought my spica past a week and it contains android version 1.5. many applications need update above 2.0. but when i use NPS or pc studio, i am not able to update firmware. can you guyz tell me the easy ways as how to update firmware to 2.0 for galaxy gt i5700.

    any answer appreciated.

    thanks in advance
    faizan

    Advertisement
    :
  2. surajkala

    surajkala Member

    i too want the same.. but i guess thier is no easy for upgrading to 2.1 .. u gotta be sort of LINUX GURU to do it .. Chances of breaking down ur phone is also high..

    Better wait for official upgrade .. Fingerscrossed
  3. mahipal007

    mahipal007 New Member

    i have seen websites posting pictures of unofficial rom of spica 2.1 but dont wann crash my phone still waiting for the official release let me also know if sumbody knowa anything
  4. ktom

    ktom Member

    Does anybody know where the update will be announced when it is released?
  5. andy-roid

    andy-roid Well-Known Member

  6. sasaboss

    sasaboss Member

    as far as i know, the official 2.1 update for the spica should come in april (not sure how it will be provided since new pc studio does not really work with this phone). In the meantime, you can google to find guides how to install the unofficial 2.1 rom on your spica.
  7. Sparx

    Sparx Member

    There is an unofficial method as detailed in this blog post.

    Of course, like most hacks, there are a few caveats and bugs. If it indeed is April when we get Android v2 and above on the Spica, then it isn't all that far away, is it ?
  8. lqtdc

    lqtdc New Member

  9. 28064212

    28064212 Well-Known Member

    And by official, you mean completely unofficial and not sanctioned by Samsung or Google in any way, right?
  10. andy-roid

    andy-roid Well-Known Member

    im going to wait for the official one
  11. svkndv

    svkndv Well-Known Member

    Any update on firmware availability? Nokia is connecting people... Samsung is disconnected with customer once they sell the piece. I am wondering what preventing them to announce the schedule so that customer need not to google everyday get the news....
  12. faixan.6x

    faixan.6x Member

    guys finally i got eclair working in my fone gt5700. it is obviously an unofficial way but pretty easy. just search for guide "how to update firmware of spica" n you can do it yourself. you have to download a firmware 2.1 of any choice of baseband version and a ODIN application. i guess least chances of bricking your fone. if you are not dumbest in the world then go for it. you can do it easily as i did. eclair is great and finally bluetooth works in my fone. feeling like nexus! hahhaha....
    any help regarding update, you can ask me. i will tell you exactly what to do.
  13. svkndv

    svkndv Well-Known Member

    News: Samsung has officially released the Android 2.1 update for Galaxy Spica. The update has been initially rolled out in Germany and will be released gradually in the rest of the regions.

    Source.. I5700 Galaxy Spica officially gets Android 2.1 | Samsung Hub

    Please confirm if it is available for your region
  14. faixan.6x

    faixan.6x Member

    i am from india and not atleast in here!
    i am on with unofficial one so no waiting anymore!
  15. Rheza

    Rheza New Member

    Hello...I'm from Indonesia..what exactly happen if we used the firmware for Europe in Asia?
    thanks for the answer
  16. gusto5

    gusto5 Well-Known Member

    We're playing the waiting game. Most of the european countries that should get this first haven't so it's probably not our turn yet. Meanwhile you could make sure your phone connects and is detected by NPS as "up to date" since there isn't a 2.1 update yet.
  17. Rheza

    Rheza New Member

    hmmm....The NPS is already Up To Date. I've got the latest samsung New PC Studio..The problem is, when i want to download the update firmware from the NPS, there's GT-I5700 in their gadget list to download the firmware..But i don't know why, the NPS don't want to start downloading..and say the device isn't suppoprted...
  18. gusto5

    gusto5 Well-Known Member

    So, to make sure we're on the same page:

    You run NPS. It detects that your phone is connected over USB as indicated by the icon on the top right mounted in an OSX-like visual. You then click on the triangle and go to "upgrade mobile phone" it then searches for an upgrade, finds it but then claims your device isn't supported?

    Also, are you running NPS 1.4 or 1.5? I've read in various situations in which versions of 1.4 won't support the phone properly

    If we're on the same page and you're on 1.5, then i don't have an answer or idea for you ;)
  19. faixan.6x

    faixan.6x Member

    the only difference between firmwares as per continent category is the language recognition in them. and english is default in almost in every one. so if you are good at english. you can update your phone with any firmware you wish.

    i have myself updated my phone with european version when i reside in ASIA(india).

    hope it will help!
  20. Rivisio

    Rivisio Member

    Where did you find the firmware/was is hard to install?
  21. ChicoG

    ChicoG New Member

    I've followed the procedure to install xxxxJCF - and I subsequently tried xxxxJD1 as well - and Odin seems to do exactly what it's supposed to do.

    But when the phone reboots I get the Triangle/Exclamation mark warning, and when I power off/on I get the Samsung logo and a progress bar, and when it hits the end it just hangs.

    Not just a few minutes, 20, 30, I've given up.

    Anyone got any advice they can offer?

    Cheers,
    Chico
  22. ChicoG

    ChicoG New Member

    *** UPDATE ***

    I finally managed to complete the update using the .tar and the .ops file from Message 29 in this thread:

    New FW I570EXXJD1

    Worked just fine, so if you have the same problem as me, stalling at the Samsung logo after flashing, try this out.

    Cheers,
    Chico (A very happy Chico I might add).
  23. Rivisio

    Rivisio Member

    What country are you from, I'm told people from USA/Canada have a greater chance to Brick their device.
  24. gusto5

    gusto5 Well-Known Member

    May I ask which individual told you this? Such a comment seems rather unwarranted since there is no logical reason to conclude North American phones have a greater chance to brick.

    As long as you follow the same procedure, everything should work out. For a North American user, since none of these firmwares are from a North American source, you will definitely need to take a few steps after reflashing, such as setting up your APN from your NA provider, since they will likely not be available in the firmware you flash over (use something like APN backup and restore for this).
  25. rainor94

    rainor94 Well-Known Member

    I am from Canada and my phone is Rogers (my service provider) branded. I really want to update my phone but when I go into the about screen on my phone the Model Number is: GT-I5700R. For people in the rest of the world isn't it GT-I5700? If I install a European firmware for example would everything work or would it be ok? If something doesn't work is there a way to go back to 1.5? Do I loose the crap that the service provider from who I bought the phone put on? Also is the installation process just the normal instalation process from Home
Loading...

Share This Page