1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

"Firmware Upgrade Encountered an Issue..."Support


  1. higaran

    higaran New Member

    Hi guys... I need help because I made a stupid mistake that is costing me sleep. I picked up a new SGSII just yesterday. I hated the stock ROM almost immediately, so I decided to root it so I could install MIUI, just like I had on my previous phone (Captivate).

    Ordinarily this wouldn't have been a problem, but I did two very stupid things. First, I tried using ODIN and Kies on a PC running a pre-beta version of Windows 8, which I discovered (too late) is incompatible. Sure enough, ODIN froze halfway through flashing to a new bootloader. I waited several minutes until I was sure there was no hope of it completing, and then I did the next stupid thing: pulled the plug and tried to reboot the phone.

    Sure enough, the phone instantly boots to screen that says "Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again." There's no option to continue or circumvent this error screen, and therefore no way to get back into download mode.

    I actually went to the hassle of removing Windows 8 from my computer and reverting back to Windows 7, just to make Kies work properly. But Kies still won't talk to the phone at all; it just detects it and then reports a connection error. The Kies emergency recovery mode will not detect the phone, and won't even try recovering firmware until it gets a silly recovery code, which I've never seen before.

    I've tried every reset method possible - three-finger reset, battery-out USB boot, removing SD and SIM cards, etc, etc.

    I've also tried killing off all Kies processes and re-flashing the bootloader from ODIN, but I get this result:

    <ID:0/003> Initialzation..
    <ID:0/003> Get PIT for mapping..
    <ID:0/003> Firmware update start..
    <ID:0/003> zImage
    <ID:0/003> NAND Write Start!!
    <ID:0/003>
    <ID:0/003> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)

    So, ODIN seems able to connect, but unable to fix anything. And I'm too noob to know what I'm doing from here.

    Can anyone offer a suggestion?

    Advertisement
    :
  2. Shotgun84

    Shotgun84 Well-Known Member

    I've seen that message a few times and it was usually caused by a bad download. So it may be worth trying to flash a different firmware file with odin.
  3. higaran

    higaran New Member

    I had actually tried a different .tar already, but I downloaded yet another... CF-Root-SGS2_XW_ODD_KE8-v4.0-CWM4.zip.

    Still no luck. I get the exact same error as before.

    Any other ideas?
  4. Shotgun84

    Shotgun84 Well-Known Member

  5. higaran

    higaran New Member

    I had no luck whatsoever with trying to install about half a dozen firmwares.

    Finally I tried following Tsar3000's directions posted at How To Update Samsung I9100 Galaxy S II Firmware.

    This method bricked the phone completely - I'm assuming this is probably because it monkeyed with the partition information.

    In any case, my phone is now completely brain-dead and won't even power on. I'm going to see if my cell provider will do anything for me, since the phone is only a couple of days old. But failing that, it looks like I'll have to send it to someone who can perform a JTAG resurrection.
  6. devilsneer

    devilsneer New Member

    higaran, I am also encountering the same situation, did u find any solution??!! help will be much appreciated!
  7. daleneedshelp

    daleneedshelp New Member

    I too have a somewhat similar issue.

    My Sprint Samsung Galaxy S2 fails to connect to my computer (also tried another computer and different usb cable), after a failed attempt to upgrade to ICS 4.0. The phone will not load up now to 'normal' operating mode.

    It will only come up to the message:
    "Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again."

    I can no longer get into Recovery or Download modes. At least none that work. (See below)

    I also built and tried the USB jig solution, which does power on the phone, but it then comes up and says:

    ODIN MODE
    PRODUCT NAME" GT-19100
    CUSTOM BINARY DOWNLOAD: YES (2 counts)
    CURRENT BINARY: SAMSUNG OFFICIAL

    Downloading...
    Do not turn off target!!

    Any ideas?
  8. smb3843

    smb3843 New Member

    i want upgrade my sgs2 to android 4 and download firmware file from samfirmware.com but when i executed odin program i ticked repartition and now my phone doesnt boot in any mode and when i turn on it on the screen just show "a computer and a phone and an alert Triangle mark between those".
    how can i resolve this disaster?
  9. Slug

    Slug Check six! Moderator

    You'll need to use Odin to flash both the original firmware and the correct .PIT file (with "Re-Partition" selected). The firmware should be available here, but you'll probably have to search XDA for the .PIT file.
  10. aayushsugandh

    aayushsugandh New Member

    Hey guys, i tried upgrading(through Kies) my international galaxy sII from ICS to Jelly bean but due some problem it got stuck at 1%. I did unplug it and tried connecting it back(my bad :eek:) but it showed "Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again". Even after connecting it to Kies it couldn't recover. How could i restore my phone and i wish i can still save my data :( . I heard of 'Odin' but don't know to use it, my phone is not rooted and im waiting for the earliest reply by someone. Thanks in advance :)
  11. ironass

    ironass Well-Known Member

    Hello and welcome to Android Forums aayushsugandh! :)

    Are you able to get into, "Download mode"? Press Volume down+Home+Power key and hold for 10-20 seconds.

    If you can get into, "Download mode", you can flash a stock Samsung firmware to your phone via Odin, as described in #1.7 of the Jelly Bean update - Dummies Guide.
  12. Snoopy168

    Snoopy168 New Member

    Hello Ironass.

    Please help this newbie here.


    I have an international S2, with ICS. Tried to update the firmware yesterday and both S2 & the PC hung. Now all I see was ""Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again".

    NOT possible to do the "Download mode". The Above error msg will stuck itself on the screen forever.

    I had since uninstalled KIES and had installed the Samsung drivers.

    Odin 1.86 can detect a device. ID:COM (yellow box) says "0:[COM4]". The message of " ""Firmware upgrade encountered an issue....." remains on screen.

    I had tried to follow the instructions here http://forum.xda-developers.com/showthread.php?t=1457458 . But I am unsure if these steps are still valid.

    Any help is appreciated.

    Thank you
  13. ironass

    ironass Well-Known Member

    Hello and welcome to Android Forums Snoopy168! :)

    Sorry to learn that you are having problems.

    Are you able to get into Download mode if you remove and replace the battery? For instructions on how to boot into Download mode, see post #2, here.

    If you are able to do so, then you can flash a stock Samsung firmware as per the instructions in my previous post.
    Snoopy168 likes this.
  14. Snoopy168

    Snoopy168 New Member

    Thank you for the reply.

    Only managed to get to "Download mode" by removing the SIM card & SD card.

    I have just 2 questions.

    1. Using Odin . Is there an icon that will indicate that the update is in progress. Like our Windows files transfer, with the animation icon ?

    2. For a normal update using Odin. What is the expected time to completion ? My several attempts has past 35 mins and with no response from Odin. I had used 1.8.5 and the 3.07 versions.

    In my case, with the "firmware update error", my longest attempt is over 60 mins and with no response except for a very very warm battery & handset. I had to disconnect. Is this normal ?

    To think back, my earlier attempt to upgrade to ICS resulted in a brick also. It was under warranty and SSC took 45 mins to fix it with a replacement of the LCD screen & camera (i talked them into this).

    Guess my luck ran out .... :(

    (where I got stuck previously)

    Attached the S2 and there is a yellow box "0:[COM5]" appears.

    Then the following messages :

    <ID:0/005> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> I9100ZSLSJ_I9100OZSLSJ_I9100XXLS8_HOME.tar.md5 is valid.
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/005> Odin v.3 engine (ID:5)..
    <ID:0/005> File analysis..
    <ID:0/005> SetupConnection..
    <ID:0/005> Initialzation..
    <ID:0/005> Get PIT for mapping..
    <ID:0/005> Firmware update start..
    <ID:0/005> boot.bin

    upto this stage and nothing happens for the next 45 -60 mins.
  15. ironass

    ironass Well-Known Member

    There is a progress bar shown in Odin with details in a window of Odin, showing the various stages.

    Roughly speaking, the actual loading and initialising of the firmware should only take about 4 or 5 minutes and around the same time to reboot.

    No, that is not normal and indicates a user error. For instance, had you enabled USB debugging?

    You will need to carefully and thoroughly read and follow the step-by-step instructions and video contained in the link in #1.7 of the Jelly Bean update - Dummies Guide.
  16. Snoopy168

    Snoopy168 New Member

    After almost 1+ hour.....I saw the reply.

    THis is definitely not happening. I had that Download icon, connected via USB and the Odin saying the above messages. For over an hour.


    I last remembered that this USB debugging was checked. Now, with the firmware error on screen, I am unable to verify it futher.

    Yes,I had read this & watched the video a few times. There was no progress bar on the S2.

    When I unplug the USB cable. This pops in the message "
    "<ID:0/005> NAND Write Start!!
    <ID:0/005> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)
    <ID:0/005> Removed!!"


    Yesterday, at the same time. Canon USA announced the firmware update for their flagship 5D Mk3 (which is a US$2500 camera). The update steps ? After agreeing to all the legal mombo, download & unzip the file to the SD / CF card, goto camera memu and click "update firmware". In less than 6 mins from the time getting to the website and to completion. Why can Samsung make things THIS simple for us, non techies ?
  17. ironass

    ironass Well-Known Member

    I fear that your original problem with flashing via Kies has resulted in an incomplete firmware update which seems to be preventing flashing of any kind.

    You could try re-installing Kies and seeing if it will do a recovery for you. I cannot comment on the link that you posted to for a recovery as I have not tried it myself.

    Alternatively, you could take your phone to a Samsung Service Point and explain about your problem with Kies and request a recovery from them.
Loading...

Share This Page