First time rooting


  1. psilocybe38

    psilocybe38 Member

    Hello everyone. This is my first rooting experience, so I apologize for my general ignorance and narb status in these matters. I recently got a Droid 4 and rooted using the GB only Droid 4 Utility. After rooting I tried flashing a ROM, and got into some trouble after a wipe.

    Currently, the phone is stuck at the 'dual core' splash screen when I turn it on. After I first I rooted, I installed Safestrap v1.09 and made a backup, which I still have on my SD card, but for some reason I'm unable to boot into Safestrap since the wipe

    Advertisement
  2. Brian706

    Brian706 Moderator Moderator

    Hey psilocybe38! I am not familiar with your device but I know how that moment of panic feels when you get stuck in unfamiliar territory so I will throw in my two cents really quick anyway. From reading through your steps, it sounds like you just don't have a rom loaded. Any way you can download your rom again and get it on your external storage? Then try step 6 again? I am not sure what safe strap is. Also, if you can get into recovery, etc. then I don't think you are screwed yet! By chance do you have a nandroid backup made that you can restore through your recovery to at least get booted back up?

    psilocybe38 likes this.
  3. psilocybe38

    psilocybe38 Member

    Hey Brian, thanks so much for your help and consideration.

    Safestrap is the custom recovery tool on the droid 4. I have a backup of my previous system on SD, but I can't even get into safestrap recovery to restore, and if I go into the regular motorola primary recovery system, the only options I see are:

    >reboot
    >Update from sd
    >wipe/factory reset
    >wipe cache partition

    There is no restore option in the menu.

    I'm not very versed or familiar with backups, so I'm not sure if a backup made in safestrap can be of any use with other recovery systems, but my safestrap backup (nonsafe) file has a nandroid.md5 file in it along with various other .tar files. I assume this can only be restored through Safestrap?

    Should I just forget about the backup I have and flash the stock ROM using "update from SD"? If I do, will I have lost root?

    I'm not familiar with fastbooting, but from what I've read it seems to be appropriate for getting back to stock ROM, and then I can re-root.
    Brian706 likes this.
  4. Brian706

    Brian706 Moderator Moderator

    First, before we do anything, I am going to call in some reinforcements. I just do not have enough knowledge of your device to be giving advice on what files to download and flash. It sounds like you are still fixable and I wouldn't want to do anything to really get you stuck.

    From experience in the HTC world, I know it is possible (at least on my device) to flash a recovery through an update file on the sd card. Alternatively command prompt can be used. So there could be a chance that you can just flash your recovery again.

    I hadn't realized you could only get into stock recovery. You definitely need a custom recovery to handle your backups!

    I will let someone that is more familiar guide you through the specifics! Hang tight, help is on the way!! :)
    psilocybe38 likes this.
  5. psilocybe38

    psilocybe38 Member

    Thanks so much for your prompt respones, Brian. You're the man.

    I think I'm just gonna try the AP Fastboot method once I'm able. A guy on this xda thread seems to have had the same problem, and it sounds like fastbooting worked.

    However, in fastboot, I see "Battery Low Cannot Program," so I've got it charging via power outlet now. Not sure if it's even working; it just sits at the the same screen when plugged in. I guess I'll wait and see...
    Brian706 likes this.
  6. doogald

    doogald Guides Guide

    xmr405o, psilocybe38 and Brian706 like this.
  7. psilocybe38

    psilocybe38 Member

    thanks, doogald for following up with all that info; super helpful. I'll keep charging, and hopefully flashing back to stock will do the trick.

    thanks again, to both you and brian.
  8. Brian706

    Brian706 Moderator Moderator

    Hey it's no problem! Wish I could have helped more. Please let us know the results once you get a chance to try!
    psilocybe38 likes this.
  9. xmr405o

    xmr405o Well-Known Member

    Hopefully you can get your backup flashed if not I hope rsd lite saves your phone.
    psilocybe38 likes this.
  10. psilocybe38

    psilocybe38 Member

    I seem to have hit a strange and unfortunate snag; the battery doesn't seem to be charging while plugged into the power outlet. In fact, the battery has been completely drained because it has just been sitting on the startup screen this whole time.

    Now I can't even boot into recovery or fastboot unless its connected to the wall outlet, yet the battery receives no charge.

    How can I put some juice into this thing? Perhaps find another Droid 4 to switch batteries with? Or is there some alternative McGuyver method for getting a battery charged?

    Also, I was wondering if a fully charged battery is also required to "flash from sd" in Moto Recovery; could I somehow flash to stock that way while it's plugged in?

    Any further advice would be greatly appreciated. Kinda bummed, I was super confident I'd be home free after charging for a while and then fastbooting. :(
  11. xmr405o

    xmr405o Well-Known Member

    I don't think they make a sync and charge cradle for the Droid 4. I tried looking around on google.

    So you can't shut the phone down at all? Holding down the power button for 30 seconds doesn't power down the device? Unfortunately, I don't have a droid 4 but when a similar situation happened to my bionic, I turned the whole phone off and charged it. I wasn't able to charge it while the bionic was on (stuck in the droid eye). After a few hours, I checked to see if my battery charged then it appeared to have charged because I was able to put my phone in fastboot mode and I was able to rsd lite after that.

    As for having to have a fully charged device for safestrap or recovery, that's always a recommendation but I've gotten in recovery with my bionic a few times with 80%. I think if it's less than 40%, the motorola recovery will not let you enter recovery.
    psilocybe38 and Brian706 like this.
  12. doogald

    doogald Guides Guide

    As xmr405o mentioned, you should be able to power down by long-pressing the power button (about 10 seconds). I've never tried charging with stock recovery or fastboot running on my D3, but on my old Eris, the phone would not charge while it was in this mode while plugged in. You should be able to charge after powering down.

    The D4 has a non-removable battery, so swapping batteries (or pulling the battery) is not an option.

    So, long-press power until the start screen is no longer displayed and the phone is powered down, plug in for at least an hour or so with the phone powered down, and see if that helps.

    FWIW, there was a version of Safestrap that would not start safestrap recovery if the phone was powered on, but I believe that was Safestrap 2.1, so version 1.09 should not have that problem. However, here's hoping that you'll see Safestrap after the battery is charged and you start the phone running on battery rather than AC power and you can restore from safestrap...
    psilocybe38 and Brian706 like this.
  13. psilocybe38

    psilocybe38 Member

    Hi guys, thanks again for all the input.

    Currently, I can power down the phone by holding the volume down and power button for ten seconds, but the phone always tries to automatically reboot a few seconds after I power it down.

    The only way that I can get the phone to power off and stay off is to boot into AP fastboot, then hit the power button to power down. For some reason, that causes the phone to stay off, but the phone doesn't seem to be charging if I plug it in while it's in this state, neither outlet nor computer.:confused:

    The Droid 4 battery is technically "non-removeable" but after taking a look, it's just screwed in with two T3 torx screws
  14. doogald

    doogald Guides Guide

    How do you know that it's not charging? At least on my D3, there is no external indicator that a charge is happening - the LED does not light. (I just checked - it's the same for the Droid 4.)

    See here: https://motorola-global-portal.custhelp.com/app/answers/prod_answer_detail/a_id/81426/p/30,6720,8302

    Also, are you using the Moto USB cable and charger, or a cable from another device? If from another device, you may want to try another charger and cable. (Though I do have to say that I can charge with just about any micro-USB cable, there are some wall chargers that do not supply enough amps to charge the D3.)


    Yes, if you cannot charge, that's what I would do. Since you have removed the battery, expect them to tell you that you have voided your warranty, etc.

    Good luck. I'm watching this thread, so let us know if you make any progress.
    psilocybe38 likes this.
  15. psilocybe38

    psilocybe38 Member

    I just left it plugged in for like 2 hours or so in both outlet and PC, and the phone didn't turn on after either. This was after I plugged it in after powering off from the fastboot menu screen.

    Yup, using only cables and adapters that came with the phone.

    Just now I tried plugging it into an Apple computer just to see if that worked (I'm trying anything I can think of at this pont); when plugged into the Mac, the phone does not try to turn on as it did with PC and outlet. Instead, the message indicator light (green) turns on when I plug it in
  16. doogald

    doogald Guides Guide

    psilocybe38 likes this.
  17. psilocybe38

    psilocybe38 Member

    Alright, so after around 6 hours of solid Green LED charging in the Mac computer, no charge was retained. So, convinced that the computer charging method was a no-go, I decided to just leave it plugged in with the stock charger via wall outlet overnight once more, to no avail - still no juice in the morning.

    So, I decided to go into Verizon this morning and play dumb; I told them that the phone had just died (of natural causes) and wouldn't charge or boot up while plugged in. Miraculously, and to my great advantage, the technician there did not realize that the warranty sticker had been completely removed (from when I tried a battery pull), so he arranged for a replacement phone to be sent to my house, and said that I needed to send my current device back in the same box.

    My worry is, if I send them back my phone with no OS and a voided warranty, would they trip on it and charge me for a new device? Should I use the new phone to charge a battery, swap it, and fastboot GB 219 before I send it back(although it would still have no warranty sticker)?

    Any advice or experience with this situation would be greatly appreciated.
  18. doogald

    doogald Guides Guide

    I can't help you with any experience. No OS on a returned phone must happen a lot. The issue with using the new phone to charge the battery is that you are going to void the warranty on a second device, so I doubt that's the best way.
    psilocybe38 likes this.
  19. xmr405o

    xmr405o Well-Known Member

    One last thing to try...Have you tried to hold down the power button and both volume buttons to perform a reset? It's equivalent to a battery pull. See if that helps.
    psilocybe38 likes this.
  20. psilocybe38

    psilocybe38 Member

    Ya, I've tried this plenty of times without success—it just powers itself back on and stays at the boot screen.

    They won't be able to tell that it was rooted in it's current state, right? If there's no way to tell it was rooted before the wipe, then I think I'll just take my chances sending it in without the warranty sticker, and hope they don't think anything of it.

    From what I've read in various other forums, there are plenty who have sent back devices that were rooted, or with unlocked bootloaders without any further inquiry made by Verizon, although there are certainly a couple stories from people being charged market value for a new device. I hope I don't fall into the latter category.

    It might even be feasible to carefully put the new device's warrant sticker on the one I'm returning, we'll see.

    Thanks again for all the help, guys.

    EDIT:

    Quick update. Since I figured I'd be sending this device back and it's warranty is voided, I tried one last experimental charging method with a Spliced USB Cable going into a wall charger, which seems to be working (the charger I'm using has a charging indicator light that shows the battery is taking charge).

    If I can charge up and restore GB with fastboot on the current device, I'll likely just send the new device right back to Verizon to make sure I don't get slammed with the market value charge on the voided warranty. Wish I tried this before going into Verizon…
    Brian706 likes this.
  21. psilocybe38

    psilocybe38 Member

    So, the McGuyver'd USB cable charging method worked, and I fastbooted GB 219 without error. :D

    Thanks again to everyone for your attention. This community has been super friendly and informative.

    Cheers :beerglass:
    xmr405o and Brian706 like this.
  22. Brian706

    Brian706 Moderator Moderator

    Awesome man! Congrats! Happy to hear you got it going. :D
  23. xmr405o

    xmr405o Well-Known Member

    Dude that's great! I'm glad we have the internet for fixes like that.
  24. doogald

    doogald Guides Guide

    Good news. I think that the one thing that i would check is that the charging circuitry for the D4 is actually working, so you don't have McGyver charge every time.
Loading...

Share This Page