[FIX]Broken bluetooth on updateSupport


Last Updated:

  1. karendar

    karendar Well-Known Member This Topic's Starter

    Joined:
    Jun 22, 2010
    Messages:
    513
    Likes Received:
    60
    Hey all,

    I found a quick fix to correct the bluetooth not pairing when updating without a wipe. The fix is quite simple really:

    Get a file explorer application (Like root explorer or ES File explorer), navigate to the /Data/misc/bluetoothd folder. You should see a folder name XX:XX:XX:XX (Where X is your bluetooth mac address), simply delete that folder and reboot phone. Your bluetooth profile will be reset and pairing will work without wiping data.

    Enjoy!
     

    Advertisement
    barney_rebel likes this.
  2. TheSarge

    TheSarge Active Member

    Joined:
    May 22, 2011
    Messages:
    38
    Likes Received:
    3
    had this same problem. Had to do a hard reset (factory data reset). Wish I'd known this beforehand. :(
     
  3. karendar

    karendar Well-Known Member This Topic's Starter

    Joined:
    Jun 22, 2010
    Messages:
    513
    Likes Received:
    60
    Sorry. ;) Tried my best to find the fix beforehand...
     
  4. rfvyhn

    rfvyhn Member

    Joined:
    Dec 11, 2010
    Messages:
    8
    Likes Received:
    5
    Thanks, it worked for me. Although on my phone the path was actually /data/misc/bluetoothd.
     
    karendar likes this.
  5. karendar

    karendar Well-Known Member This Topic's Starter

    Joined:
    Jun 22, 2010
    Messages:
    513
    Likes Received:
    60
    Hey no problem. And yeah, forgot to type Misc! Sorry. ;) Just updated first post.
     
  6. cjmaniac

    cjmaniac Well-Known Member

    Joined:
    Jun 9, 2011
    Messages:
    51
    Likes Received:
    5
    I am still having some issues with this. When I look through my folders on sd card with es file explorer, i am unable to find the file /Data/misc/bluetoothd. My bluetooth device will pair but it always fails to connect. I tried clearing the cache for bluetooth opp, bluetooth pbap and bluetooth services and still no luck. Any other ideas or will I need to hard reset to get it to work properly?
     
  7. karendar

    karendar Well-Known Member This Topic's Starter

    Joined:
    Jun 22, 2010
    Messages:
    513
    Likes Received:
    60
    Hi,

    It's no on the SD card, but in /data/Misc/Bluetoothd... In ES file explorer, you have to hit up until you reach root (Which will show you /system, /data/, /sdcard, etc) and then go in data from there. Then misc and then bluetoothd... If you don't have root though, this will not work.
     
    cjmaniac likes this.
  8. cjmaniac

    cjmaniac Well-Known Member

    Joined:
    Jun 9, 2011
    Messages:
    51
    Likes Received:
    5
    Oh ok so to get it to work i had to change the home directory to just be /. It would not let me go to the root directory otherwise.
     
  9. karendar

    karendar Well-Known Member This Topic's Starter

    Joined:
    Jun 22, 2010
    Messages:
    513
    Likes Received:
    60
    Exactly, ES file explorer has this thing where it dumps you in your sd card, but it does permit to access the root if you know how. ;) Which is why I prefer using root installer personally
     
  10. kchahal

    kchahal Member

    Joined:
    Jan 24, 2011
    Messages:
    17
    Likes Received:
    0
    My /data folder is empty, so I cannot delete anything to try this fix. Is this normal? I have used both File Manager and ES File Explorer to confirm (and yes I am at /data and not in /sdcard)

    This folder remains blank even when I pair and connect to my Car. It connects and disconnects every few seconds in a non stop loop.

    Please help !
     
  11. karendar

    karendar Well-Known Member This Topic's Starter

    Joined:
    Jun 22, 2010
    Messages:
    513
    Likes Received:
    60
    Do you have root? I'd suggest using root explorer instead... But I can't say why it's not showing up when you go in data.
     
  12. funpig

    funpig Well-Known Member

    Joined:
    Nov 29, 2010
    Messages:
    607
    Likes Received:
    68
    kchahal, I have never rooted my phones and have done the LG 2.3.3 update four times (original plus 3 warranty replacement phones). Each time, I was able to recover the bluetooth by doing a factory reset. This means you will have to restore all your apps and data, so make sure you back-up first. Having done this about a half dozen times, it's not so bad.
     
  13. neilbre1

    neilbre1 New Member

    Joined:
    Dec 2, 2011
    Messages:
    2
    Likes Received:
    0
    LG Shine Plus will not connect to any of my Bluetooth devices. This was after a update was installed onto the phone.
    Any suggestions?
     
  14. cjmaniac

    cjmaniac Well-Known Member

    Joined:
    Jun 9, 2011
    Messages:
    51
    Likes Received:
    5
    2 Options.
    Do a factory data reset

    Or Root your phone and follow the instructions in this thread.
     
  15. tremer

    tremer New Member

    Joined:
    Nov 27, 2011
    Messages:
    2
    Likes Received:
    0
    The data folder is empty ?!?!?!?

    Thanks for the help :)
     
  16. karendar

    karendar Well-Known Member This Topic's Starter

    Joined:
    Jun 22, 2010
    Messages:
    513
    Likes Received:
    60
    Do you have root? If you don't, data might be empty or you might need to remount data which is a more complicated process. I could also make a flashable ZIP which deletes bluetooth data, but I'm a little lazy. ;) haha
     
  17. tremer

    tremer New Member

    Joined:
    Nov 27, 2011
    Messages:
    2
    Likes Received:
    0
    I just find the option for shoing the hidden files. Thanks a lot!
     
  18. kchahal

    kchahal Member

    Joined:
    Jan 24, 2011
    Messages:
    17
    Likes Received:
    0
    Deleting files from that hidden/root folder does not resolve issue. Well it does resolve it temporarily but the same problems (disconnections) start happening again after a day.

    Anyone has any other ideas?
     
  19. karendar

    karendar Well-Known Member This Topic's Starter

    Joined:
    Jun 22, 2010
    Messages:
    513
    Likes Received:
    60
    Did you try the factory default settings? Everything works fine here after deleting the lingering bluetooth settings.
     
  20. kchahal

    kchahal Member

    Joined:
    Jan 24, 2011
    Messages:
    17
    Likes Received:
    0
    Yes, tried both options

    a) Rooting phone, then deleting the files/folders
    b) Doing a factory reset

    and

    c) also sent it in for Warranty repair asking Telus to reinstall 2.1 with a list of problems.

    They installed 2.3 again and said problem fixed. But it is still not fixed :( .
     
  21. karendar

    karendar Well-Known Member This Topic's Starter

    Joined:
    Jun 22, 2010
    Messages:
    513
    Likes Received:
    60
    Gotta love LG and Telus...

    Wrote some hate mail to LG pointing to these forums speaking on behalf of the community telling them to issue a fix. I know they won't though!
     
  22. linux4u

    linux4u New Member

    Joined:
    Mar 2, 2012
    Messages:
    1
    Likes Received:
    0
    I still have the older version 2.1 V10d, but the bluetooth neither recognizes any other device, nor is being discovered although it is discoverable. I tried both suggestions, and no luck!:mad:

    Any idea to fix it? Any guarantee as for if I update to 2.3.3 or V20* and try the fix to get the BT working?

    Help appreciated.
     
  23. funpig

    funpig Well-Known Member

    Joined:
    Nov 29, 2010
    Messages:
    607
    Likes Received:
    68
    If you have tried all of the software fixes suggested above, it is possible that your phone bluetooth hardware is defective. One of my many shine pluses (I have had to exchange about six for various reasons) had a bluetooth which was bad out of the box.
     

Share This Page

Loading...