Fix for Google Contacts Not SyncingSupport


Last Updated:

  1. Peaser

    Peaser Well-Known Member This Topic's Starter

    Joined:
    Dec 5, 2009
    Messages:
    103
    Likes Received:
    8
    :)Thanks to the folks in this forum, I was able to fix my syncing for contacts and you can too if you're having this problem.

    Go to menu>settings>applications>manage applications>contacts storage and then delete the data. I backed up my Google contacts on line first by exporting the file just in case. (Not a bad idea anyway, this way you'll have an Excel database with all your contact in case anything should ever happen to your phone).

    Then resync. It will all go back in without a problem. I noticed that the file is about 1/2 the size now and I think that's because I didn't sync up all the Facebook data back yet (no photos matching to people, etc.). but I think I'll make sure it all syncs continuously again first, then try adding back in the Facebook info.

    Hope this helps others. So far two of the problems were solved by deleting old data (I didn't want to do a factory reset after getting 2.1 just where I wanted it except for the few glitches).

    Thanks all.


     

    Advertisement
  2. jdog94

    jdog94 Well-Known Member

    Joined:
    Feb 1, 2010
    Messages:
    64
    Likes Received:
    1
    resync what ?? facebook??
     
  3. Peaser

    Peaser Well-Known Member This Topic's Starter

    Joined:
    Dec 5, 2009
    Messages:
    103
    Likes Received:
    8
    Resync google contacts. however now i am noticing that Facebook photos and friends won't sync back. i tried logging out of the facebook app and going back in but it doesn't fix that issue. not a big deal for me but annoying.

    Okay, fixed this by going to the account sync section and removing the Facebook account. It says you will lose all your data. Doesn't matter. It all comes back when you add the account back in. Which I did next. Then go to the Facebook app and log out of that. When you add the Facebook app back the contacts and their connection to Facebook (photos, updates), etc. will come through. You don't have to get the updates however, or choose how often to get them. I just liked having the photos show up with callers.
     
  4. redfirefly

    redfirefly Member

    Joined:
    Jan 29, 2010
    Messages:
    21
    Likes Received:
    1
    I've done all of this and thought it was fixed...I was having the problem with the contacts being linked to their FB. I've tried to re-sync them to FB and I keep getting an error and it has to force close. So annoying. Anyone else having this problem?
     
  5. elektrared

    elektrared New Member

    Joined:
    Jan 31, 2012
    Messages:
    1
    Likes Received:
    1
    Best Answer
    I have tried this and everything and short of a factory reset (might as well go out and get an iPhone if I have to do that) nothing has worked. My contacts have not synced since Aug 2011 and I continually get the "Sync is currently experiencing problems. It will be back shortly" message. Can anyone help?:mad:
     
    Jaclyn Marie Netzel likes this.
  6. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,620
    Likes Received:
    1,896
    Well, I think that the standard method (which I think was described above) is this:

    - settings->accounts & sync->your gmail account->uncheck contacts sync

    - settings->applications->manage applications. Wait for the refresh (it usually takes a minutes or two). It may help to menu->sort by size and then menu->sort a-z. Then find Contacts Storage, tap it, and tap the clear data button

    - settings->accounts & sync->your gmail account->check contacts sync.

    If this still does not work and you have other services that are syncing contacts data (i.e., Facebook), try removing those other services from settings->accounts & sync and try again.

    [edit] one last thing: in settings->SD card & phone storage, what is the number of available space under "Internal phone storage" (i.e., the last number on that page)?
     
    Jaclyn Marie Netzel likes this.
  7. rodrigobraz

    rodrigobraz New Member

    Joined:
    Feb 24, 2012
    Messages:
    2
    Likes Received:
    1
    Just an update: at least in my current version (Froyo), the application is not called "Contacts storage" anymore, but "Google Contacts Sync" (which is a bit confusing since there still is a "Calendar Storage", for example).
     
    Jaclyn Marie Netzel likes this.
  8. RLG4444

    RLG4444 New Member

    Joined:
    Mar 1, 2012
    Messages:
    1
    Likes Received:
    1
    I'm having the same issue not being able to sync my contacts on my Samsung Note. They synced just fine and now have not been syncing for several days. I removed Facebook and Twitter from my phone and even did the dreaded system reset, some of my contacts synced back but I still keep getting the error "sync is currently experiencing problems. it will be back shortly"
     
    Jaclyn Marie Netzel likes this.
  9. shanraha16

    shanraha16 New Member

    Joined:
    Jul 25, 2012
    Messages:
    1
    Likes Received:
    0
    great fix thanks
     
  10. kahn

    kahn New Member

    Joined:
    Dec 22, 2012
    Messages:
    1
    Likes Received:
    0
    Fixes it by deleting the cache of 'contact storage'

    Thanks a lot.
    much appreciated
     
  11. Scubadooper

    Scubadooper New Member

    Joined:
    Jan 15, 2013
    Messages:
    1
    Likes Received:
    0
    Thanks, worked a treat!
     
  12. rajsharan

    rajsharan New Member

    Joined:
    May 8, 2011
    Messages:
    2
    Likes Received:
    0
    Thanks...deleting the data from applications -> contacts storage and resyncing worked for me too.
     
  13. atomicbreakout

    atomicbreakout New Member

    Joined:
    Apr 2, 2012
    Messages:
    2
    Likes Received:
    0
    The steps above worked fine for me, just found contact storage and cleared data then it just started to sync and fixed the contact sync problem... Thanks:D
     
  14. Jcreddy

    Jcreddy New Member

    Joined:
    Jun 24, 2015
    Messages:
    1
    Likes Received:
    0
    I'm not seeing "sync contacts" under my Google account in settings... I don't know what to do, plz help!
     
  15. Sean Anderson

    Sean Anderson New Member

    Joined:
    Jul 25, 2015
    Messages:
    1
    Likes Received:
    0
    When going to >Settings >Accounts >Google, selct the account that is giving you the error. See if there is something called "inbox" that is syncing. If so, stop it from syncing. "Inbox is different from Gmail. It was making it not work.

    I dont know if this is the same problem, but I was getting an error that Sync wasnt working under the gmail account. I realized that BOTH "Gmail" & "Inbox" were syncing at the same time. I am not using "Inbox", so I shut off the sync just for "Inbox" and everything started working. Note: I am referring to "Inbox by Gmail".
     
  16. dougkm

    dougkm New Member

    Joined:
    Aug 15, 2015
    Messages:
    1
    Likes Received:
    1
    Wow!!! 5+ year old message saves the day. I've been struggling with google contacts not syncing between my S5 and Google/Gmail in either direction. I even removed my google account on the S5 and re-added it and that didn't even work. Finally I find this thread and try this: Go to menu>settings>applications>manage applications>contacts storage and then delete the data. Boom! Sync is now working between the S5 and Google. Thanks so much!!!
     
    scary alien likes this.
  17. Xama

    Xama New Member

    Joined:
    Oct 6, 2015
    Messages:
    1
    Likes Received:
    0
    I found that I needed to

    1) Delete the Contacts Storage
    2) Hold Volume Up, Power and Home and then DELETE THE CACHE SPACE
    3) Delete the Contacts Storage AGAIN

    THEN IT WORKED (Samsung S3 ... but will move to LG and turn Updates OFF )
     
  18. McDude62

    McDude62 New Member

    Joined:
    Apr 27, 2016
    Messages:
    1
    Likes Received:
    0
    Don't know if this will fix some of your problem where contacts were sometimes showing up on your phone but not on your pc but here is what worked for me. I have Galaxy S5 which when making new contacts default to whatever you choose to last save when creating a contact. I noticed contact was saved on "my device" instead of google account.

    To tell if contact is saved on phone device or google cloud is by looking at the symbol inside your contact field labeled "connected via" - the field will show Google symbol or a blue Device Symbol.

    If your contact is saved via mydevice symbol instead of google symbol then you will need to redo the contact and choose save via "google" by clicking on the top field pulldown for "device, google, or simcard" when creating a new contact.

    Unfortunately, I could not find a way to rechoose which device to select after it was saved. Hope this helps understand why sometimes contacts were not showing up on google contacts on my pc. Just be careful how you create the contact and choose google connection instead of my device.

    What S5 galaxy programming idiot did not allow you to edit connection field after you created a contact will be loathed. Hopefully I'm wrong and it's editable somehow. My apology to the idiot.

    Hope this helps if you had same problem as I did.
     
  19. C Campbell

    C Campbell New Member

    Joined:
    Jul 18, 2016
    Messages:
    1
    Likes Received:
    0
    I wonder if Google or the Android Gods are reading this forum. I've tried all the suggested fixes, to no avail. I especially agree with McDude62, that inability to change the connection field or add to it is ridiculous.
     
  20. rosatx

    rosatx New Member

    Joined:
    Aug 11, 2016
    Messages:
    3
    Likes Received:
    1
    THANK YOU THANK YOU THANK YOU FOR POSTING THIS EASY TO FOLLOW AND UNDERSTAND FIX!
    It worked for me on my LG Curve after 2 years plus of seeing the same old error message (last successful sync was 6/14/2014 - I kept hoping that one of the samsung updates would fix it). Then, today i decided to actually look for an answer and HERE IT WAS ALL THE TIME -- posted in 2009! AMAZING! and THANK YOU androidforums.com for maintaining this website all those years just for me! :) LOL

    By the way, I didn't do a backup of my contacts (decided to rely on the Google god in the cloud for that) BUT I did disconnect my laptop from the internet, just in case..... By the way, I also Run With Scissors!
     
  21. cral dogman

    cral dogman New Member

    Joined:
    Sep 24, 2016
    Messages:
    1
    Likes Received:
    0
    All of this seems to assume that the contacts are already in Gmail account. Mine are not, they are on the phone but will not and never have sync'd with Gmail account. What to do? If I delete the contacts cache on my phone, how will I get it back? "Sync is experiencing problems, it will be back shortly"..... I do not consider over a year as "shortly". Since I got the phone this has been going on.
     
  22. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,620
    Likes Received:
    1,896
    I'm not sure which phone you have, but I think all phones, somewhere in the settings of the contacts app, should have an export contacts setting, where you can export the contacts in CSV (comma separate values) format. This CSV file can then be used to import into Google contacts, Outlook contacts, Yahoo contacts, etc. - wherever you want to sync to.

    I strongly encourage you to pick an online platform and sync contacts, as it will make it much easier to transition to a new phone, or recover from a lost, stolen, or broken phone.

    You are right that wiping Calendar Storage without exporting your contacts will lose them all. Good luck, I hope that you get it worked out.
     
  23. KRPataky

    KRPataky New Member

    Joined:
    Sep 29, 2016
    Messages:
    1
    Likes Received:
    1
    I noticed an important omission that I had to share here to get the "delete Contacts Storage" fix to work. With my version of Android at least, 6.0.1, when you open the Application Manager, you don't see Contacts Storage, only Contacts. You have to first touch the vertical 3 dots symbol and select Show System Apps. Now, Contacts Storage is visible. Note that clearing data from Contacts only will not work. Hope that helps. :)
     
    carabs likes this.
  24. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,620
    Likes Received:
    1,896
    Thanks for the update. FWIW, this thread started with a phone running Android 2.1, over six years ago. Things sure have changed...
     
  25. carabs

    carabs New Member

    Joined:
    Oct 18, 2016
    Messages:
    2
    Likes Received:
    0
    Thank you for this information. I had deleted the Contacts data but it had no effect. Finding "Contacts Storage" and deleting seemed to do the trick.
     

Share This Page

Loading...