[Fix] For I cant boot into recovery


  1. OMJ

    OMJ Bazinga VIP Member

    Recently a problem has crept up in rom manager that lead you to not have access to recovery. For me it happens when I flash SPRecovery. After I flash it I am completely unable to boot into recovery. It doesnt work from Rom Manager and it doesnt work by holding x while powering on the phone. The phone is able to boot up but not have recovery is a major problem.

    Other people are having the same issue but when flashing clockwork.

    For most it seems that this can be fixed by simply flashing a different recovery in rom manager. You can flash SPR, Current Version of clockwork, or go under all clockworkmod recoveries and flash an old one. Then flash back to the recovery that you wish to use and it should be fixed.

    For me this unfortunately did not work. So here is a couple other ways to solve the problem.

    You can use terminal or I will provide scripts to flash the other recoveries. To do this make sure you have a copy of the recovery on the root of your sd card. And be sure that flash_image is in your /system/xbin/ folder.

    If you dont have flash_image in your /system/xbin folder click show for instructions

    flash_image can be found
    flash_image

    Easiest way to get it to /system/xbin is to use root explorer and copy it there.

    If you dont have root explorer you can use adb.

    The adb command is

    adb push flash_image /system/xbin/


    Clockwork can be found
    www.droidaftermarket.com/koush/recoveries/recovery-clockwork-1.8.1.4-sholes.img

    SPRecovery can be found
    http://downloads.droidmod.org/recovery-0.99.3b.img


    If you want to do this in terminal download terminal emulator by Jack Palevich

    In terminal type the following commands for clockwork

    Su
    cd sdcard
    flash_image recovery recovery-clockwork-1.8.1.4.img
    reboot recovery

    For SPRecovery type the following in terminal
    Su
    cd sdcard
    flash_image recovery recovery-0.99.3b.img
    reboot recovery


    Now the easier way to do it is with scripts.
    Make sure those files are in the root of your sd card and then download GScript Lite from the market. Open gscript.

    Then download the following scripts and put them on your sd card in the Gscript folder.(If you dont open GScript Lite first the folder will not be there and you will have to make it yourself.)

    Clockwork Script
    clockwork.sh

    SPRecovery Script
    spr.sh

    Then go back in to gscript lite press menu then add script then press load file and load the correct script.

    Then run the script and you will have the correct recovery. These wont reboot you into recovery you will have to do that manually or use RM.

    Any issues with this just ask.


    Edit: After flashing like this several times rom manager is working for me again to flash both recoveries. I think doing a flash this way may fix rom manager flashing but I cant be sure. Let me know if this fixes RM flashing recoveries for you.

    Advertisement
    :
  2. obutto

    obutto Well-Known Member

    Not working for me. I keep getting "flash_image: not found".

    I have the flash_image file and both recovery scripts on my base of my sdcard.

    Is this not working for me because my new directory for sd card is /mnt/sdcard/?

    I tried doing that as well but had no solutions. Any help?
  3. OMJ

    OMJ Bazinga VIP Member

    did flash_image get any extension added to it when you downloaded? Some browsers will add .zip or something to it just because. I am on froyo so my sd card is /mnt/sdcard/ as well and it works fine for me.

    edit: Do you have the recovery that you are trying to flash in the root of your sd card as well?
  4. Redflea

    Redflea Well-Known Member

    Did you try the other method UMG refers to above? Flash between recoveries in ROM Manager - flash the alternative recovery (SPRecovery) and then flash Clockwork Recovery? (In some cases a reboot between flashes may be necessary).
    obutto likes this.
  5. OMJ

    OMJ Bazinga VIP Member

    yea I was assuming he tried that. For some reason that didnt work for me when I had this issue so I am sure it wont for others
  6. obutto

    obutto Well-Known Member

    Ahh switching between worked. Thanks guys.

    And OMJ i was using Terminal Emulator by Jack Palevich. Whatever, its working now.
  7. OMJ

    OMJ Bazinga VIP Member

    are you using terminal emulator? And is the dev who made it Jack Palevich?
  8. Redflea

    Redflea Well-Known Member

    Yup, just wanted to make sure he hadn't skipped trying that as well... :)
  9. G.Armour

    G.Armour You know you want to. VIP Member

    For spr you can also use Droid root pro to download flash and reboot into recovery. That's the way I went. Hope this helps.
    Not sure if it is still on the market though. I had it backed up.
    Sent from my Droid using Tapatalk
  10. jxker

    jxker Well-Known Member

    Droid root pro did it for me, thanks!!!!!!!!!!!!!!!!!

    (had it backed up)
  11. monsterenergy22

    monsterenergy22 Well-Known Member

  12. Burns11

    Burns11 Member

    Do you think my SD card took a dump? SPrecovery kept acting funky, saying it couldn't mount sd card. After a couple of reboots it would work ok. So I tried rom manager to reinstall sprecovery by installing clockworkmod then back to spr. At that point it failed to start recovery (it gives motorola logo for a while then reboots back to os.

    That brought me here, I tried both gscript and terminal and both give me similar errors.
    stderr: mtd: read error at <memory address> (out of memory)
    <memory address> is a sequential memory addresses, it doesn't actually say that. Later it gives re-read errors, write errors final error is:
    stderr: mtd: error writing recovery: no space left on device

    I can read and write the SD card fine in windows.
  13. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    The link to Koush's CWM is not longer working - the domain redirects to a GoDaddy parking page, stating that the domain is available for purchasing.
  14. Burns11

    Burns11 Member

    Well, I just reinstalled rom manager, flashed clockworkmod and it worked, I can boot into clockworkmod recovery.
  15. swevrywhere

    swevrywhere Member

    I currently have CM 6.1.2 on my original Moto Droid and wish to upgrade to the latest 7.0.0 RC. My problem is that I can't boot into recover mode to backup my current ROM or install new ones. I currently have CM Recover 2.5.0.1. I have seen recommendations to flash the alternate recovery (SPRecovery) and back to CMR, but every time I try, I get the error "an error occurred while flashing your recovery." I have tried booting into recovery about 10x, and it hasn't worked once since I installed CM 6.1.2. Flashing other versions of clockwork fail, and the method where you hold x with the power button doesn't work either.

    Are the recommended steps still applicable at this time, or should I try something different? Thanks!

    Thanks!
Loading...

Share This Page