[FIX]Mobile Partition - Fix For Phone Wont Boot


  1. Austrie

    Austrie Well-Known Member

    Semi-Brick(ed) - Phone will not boot up or go into recovery.

    ~The folder is using CWM recovery by default, the stock recovery is labeled the same name except it has 'old' added to the name~

    This is the mobile partition, image folder(folder inside the driver on your computer when you go into download mode), for anybody who wants it, who wants to revert theirs back to stock, or whose phone is bricked.
    Just go into download mode(power button + volume down), connect your phone to your laptop/computer, open the 'MOBILE' driver, delete the folder labeled 'image', extract the downloaded folder, and put the extracted folder in the MOBILE driver. The extracted folder should be named 'image' as well.

    Download: http://www.noxtek.com/android/triumph/good_triumph_mobile_image.zip

    Advertisement
  2. TheGeekRedneck

    TheGeekRedneck Well-Known Member

    Curious, did this come from your phone?

    This works, same as the one atrickpay posted in this thread:

    http://androidforums.com/triumph-al...icked-my-phone-formatting-fat-cwm-heeelp.html

    However just like the one posted in that thread the Motorola bootlogo doesn't appear - just a black screen. Also the polling text that normally scrolls down the screen in bootloader mode doesn't appear.

    This is on a phone where the 'MOBILE' partition accidently got formatted using an old CWM recovery (the newer recoveries no longer have the option, thank god).

    I'm wondering if one of you guys would be willing to make an actual image of the 'MOBILE' drive that comes up when you plug the phone in while it's in bootloader mode - maybe there is something hidden in the partition data that triggers the boot display. Maybe using a tool like WinImage or something else that can make an .iso or .img file from this drive.
  3. Austrie

    Austrie Well-Known Member

    Never saw that thread, hmm, but anyways, SEEMS like your /fat has gone bad, seeing as you used the earlier cwm. Try this using windows, have my folder ready, go into download mode, connect to laptop/computer, go to my computer, right click the driver, look for 'format...', click it, format it, then open it put my folder into it, eject the driver from computer side, unplug phone, battery pull, see if it works, and tell me.
  4. TheGeekRedneck

    TheGeekRedneck Well-Known Member

    Tried all that... I've even tried things like formatting with different cluster sizes and stuff... no dice. I even tried making it a FAT32 partition out of desperation - same result. Very weird...

    EDIT: Just did it again for the heck of it - followed your instructions to the letter. Same result. Black screen at boot until it gets to the point of loading the boot animation - no Moto logo. Bootloader / download mode shows no polling messages on the screen. (although it obviously works as I can access the 'MOBILE' (/fat) that way.) It's like somehow the display just isn't getting initialized.

    I'm not the only one either, there was another guy in that thread that formatted his /fat partition in exactly the same way and the same thing is happening to him. We're missing something... I just wish I knew what it does. Like I said earlier my best guess is something hidden in the actual /fat partition itself that doesn't show up as a file per say. Or maybe the partition and FAT table has to be layed out in a certain way that isn't getting reproduced if we just copy the files to a freshly formatted partition.

    I mean we could be worse off - at least we got the phone unbricked. :D
  5. davidx385

    davidx385 Member

    Thank you so much!!! I bricked my triumph about a month ago and it works again :D:D:D:D:D:D:D
  6. Austrie

    Austrie Well-Known Member

    Glad, I could help. :D
  7. davidx385

    davidx385 Member

    quick question though:
    I can't seem to boot into download mode now, any idea why?

    EDIT: It does go into download mode, but no white text. strange haha
  8. android_mick

    android_mick Member

    Does it give any indication that it is in download mode?
  9. TheGeekRedneck

    TheGeekRedneck Well-Known Member

    No it does not, it just gives you a black screen but the phone is still in download mode. You can verify this because the mobile drive will appear on your pc when you plug it in. Copy the image folder from your pc to the mobile drive, Disconnect the phone from the computer and pull the battery. Re insert the battery and power the phone on as normal. You will see a black screen at first but in the phone will boo boo you'll see the bootanimation after about 10 seconds.

    No one has found a fix for the missing boot logo or the missing white text in bootloader mode.
  10. Chingling

    Chingling Well-Known Member

  11. TheGeekRedneck

    TheGeekRedneck Well-Known Member

    This doesn't appear to be related to the splash.img - in fact whatever is causing it not to appear is also what's causing the polling text not to be visible in bootloader mode. I suspect that there is either hidden data within the original FAT partition that we're missing, or the physical layout of the files in the FAT partition has to be specific.

    What we really need is someone to use a disk imaging utility to make an actual disk image of the drive.
  12. davidx385

    davidx385 Member

    How would someone make the disk image of the drive? I have a brand new triumph now and it would be handy to know how to do that.:D
  13. TheGeekRedneck

    TheGeekRedneck Well-Known Member


    David, I'm going to send you a PM with some instructions! :)
  14. TheGeekRedneck

    TheGeekRedneck Well-Known Member

    OK thanks to Davidx385 above sending me the files from his phone and some research I think I've figured out what's going on here.

    There are TWO hardware revisions of the Motorola Triumph. The original first run version of the phone (I call this the 'sloppy' version because of it's light heft and a run of manufacturing defects the likes of no one has ever seen before), and the second 'better' hardware revision.

    You can tell which version of the phone you have by looking under the battery cover - if you have SIX barcodes you have the NEWER revision. If you have SEVEN barcodes then you likely have a phone from the original batch (poor fellow).

    It looks as if the two versions of the phone use slightly different files in the FAT partition (the 'MOBILE' drive that shows up when you plug in the phone in bootloader mode). Using the wrong files on your phone won't keep it from booting, but will cause weird problems like the initial boot splash not appearing (the red Motorola logo), the offline charging animation not appearing, and the white USB polling text not appearing in bootloader mode.

    SO... if you've applied the fix to your phone from the first post in this thread AND your phone doesn't show the splash image anymore when you power it on... well... you've got a NEWER revision Triumph and you've got the wrong set of files for your phone. Thanks to Davidx385 we now have the RIGHT set of files:

    http://www.noxtek.com/android/triumph/good_triumph_mobile_image.zip

    Download and unzip the above file somewhere on your PC, you'll wind up with an 'image' folder. Boot your Triumph in bootloader mode (vol-down + power) and then plug it into your PC. When the 'mobile' drive pops up on your computer, open it and delete the 'image' folder from it. Now copy the 'image' folder from the unzipped file above back to the 'mobile' drive. Once it's done you can unplug your Triumph, pull the battery, put the battery back in and then power it up!

    You should have your boot splash back, the big green battery (charging animation) should show up on the screen if you plug the phone in to charge while it's turned off, and the white USB polling text should show up on the screen if you power it on in bootloader mode. BAM!

    [​IMG][​IMG][​IMG]


    Once again I have to give big shouts to Davidx385 - without him I wouldn't have figured out what the heck was going on. I hope this helps someone else too! :D


    [EDIT: It should be noted that the image file set included in the file above is BONE STOCK - and that includes the stock recovery.img and stock splash.img]
    twayne and Vtec01 like this.
  15. Austrie

    Austrie Well-Known Member

    I'm wondering how you found out about the old and the new revisions, but if this actually works then good job Red, this must have been work.
    lwd25 likes this.
  16. TheGeekRedneck

    TheGeekRedneck Well-Known Member

    Thanks Austrie, it's definitely been an interesting experience. :D

    I've actually known about the different revisions of the phone for awhile now...

    The main differences between the two versions of the phone:

    1. Different stock FroYo build versions - older ends on .38, newer ends in .39.
    2. The older first run version of the phone actually weighs less than the newer one due to slightly different construction.
    3. As stated above the white ID sticker in the battery compartment on the newer phone only has 6 barcodes instead of 7.

    Apparently the internal hardware differences aren't big enough to cause major problems with builds of Android which is why we can use the same ROMS and such.
  17. twayne

    twayne New Member

    I have had the same problem as the others, in respect to not having boot logo, battery charge animation, and boot loader polling text, but everything else has worked fine. I am currently running Tickerguys CM7 Beta 0.8 Final ROM, and OCv1.5 Kernel. My question is; Will using the fix mentioned here work now that I have already upgraded everything, or will it seriously damage my phone by doing so. Thanks for all the info, so far. I would like to put a custom boot logo on my phone, and have the charging animation back.
  18. agentc13

    agentc13 Daleks Über Alles VIP Member

    Doing this will put you back to stock, but you can restore a nandroid after and you will be set. Just do a backup right beforehand, and everything should be cool. :) Doing the stuff here will not damage your phone.
  19. Austrie

    Austrie Well-Known Member

    Added the TheGreekRedNeck's download as main download...
  20. chiphart

    chiphart New Member

    not sure sure if I'm replying in the right spot but I'm sure you well read this. I THANK YOU, I'm new to all this and if it wasn't for people like you helping people like me , I would be screwed.I came from apple to android and things are alittle different and I'm learning, thats why I'm thanking you. THANK YOU!!!
  21. lynsey11

    lynsey11 Active Member

    I did this to my phone--deleted the original files while trying to download CM7---don't ask....

    Anyway,
    I'm able to get the image file halfway copied over to my MOBILE file, when suddenly the MOBILE file seems to eject itself and not finish downloading. When unplug it, plug back in, wait for my computer to decide it wants to register the phone connection (up to 10 minutes to an hour) and bring back up the MOBILE--->image file, inside is just a txt file but none other. Am I doing something wrong here?
  22. skearton

    skearton Well-Known Member

    Did you extract the image file before the transfer? Hopefully someone else will be able to help. Odd that your phone ejects it halfway through. Have you tried on a different computer?
  23. ctaing

    ctaing Active Member

    okay so i just erased the image folder on the MOBILE drive and dragged the extracted zip folder the op linked us to. However I'm stuck on a motorola logo now. I recently had cm7 by MDEV. Im trying to get it back to stock so I can sell this phone. I keep getting stuck at the motorola logo when trying to boot normally. I can get in download mode and recovery mode just fine. I even tried clearing dalvik cache and cache in cwm as well as factor resetting from there. Any ideas what I may be doing wrong? Or should it take 10 + minutes to boot?

    p.s my triumph has 7 bar codes so I guess its an older version.
  24. jedgell233

    jedgell233 Member

    I followed the guide and still having no luck :(

    I have the newer version so got the correct image folder, put phone in download mode and moved the image folder over.

    Restart the phone and all I get is a black screen. I get a black screen regardless if I try to regular boot, recovery boot, or download mode. The back light comes on though. Anyone else running into this?
  25. creab

    creab New Member

    The link from Austrie

    http://www. noxtek .com/android/triumph/good_triumph_mobile_image.zip

    Well this link wont work anymore, or at least not for me. I have a new version of the triumph and I need the image folder but cant seem to find it anywhere. My phone wont boot just vibrates constantly. The problem is the image folder i just need a new one that works. If you could supply me with one that would be awesome. I saved the original recovery but the phone still wont boot. I have done alot of screwing around with this phone currently only a new boot, and splash img are in the folder along with the original, and i also tried with a new, recovery img. Are there other files that i need in the image folder to get it to work. pwr + vol up + vol dwn = vibrate forever. pwr = vibrate forever. pwr + vol dwn = nothing. I can still access the mobile and image folder via usb connected to my laptop...thats all i have for ya let me know

Share This Page