Fixed MTP device error with Samsung GalaxySupport


  1. sizzlingice

    sizzlingice New Member

    I finally fixed the dreaded MTP device error (code 10 error - device cannot start) with Samsung galaxy android version 2.1. I have been trying to connect to Kies since December and tried everything posted in all the forums to no avail. I called Samsung and they told me they can't help me, and I have to send the phone back for repair. Here is their logic - since I could not connect to Kies on several computers, it must be the phone.

    So far I have installed and uninstalled Kies a million times (seems like it anyway) and used 3 versions of Kies with all versions of windows available to me. Finally, yesterday I managed to upgrade to Froyo with the latest Kies (Feb 8, 2011 version) The phone now connects to KIES in pcs with windows xp, windows 7-32bit and 7-64 bit.

    THis is how I solved it to save you all the agony and the cursing.

    Note: I used windows xp since XP will allow you to manipulate files in system folders.
    First, leave the phone connected to the PC.

    1. Uninstall the MTP device from device manager.
    2. Unplug the phone from the usb cable.
    3. Go to c:\windows\system32\drivers and rename wudfrd.sys and winusb.sys to wudfrd1.sys and winusb1.sys repspectively. DO NOT delete them, you will need them again.
    3. Replug the phone. (assuming you chose to connect to PC in Samsung Kies mode)
    4. THe computer will try to install MTP and will fail because it cannot find the 2 files above.
    5. Go to device Manager, select the MTP device, choose Driver tab, then update drivers and choose specific location for the driver. Picked any folder in c:\Program Files\Samsung\USB drivers. (actually I tried all of them. But I think just one is enough). Again the update will fail but this time the code is different (I think code 28).
    6. Go back to c:\windows\system32\driver and rename the 2 files back to it's original names.
    7. Go back to device manager and now update the drivers. This time choose recommended method. This time, windows will update the MTP device with a fresh reinstall,
    8. Right click on MTP device and choose enable (if it is disabled), and this time the phone should connect to Kies.
    9.Kies will now tell you there is an update available. Update right away - choose yes to update to Froyo 2.2

    That's it. My guess of what happened is, somehow in the initial install of Kies, and plugging in an android 2.1 phone, the drivers got corrupted and the only way to get windows to reinstall those USB drivers from scratch is to force it to release the corrupted files first.

    So after my phone was upgraded to Froyo (2.2), the phone now connects to previously failed Kies connection in pcs with windows 7 (32bit and 64 bit) without having to reinstall Kies on those computers.

    I hope this works for you coz froyo definitely improves the functionality of the phone - youtube, better control of bluetooth devices, etc....

    Advertisement
    :
    AZgl1500 likes this.
  2. AZgl1500

    AZgl1500 Well-Known Member

    Thank you very much for that detailed information.
  3. thesinofmen

    thesinofmen New Member

    I am using windows 7. Is there another way to do this on this OS????
  4. Jo117

    Jo117 New Member

    I have a win 7 pc also, what I did for this phone is change it to media player mode in the usb settings, it installed the drivers correctly right away and I haven't noticed any problem with it on the phone.(although I did only put songs on the external sd card and not the internal)

    If you want to do this you just go to settings in the phone and to "about phone" at the bottom, then just change the "usb setting" to media player. Didn't try any others as this worked for me.

    Hope this helps and if this may cause an issue on my phone please let me know...
  5. kanakmahmud

    kanakmahmud Member

    Tried all but didnt work. Then i took help of Odin. Now i am on 2.3.4 gingerbread. Updating through odin took me only 15 mins or so once all drivers, Odin itself and the set up files are downloaded. I am recommending upgrade through Odin to all who are still stacked because of dumb Kies. there is a forum post by Mr. Kapil at androidsoul which has got a very clear and easy set of instruction.
  6. Meindert.B

    Meindert.B Member

    I live in Asia and yesterday a friend brought me a Dutch Galaxy GT-i9000. Firmware was old and I went to the Dutch website from Samsung and downloaded Kies and instillation was a matter of 15 minutes and now I have Gingerbread smoothly running on the Galaxy.
    Seems that ( perhaps with some luck ) things also can work smooth.

    Wish that others also nod have problems and a positive posting sometimes also can be nice.
  7. manishisthere

    manishisthere New Member

    Hi Sizzlingice,

    I do not have winusb.sys at all in my system..what can I do..It has been a big problem for me as I have not been able to do much with my galaxy s2.

    My laptop recognizes all other usb devices.Not sure what is so unique about galaxy s2 though that the system is not recognizing it.
  8. RajuD

    RajuD New Member

    Hi SizzlingIce...Thank you very much... You saved my day.. Working for my mobile galaxy. Im able to connect kies now. :)
  9. StuffDabbler

    StuffDabbler New Member

    I must have wasted a day or two on and off idly trawling the Internet looking for solutions:

    Windows XP SP3, Samsung Galaxy Tab 8.9 with 3.2, latest Kies, and latest everything else.

    This thread led me to a solution but all I did was reinstall Windows Media, connect the Tab again and, boomph, it worked first time. No deleting drivers, nothing, and what's more the Windows Media version I had was the current version which I reinstalled over anyway.

    Hope this shows up prominently in Google searches so others don't waste as much time as I did.
  10. sg3geek

    sg3geek New Member

    I found a solution that worked. Below was the method I used, followed by further explanation. You may not need to follow these steps exactly, but they're the steps I used.

    1) Plug Samsung Galaxy S3 phone into computer's USB port. You will get the MTP driver failed to installed message.

    2) Backup SMS / MMS using a backup app (like MyBackup Pro).

    3) Factory reset phone (while still plugged into computer).

    4) Do NOT sign in to your Google Account when phone resets - This is CRITICAL. You can do it later.

    5) Basically, just get the phone started up again without signing into any accounts (like Dropbox, Samsung account, etc.)

    6) MTP driver should have automatically installed on computer - if not, then unplug phone from computer and reconnect.

    7) Sign into your Google Account, and feel free to re-customize your phone at this point.


    Explanation and Notes:

    1) I factory reset my phone 2x in a row. The first time, without doing ANYTHING on the phone after factory resetting it except for signing into my Google Account, the MTP driver failed to install. I believe this happens because signing into my Google Account uses the "backup and restore" functionality of the Google Android account and Google starts automatically downloading saved settings like home screen, Wallpaper, Play Store apps, and other settings. This interferes with the initial MTP driver installation. The 2nd time I factory reset (within minutes of the first factory reset), I did NOT sign into Google Account, and voila, the MTP drivers installed. Only AFTER I was able to connect to the computer did I sign in to Google Account.

    2) Previous to this solution, I had tried every solution I had found online including:

    a) checking / unchecking USB debugging mode
    b) toggling between MTP mode and Camera mode
    c) changing some hidden Android settings
    d) using different USB cables (the one that came with the phone along with others I had)
    e) uninstalling and reinstalling the Samsung drivers
    f) uninstalling and reinstalling Samsung Kies
    g) Device Manager in Microsoft Windows - deleting everything under Universal Serial Bus Controllers so it would reinstall upon Windows restart
    h) cleaning registry
    i) trying to connect to different computers (it didn't work)


    I had initially thought it was a computer problem, but then realized I was using MTP to connect other devices (like a Sony videocamera). The problem was with the Google Account automatically downloading various settings to the phone (because of the Backup and Restore functionality) PRIOR to connecting to the computer.


    For those of you who have tried everything suggested online to connect to the computer, I hope this solution helps!
  11. adamfx

    adamfx New Member


    Brilliant!

    I have been working for a couple of days myself, trying all of the suggestions, installing and uninstalling drivers/kies etc., visiting support sites and forums. With fingers crossed I installed Windows Media Player 11 and rebooted. I plugged my phone in and voila! MTP Access!! This is the only place I've ever seen mention of this. It would be great if the word gets out so that others may not go through the headaches that we have.

    Thanks again StuffDabbler!
    stabesh likes this.
  12. varunshivhare

    varunshivhare New Member

    Hi,

    i was also having the same issue when i purchased my gnote. i format it several time and updated it to final version 4.0.4. but MTP error was still scratching my head. Finally i got the solution. Keep it in mind that there is no problem with your PC neither with gnote. the main culprit is the APPS which you would have downloaded that prevent gnote to get connected to the PC due to some crappy security reasons. Do this to solve the issue:

    1. go to settings>security>device administrators.
    2. delete what ever is the device administrator since it is creating problem in your note due to some security reasons.
    3. BOOM problem solved.

    Now connect your gnote to PC. KIES will detect it and you are done.

    Regards,

    VRS
  13. StuffDabbler

    StuffDabbler New Member

    Tried regressing to older version, and that doesn't work anymore either.

    Doing this for XP and Window 7 Professional is bust too, which didn't give me any problems in the first place!

    No problem with the MTP driver now under both operating systems, my Tab appears in the file system of both computers, its just this KIES and the only problem is how do I get ICS when/if it arrives?

    Life's too short and I have a proper job to do rather than frigging around with this dumbass piece of software that is KIES.
  14. praiano

    praiano New Member

    Thank you for your solutions, this worked for me:

    Samsung Galaxy nexus phone, Windows XP SP3, latest everything

    After trying thousand things: I had simply to re-install Windows Media 11 - and everything is fine.

    Puh, this took me two days searching around. Hope it helps others.
  15. dark66horse

    dark66horse New Member

    sizzlingice's method
    easy and quick,

    this works for me, thanx!!!! gt-p6200.
  16. orionschmidt

    orionschmidt New Member

    I also had this same error, but I found a different solution. After trying all the software/registry fixes, I thought there might be a hardware problem somewhere. I tried swapping the USB cord, but my phone was finally recognized properly when I plugged it into a different USB port on my computer.
  17. ebpmkan

    ebpmkan New Member

    It didnt work for me ....!!!!
    then, I just gave up and used Odin only to update my SGS2 (GT-I9100) with new firmware (4.0.4) ...
    For some reason, my phone was reset to factory defaults...!!!
    Then Guess what happened ??!!
    Kies worked normally and been able to connect normally and backup my phone ..
    Then, happy with this, I continued installing my applications on phone ....
    Until ...
    I configured the "Microsoft Exchange Activesync" .....
    I connected my phone again to PC, Kies stopped working again ...with same error message ... (searching for preconfigured folders).
    Then, I could analyse it and find the reason ...
    ITS DUE TO ADDITIONAL SECURITY RESTRICTIONS THAT ARE INFORCED BY ActiveSync ADMIN.
    When I installed ActiveSync, it tells that I must put screen password and let remote administrator manage my security.
    it seems that there is a "bug" in Kies with this and hope I can report the issue to Samsung.
    I tested my assumption by removing ActiveSync account totaly and in fact i connected to Kies normally ...!!!
    Please make sure that non of your applications is puuting additional security on your phone.
Loading...

Share This Page