1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

FIXED Sprint mms problem/APN settingsSupport


Last Updated:

  1. Packdog

    Packdog Member This Topic's Starter

    Joined:
    Apr 16, 2011
    Messages:
    7
    Likes Received:
    7
    Ok, backstory: New Evo (sprint, obviously), had a friend try to send me a pic message but it would not download saying "generic network failure." Someone said it was probably becuase the sender was on a different carrier. Later I tried to send out a pic, but it didn't work either saying "generic network failure" and "message not downloaded." Tech support is, as always, useless so I had to find the fix myself. Below is the fix, not a work around, the real fix (for other carriers your MMSC address will be different).

    Using "APN Backup & Restore," which is free on the market, you need to backup your APN file. Name it "APN-Broken.xml". Connect your phone to your computer as "disk drive" and using notepad correct the code to match what is shown below or just cut and paste.

    FIXED Code:
    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns count="1">
    <apn name="Production" numeric="00000" mcc="000" mnc="00" apn="1" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0" mmsc="http://mms.sprintpcs.com" type="mms" />
    </apns>

    Save your changes as "APN-Fixed" and make SURE it is saved as a .xml. Using APN Baqckup & Restore again, restore your new APN. Perform a soft reboot and you are back in business.

    Original Broken Code: In bold is what I think the problem is...
    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns count="1">
    <apn name="Production" numeric="00000" mcc="000" mnc="00" apn="1apndroid" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0" mmsc="http://mms.sprintpcs.com" type="mmsapndroid" />
    </apns>
     

    Advertisement
  2. Mr. Ed

    Mr. Ed Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    6,675
    Likes Received:
    1,464
    Odd...I wonder how it gets changed.

    I am not on a sense based rom currently to verify but doesnt restoring the data profile reset the apn settings?
     
  3. Packdog

    Packdog Member This Topic's Starter

    Joined:
    Apr 16, 2011
    Messages:
    7
    Likes Received:
    7
    "reset the data profile?" I'm not sure I understand what you mean, I'm pretty new to the android platform... are you talking about a factory reset?
     
  4. E30Nova

    E30Nova Well-Known Member

    Joined:
    Sep 23, 2010
    Messages:
    69
    Likes Received:
    3
    Dang...I was hoping this would fix my MMS issue in MIUI so I did everything and my MMS still doesn't work. :(
     
  5. Mr. Ed

    Mr. Ed Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    6,675
    Likes Received:
    1,464
    It is in menu.settings.updates

    Or can be forced by following the directions I posted for faster 3g
     
  6. gm87

    gm87 New Member

    Joined:
    Apr 8, 2011
    Messages:
    2
    Likes Received:
    0
    Thanks OP! I'm trying this out now and will post with any questions. Have been frustrated for sometime about this!!

    Fingers crossed .
     
  7. Dgulli

    Dgulli New Member

    Joined:
    Jun 21, 2011
    Messages:
    1
    Likes Received:
    0
    I have had a similar problem for months. After completing your fix all of the messages that were not able to download before downloaded. Thank you!
     
  8. dublinx

    dublinx New Member

    Joined:
    Jul 3, 2011
    Messages:
    1
    Likes Received:
    0
    Having this problem since an text/tower outage in my area 4 days ago.
    My default apn settings are a little different

    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns count="1">
    <apn name="Production" numeric="00000" mcc="000" mnc="00" apn="1" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="68.28.31.7" mmsport="80" mmsprotocol="2.0" mmsc="http://mms.sprintpcs.com" type="mms" />
    </apns>

    I am setting my mmsproxy and port to null and doing a retry
    --
    p.s. Why are so many having this problem? I am chapped!!!
    I did a factory reset prior to my soon to be attempted 2nd fix.
    The factory reset did NOTHING!!!!
     
  9. bscabl

    bscabl Member

    Joined:
    Jun 19, 2010
    Messages:
    7
    Likes Received:
    0
    my apn is even stranger than this... i have 3 listings..

    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns count="3">
    <apn name="Sprint" numeric="310120" mcc="310" mnc="120" apn="1" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0" mmsc="http://mms.sprintpcs.com" type="mms" />
    <apn name="Sprint World" numeric="3161" mcc="316" mnc="1" apn="cinet.spcs" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="null" mmsc="null" type="default" />
    <apn name="Sprint" numeric="310120" mcc="310" mnc="120" apn="1" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0" mmsc="http://mms.sprintpcs.com" type="mms" />
    </apns>

    needless to say, im not sure what to do here.
     
  10. skydiverscott

    skydiverscott New Member

    Joined:
    Jun 6, 2011
    Messages:
    3
    Likes Received:
    0
    My settings were:
    apn="-1"
    type="-mms"

    I changed to "1" & "mms" and it fixed the issue,

    Thanks for the great post!
     
  11. Malibu108

    Malibu108 New Member

    Joined:
    Nov 24, 2011
    Messages:
    1
    Likes Received:
    0
    skydiverscott and anyone out there: I am newbie to Evo and smart phone, are you following the step by step by packdog by way of hooked your cell phone to your computer? DO you know a way without using the computer? Thanks for the help.
     
  12. djqwikcut

    djqwikcut Well-Known Member

    Joined:
    Dec 22, 2010
    Messages:
    68
    Likes Received:
    5
  13. schoudha

    schoudha New Member

    Joined:
    May 3, 2012
    Messages:
    1
    Likes Received:
    0
    I m having HTC Evo 4G (Relance network, India). Can you help me to do these settings on my phone, because there is no option like APN.

    Settings --> Wireless and Networks --> Mobile Networks
    Under CDMA TAB select Access Point Names
    Go To Menu --> New APN
    Fill up the following details
    Name : Reliance Netconnect
    PPP Digit : #777
    User name : <10 Digit Mobile Number>
    Password : <10 Digit Mobile Number>
    Go To Menu --> Save
    Select the newly created APN
     

Share This Page

Loading...