*FIXED* Working fix for Credential Storage Password problem!Tips


Last Updated:

  1. RobDaBomb

    RobDaBomb Member

    TL;DR? Then skip to the bottom.


    Dear lord, so for the past week or so I've been trying to figure out how to get some WiFi tether working without root. I would have gladly rooted my Verizon Galaxy S4, but the new 4.4.2 Kitkat update rendered root useless until further notice.

    This lead me to trying out FoxFi and other VPN solutions, but - like many have seen before me - there was the bloody "enter password for credential storage" popup that managed to stump many users.

    I literally spent nearly a week now trying every 'fix' and workaround that I found on the internet, except for reseting my phone. Nothing worked. Nothing at all worked, this damn credential storage password was going to be the death of this phone for me... UNTIL I somehow stumbled across a Google Group/Google Product Forum that was started last year about the same problem. Sure enough this is what the last post (ironically posted about 5 days ago) in the forum/group states:

    "3 hours later and I feel like an idiot. I read every message board and forum and tried everything but I felt that most people for giving solutions of how to avoid having a password or PIN associated with running the foxfi app. What finally worked to get past that credentials password was creating a pattern lock screen, waking the screen backup and failing the pattern until you have the option to sign in to Google account. Then I open foxfi and it made me create a pin number but it install the foxfi credentials allowing the phones mobile hotspot to also come on.so bottom line this is what works."


    So in the hopes that a simple quick fix like this can save a poor mans day, I've decided to post this for future people who'll Google this issue. Hopefully they'll then get their answer quickly, simply, and - most of all - correctly.


    SO WHAT TO DO?

    Basically this:
    1. Go to your Settings and then add a PATTERN lock. It will also then ask you to enter a PIN afterwards as well.
    2. Reboot your phone and then when the lock screen appears, input the wrong pattern intentionally 5 times.
    3. Afterwards sign in with your Google account information. DO NOT TRY THE 'PIN' YOU CREATED EARLIER!
    4. Now DIRECTLY after signing in, go straight to FoxFi (or whatever other thing is giving you the credential storage password popup)
    5. Then it will ask you to create a password/pin to use VPN/FoxFi/etc..., do this.
    6. Voila


    Sorry if this comes off as redundant to some of you, but - after a week of mental strain due to this - I think having a simple fix that can be found in a quick Google search is well deserved.

    Thanks!

    Advertisement
    Hanthehead likes this.
  2. Bobbi2012

    Bobbi2012 New Member

    Well, I've been down this same road with the same frustration for sure. But I want to post this note because i've got Samsung G5 and it doesn't work quite the same. I managed to get past the VPN after changing to a PIN but when I wanted to go back to fingerprint screen lock I couldn't get it done. When I enter the wrong PIN 5 times, it says wait 30 seconds before trying again...and it doesn't let you do it again! So I never get that google login option that everyone talks about. I'm afraid I'm faced with "learning" how to use some scary Tasker thing if I ever want to change the lock screen method! IF I'm missing something please tell me of course! I hope this is a known issue with latest version of Android so it can be getting fixed.
  3. Shadow7533

    Shadow7533 New Member

    This worked on my Galaxy s4 on Verizon , with a few differences. First, after falling the lock pattern 5 times, you get the message to wait 30 seconds and try again, but you need to press OK, then there is a button at the bottom of the screen that says "forgot pattern" (or something like that), after pressing this button you will be prompted for your Google account credentials. Secondly, on mine, after doing this it turns off screen lock altogether, so BEFORE going into Foxfi, go back into settings and set a PIN lock. THEN, go into FoxFi and it should install OK. One more note, on mine it also prompted for me to go to settings and turn on mobile Hotspot, which normally would say to contact your provider, but some how FoxFi hooks this and your FoxFi SSID will show up under the Hotspot control instead.
    Good luck to all on solving this, it took me weeks, it's a pesky little issue!
  4. RobDaBomb

    RobDaBomb Member

    I'm sorry that you might have to use Tasker - I attempted to "learn" it and gave up instantly hah. But if I were you, I'd contact Google or Samsung and ask about the Google Login option not showing up. That is incredibly weird and I couldn't imagine they wouldn't include that in the lock screen. I mean, what if you legitimately forgot your password?! What would you ever be able to do!
  5. cybertec69

    cybertec69 Well-Known Member

    Sorry, but it still is asking for the credential storage password, I am not new to android, any other ideas.
  6. lAmDroid

    lAmDroid New Member

    Note3 vzw stock touchwiz
    current kitkat Ota

    when I set pin password it also lets me input tries for all eternity without a forgot password option. However, when I set pattern lock, it'll also ask for pin backup and getting the pattern wrong 5x will offer the "forgot password" option.

    unfortunately for me, this hasn't solved the foxfi credential issue. and restarting my device magically removes my lockscreen security making it a pretty useless security feature.
  7. ardidito

    ardidito New Member

    Hey I'm sure it's different for each phone but the HTC One (M7) has this option built into the settings menu.

    Other apps just added unnecessary complications; using the settings menu I can set the SSID, password and be up within 30 seconds.

    Try clicking 'more' under the connectivity options like wi-fi and bluetooth toggles. I have two VPN options, a mobile hotspot and one other.
  8. hejwazzup

    hejwazzup New Member

    Same problem here.
  9. kph3

    kph3 New Member

    I bought my son a S4 on Swappa. After turning it on, we got the latest software update from Verizon that S4 users received in October. The above trick doesn't seem to work on the latest update as when you put in the wrong pattern, it doesn't give you any options or anything to press to put in a google password that we can find anywhere on the phone. Anyone have any suggestions? Thanks!!
  10. JBuffum1

    JBuffum1 New Member

    I have tried literally everything on this form and every other and still cannot get around the "enter Password for credential storage" message.

    I want to be able to run foxfi my verizon galaxy s3, it currently has Android 4.4.2 installed. there is also a lot of things I cannot do which other people mention doing in their posts. For example when I go to settings > security the clear credentials botton is grayed out.

    I've tried all the lock screen settings including none. I tried intentionally messing up the pattern and logging in with my Google account. I tried missing the credential password until it says "credential storage cleared". I've tried everything I can find on the web but I don't think anyone has addressed how to work around this for the galaxy s3 running Android 4.4.2.

    Does any one have any ideas?!?!
  11. jmsnyc

    jmsnyc Active Member

    Sorry a little confused if this is the fix for the problem I having. I have the N4 with Verizon so I figure it is essentially same as S4. When I install FoxFi it needs to install Credentials/Certifcates. This has to disable my phone's pattern lock. I can only use pin, fingerprint or one other, password i think. I like pattern lock for my phone the best. Is this a work around? I want to use pattern lock for phone and keep FoxFi working.
  12. Doogie333

    Doogie333 New Member

    Workaround for G5

    Installing Symantec/Verisign Cert for CA/Personal Key Signing:

    Started with "Fingerprint" Lock as my Chosen Security (which I loved)
    1. Intentionally Failed Fingerprint Scan 5 Times
    2. Logged in with Google Credentials to Bypass
    3. Went back to Chrome on Symantec "Download/Install Cert" Page (See Below, worked same with Choosing PFX
    4. "Install Certificate" Button on Symantec Page
    5. Android Prompt Box for "Enter Certificate Password" (entered the password)
    6. Android Prompt Pop-up to "Set Password or Pin Lock"
    7. Set Password Lock (ugh)
    8. Android Pop-up "Certificate Installed"

    Then I get a "Warning" in the Notification Bar, which drags down to give a Warning that the Certificate Allows Tracking of My Internet Activity!

    Now the LOUSY Part - Try to Switch Back to "Fingerprint Unlock" Method, but ONLY "PIN" and "Password" are Available! All other options, like my favorite "Fingerprint", are Greyed Out, with the message under each that they are "Turned Off by Administrator, Encryption Policy, or Credential Storage"! (long ugh) I don't have the specifics on how secure the bio-scan is for the Fingerprint Lock, but if it's Average or Better, then Fingerprint Scan is more Secure, or at Least "As Secure" - and Incredibly more convenient! What a drag...

    But, I did Not have to Reboot/Restart. After "Clearing" the Certificate, it was Repeatable. Actually, on the Repeat, it only prompted for the Certificate Password, and did not prompt me for the Credential Storage Password again.

    NOTE: I did try it again with Security->"Install from Phone Storage"->(Pick the *.pfx file in the File Browser), instead of the "Install" from the Symantec Page, and had the same positive results.

    _Really_ not Happy that I can't use Fingerprint Lock _and_ have a Certificate!

    Anyone have a Logical Reason for the Restriction?

    (Yes, I see it's a G4 Thread, but since G5 was the search that brought me here, I though I'd share. If I get the smashed screen on my G4 fixed, I'll up date with my results there, but I know I had the Cert Installed there, too - don't remember the particulars.)
  13. ihot

    ihot Member

    I found a workaround on my Samsung Note 2 running Android 4.4.2 Verizon.
    I made a mistake of deleting FoxFI's VPN certificate. PDANet+ started to ask me for password for Credential Storage". In the past years I had locked my phone with a pattern. I went to Lock Screen Settings and select Top option "Screen Lock" - which has subtitle "Locked with screen pattern". It asked for my existing screen lock. I drew the correct one. It then give me option to select "Password". I typed in a new short password and then confirm by typing it again. I don't remember exactly what happened next, but it went like this:
    I went into PDANet+ and clicked "Activate WiFi Hotspot. It prompted me with screen "Almost thereā€¦ Go To Settings". I clicked "Go To Settings" and it give me "Wireless and networks. I turn on Mobile Hotspot. It said check subscription status. Verizon banner then comes on. I ignore Verizon and click "Cancel". I do it again - click on Mobile Hotspot. Verizon banner wants me to call them. I ignore Verizon and click "Cancel". I go into PDANet+ and follow the steps again - a second time. This time, Verizon banner does not come on and PDANet+ turns on Mobile Hotspot. I got ideas from http://pdanet.co/help/wifi.php - title (Verizon only) When installing the FoxFi certificate my phone keeps asking for a password for "Credential Storage".
  14. Ben Shepherd

    Ben Shepherd New Member

    Signed up to reply as this was the top Google hit for "enter the password for credential storage 4.4". Thanks for the tips. On my Motorola Moto E (unlocked on Vodafone UK), I was able to get around this problem. (I was trying to install a certificate for my work's WiFi.) I didn't have to enter a wrong pattern though as the OP describes.
    1. Turn off screen lock.
    2. Install certificate. I was then told I needed to set up screen lock.
    3. Set up screen lock as before.
    4. Certificate installed!
    Bizarrely, I didn't have this problem last time I tried to use this certificate on an identical phone. (I bought the phone a couple of weeks ago, but had to have it replaced because the internal speaker wasn't working properly.)
  15. nonedone1

    nonedone1 New Member

    Hi,

    Following steps worked for me for Galaxy S4 running 4.4.4

    1. Set up a pin lock
    2. Restart the phone
    3. Enter the correct pin
    4. Try to install the cert. This time, it did not bug for the credential storage password.

    Thanks!
  16. CaiusTse

    CaiusTse New Member

    HAVE TRIED ALL THE SOLUTIONS MENTIONED ABOVE but still failed to get rid of the credential storage password matter of my Samsung Tab S (T700). The problem dates back to yesterday after I cleared all credential storage as to cancel the screenlock, following some instructions to deal with the None button grayed-out condition. From then on whenever I tried to access the VPN sector the credential storage password thing just popped out. I have tried out many possible solutions to the problem, including setting a pattern and input it wrongly then get verified via google account, or resetting my device or whatsoever i found online up till now, but still couldn't settle it down.

    Could anybody give me a hand????
  17. Leej5387

    Leej5387 New Member

    I signed up because of this issue with credential storage changing your phone unlock method in 4.4.2.
    I've done a lot of searching for a work around as i have used pattern unlock on three previous phones and wish to continue to do so while still being able to use VPN.
    I have two phone, both running Android 4.4.2. One is Galaxy S3 (SGH-L747M kernel 3.4.0-1784548), the other an inexpensive Alcatel One Touch Evolve 2 (4037T kernel 3.4.67). With the Galaxy I have to have either a PIN or password to use VPN, no pattern screen unlock. Even though I don't require it I installed FoxFi, ran it and it did not require any changes to the unlock method. I even tried running the apk file that they link to, that is supposed to overcome the PIN lock requirements, didn't do a thing...so much for that.

    I have also come to find out that once a phone is at 4.4.2, there is no going back to an older android version...unfortunately. I was hoping to get around all of this by going to an older version.

    However, upon adding some VPN information (locations) into the Alcatel, I was surprised that there was no request to enter a PIN, nor any change made to the way I unlock the screen. So much for this annoyance being blamed solely on Android KitKat.

    I can understand the need for security on a phone, but the method used should be up to the owner, and if your are going to force someone to use a PIN, then require that only when the application (like VPN) is to be used, don't apply it to unlocking the screen.

    I really hope that there is enough of a backlash over this that it is remedied.
  18. athurschwell

    athurschwell New Member

    OK, I'm feeling a little desperate (and pissed off). I have a Galaxy S4 running 4.4.2. Nothing is working. I'm hoping that someone has come up with another alternative method for getting me past the "credential storage password" pop-up. Thanks --
    Adam
  19. deepak1510

    deepak1510 New Member

    U juz have to do iz, if u r using "slide lock " juz change it to "patter lock " n go to d option wer itz asking "type the credential password " voila, now it wont ask password anymore, maybe its android prob, they forgot to update patter lock in some place such as "VPN" HAHAHA
  20. nanunh

    nanunh New Member

  21. profman

    profman New Member

    my Phone is Xperia ZR and this way worked on my Phone
    Thank You
  22. Androidatic

    Androidatic Member

    WOW! This worked perfectly. I've been trying to get Foxfi to work since the 4.4 update. Finally got 5.0 and this trick works now. The only problem is that it requires me to put a lock on my phone which I don't like to do .
  23. rugg

    rugg New Member

    I read the fine print on the foxfi ap and it says to do the following:

    first clear credentials (settings, security, clear credentials)

    after you do this you will need to lock screen to none. To do this go to settings, lock screen, screen lock (put the password you used for the foxfi screen lock) then choose none as an option. This will remove the screen lock pin when you are not using the fox fi. The fine print on the foxfi ap says that in order to get this ap to work with Verizon and bypass their $20 a month hot spot fee, they need to add a certificate to the phone. Verizon views this as a change in security and then Verizon requires a password because the security of the phone is being changed.
  24. Androidatic

    Androidatic Member

    Thanks for the info.

    It's an inconvenience to have the screen lock, but at this point I'm just glad that Foxfi is working. I don't want to chance breaking it again.

    I'll just deal with it and enjoy the unlimited data that I pay for. o_O
  25. abbychia

    abbychia New Member

    I upgraded my Samsung S3 to an S5 (had to pay again for the foxfi unlock for unlimited foxfi use) and had the same lockscreen issue I had with the S3. Found this thread. again. Set a pattern for the lockscreen. Deliberately did the wrong pattern 5 times. Got the "PIN code required" message (no google login option). Did the correct PIN. Then rebooted the phone to start over and VOILA! No more lock screen :) Like Magic. Don't know how or why but foxfi worked great, no new security certificate issues or lockscreen codes needed.

Share This Page