Fixing the Nexus S power button issueTips


  1. priZm89

    priZm89 New Member

    Hello everybody,

    I have had the Nexus S for a while now, and about 5 months ago started having the power button issue where it won't lock or unlock the phone. Being that the issue was irregular, I figured it was a hardware issue. After finally getting fed up enough I decided to open the phone and see what I could find.

    What is happening, is there is a ribbon connector directly across from the power button on the back of the phone that gets loose or disconnects itself, and this is why the power button is not working. All you have to do to fix this is open the phone up and reconnect the cable. You can do this by removing the battery and six screws from the back of the phone. You cthen have to pop the sides off of the black piece that runs around the screen. This part is tricky so be careful not to break it. You can then pull the back internal back off the phone and reveal the electronics of the phone. Simply reconnect the ribbon connectly right next to the power button and your power button will work.

    This is what worked for me - be careful while doing this as you will be around all the electronics of the phone. Don't blame me if you screw it up while attempting this.

    Advertisement
    dimfisch likes this.
  2. Big Dog KMc

    Big Dog KMc Well-Known Member


    You should also Post this up on XDA as well. Perhaps Rootzwiki too.
    geoff427 likes this.
  3. sumitvasudev

    sumitvasudev New Member

    i have nexus s,,,, it was working well but suddenly it got off and now its power button is not working, so mu phone is off now and doesnt start again,,,plz suggest something
  4. jabyandroid

    jabyandroid New Member

    If your android device power button stops working, out of nowhere, try the recovery below.

    Slide the battery in while the device is connected via usb/power cable.

    Here are some detailed steps to help you get it right:

    1. Disconnect the usb/power cord from the device.
    2. Remove back cover from the device.
    3. Remove battery, and leave the back cover off. You will place the battery back-in in a second.
    4. Reconnect the usb/power cord to the device and then to your PC.

    I’m not sure if the cord needs to be connected specifically to a laptop or if connecting the device to a power outlet is good enough. In my case, I connected the Nexus S to my laptop.

    5. Now, while the device is connected, plugin the battery. This is the key step.
    At this point, the device shows the battery charging animation, the black/white one on fullscreen, the one that is shown when the device is powered-off and charging. The device had not shown this image in a very long time, while the power button issue was going on, so this looked promising.

    6. Now, I pressed the power button, and then the phone started to boot-up.

    Prior to doing this maneuver though, I had cleared the device of all files, and also performed a factory reset. The device had no root or anything done. Even after the factory reset, the power button issue was still persisting. So, maybe a combination of “factory reset” + “battery connect while usb connected” method is the recovery. I’m not sure. Also, I may have tried the “battery connect while usb connected” method before, without any results, but I can’t recall. So you may want to try the “battery” method a few times before trying factory reset.

    Took me weeks to get to this point, so I want to share it with the world.

    The power button issue first surfaced for me around Feb 2012, then a few weeks later, the button started working again. Fast-forward to March 2013, the same issue resurfaces. That is why I'm fairly confident the issue is not hardware, but software. I took apart the device as that youtube guide shows to - and everything looked fine. The button clicked fine.

    I don’t know the root-cause of what introduced the power button issue, but I know of a recovery method that worked for me, and possibly a few other folks.

    So, no more app-workarounds necessary. No more hardware fixes, etc. However, thanks to those app workarounds, because they helped keep me afloat up to this point.
    TranCeChick likes this.
  5. greenbox

    greenbox New Member

  6. stephen1979

    stephen1979 Member

    I lost function of the power button a few months ago. Mysteriously it came back after a few weeks. It still acts up now and then, but when it does I just have to wait it out.
  7. TranCeChick

    TranCeChick New Member

    Holy Moses!!!!! Dude if I could jump through my laptop and hug you, I would. :D
    My power button randomly stopped working. I tried your suggestion an tho I didnt get the battery chargining animation, the phone just rebooted on its own, it worked. Immediately after rebooting it didnt but after giving the phone a minute or two it did.
    Thanks for deciding to share with the world.
  8. dimfisch

    dimfisch New Member

    I tried this, and indeed the ribbon was disconnected, but it wasn't the power ribbon, it was actually the longer one just beneath, which I think connects to the display... Anyway, I reconnected it properly, but that didn't change anything, my screen still remains completely dark.

    Tried it again and again, and still nothing :(

    I know the device really is running because the chips are getting hot. So my guess is the screen is somehow not receiving the right signal.

    Any further tips? Besides throwing the phone away and bringing it to a pro shop.
  9. YddEd

    YddEd New Member

    Would you mind posting pics so I could see the ribbon? I don't see a ribbon.
  10. tony_nexus

    tony_nexus Member

    Thanks for the tips. The video was helpful, I'll try re-seating the connectors again. My solution was to use a Klick button which goes into the earphone jack. There is an accompanying app which can be programmed to react to a single, double, triple or long press of the klick button. I have a single press set to open messaging though it can be any function. Pressing the Klick button wakes up the phone just as if I had pressed the power button. No rooting required. A couple of bucks for the button on eBay. The downside is I can't power off the phone.

    Plugging the phone in for USB charging also wakes up the phone but I don't have a charger all the time.

Share This Page