Flash a Sprint RUU to an Alltel Phone?


  1. Murrfk

    Murrfk Member

    I have an Alltel phone that I need to put a Sprint Radio 1.04.01.09.21 Radio Rom on. I can flash the radio, but when I flash that radio (which is an early sprint radio) the phone will reboot. If I flash a different sprint radio, it will work fine, but I need that earlier sprint radio.

    So I tried to flash a compatible sprint RUU, and got a "customer id error". Is there any combination of gymnastics that I can do to get either the sprint ruu flashed on the alltel, or somehow get the 1.04.01.09.21 radio to work? I suspect that radio is not supported with 2.1 as it was originally on 1.5, but I don't know for sure.

    Any ideas?

    Advertisement
  2. Murrfk

    Murrfk Member

    Okay. Now another Sprint Radio Rom doesn't work. These are the roms I am flashing:
    heroc.radio-1.04.01.09.21-signed.zip
    heroc.radio-2.32.40.11.09-signed.zip

    Both cause the phone to reboot. Is it because the are signed? Do I have to rename them?
  3. Murrfk

    Murrfk Member

    I flashed WildHeroc RC4 and was able to change the radio to 1.04.01.09.21, so this solved my problem.
  4. LBPHeretic

    LBPHeretic Well-Known Member

    It seems like you figured this out on your own. Good work, man.

    The radio you used looks really old, but I guess that is why it is working for you. Thanks for following up in this thread.
  5. Murrfk

    Murrfk Member

    Thanks. While I was able to get the radio onto WildHeroC, I found that EPST wasn't available so I could not enter any ##commands, like ##PRL# or ##DIAG#, which I needed.

    So, after further research, I was able to put Fresh 2.3.3 on, which has the ##commands, AND it is running with the radio I need.

    I still don't know why the stock Alltel would not take that radio. I thought any CDMA hero radio would work.

    Anyway, I NOW have the phone where I need it to be, which lets me monkey around and learn.

    Thanks again.
  6. Murrfk

    Murrfk Member

    I wanted to try the original sprint rom (1.29) on the phone. To do this, I had to superCID the phone using unrevoked_forever.zip. I kept having a [131] Customer ID error when trying to flash Sprint onto the Alltel phone. The original CID was ALLTE001. Now it is 11111111

Share This Page