Flash Recovery Error. 4ext. No Space left on device. Other threads don't help


Last Updated: 2011-09-12 12:03:44
  1. dewmaster07

    dewmaster07 Member

    Let me first say that I have spent nearly 2 weeks searching for a resolution to this problem and have read countless threads but none were able to help.

    I am Running an HTC Incredible S
    Android version : 2.2
    Baseband version (Radio): 2.15.10.07.07
    HBOOT- 0.92.0000

    I am trying to replace my CWM Recovery 5.0.1.0 with this 4ext recovery so that I can Install Android Revolution 1.1.7

    These are the methods I have tried.

    1) Terminal Emulator
    I placed new recovery in root of my sdcard and renamed "recovery.img"
    open terminal
    type su
    (got root)
    type flash_image recovery /sdcard/recovery.img
    then I receive error "error writting recovery: No space left on device

    I tried a different version of a 4ext recovery and still received the same error.
    I tried formatted SD Card to FAT32 = same error
    Tried formatting internal memory = same error.

    2) CMD Prompt through Windows PC
    I have the SDK kit installed with ADB
    Enable debug mode and plug phone in
    Placed new recovery in c:/ root
    Open cmd prompt on PC
    type cd C:\android-sdk-windows\platform-tools
    type adb shell
    type su
    type flash_image recovery /sdcard/recovery.img
    receive error "error writing recovery. No space left on device

    3) Fastboot
    Hold down power and volume down button
    Select fastboot
    Open cmd prompt on pc
    type fastboot devices
    HT11BHJ04273
    (change dir to location of new recovery)
    type cd c:/
    fastboot flash recovery recovery.img
    sending 'recovery' <4292 KB>
    writing 'recovery'
    receive error FAILED <remote: not allowed>
    finished. total time: 0.674s

    I even tried
    fastboot boot recovery recovery.img
    cannot load 'recovery'

    4) CWM Recovery Flash Trick
    Navigate to the downloaded clockworkmod recovery
    copy name of file and change new recovery.img name to the name you just copied.
    Make sure to change the name of the original cwm recovery.
    Open rom manager and select flash.

    Please help me install a 4ext recovery. I am going insane because I feel like I have tried everything.

    Advertisement
  2. iowabowtech

    iowabowtech root@android:/ #

    This is the original incredible forum so we may not be the best source of info. However, I have done a LITTLE reading on your phone and I would offer this:

    We can flash alternate recoveries in hboot with s-off. I noticed they got s-off for your phone so it may work similarly. What we do is zip a PB31IMG containing the recovery.img you mentioned in addition to the android-info.txt from what I believe to be a stock recovery img. Then we place onto the root of a FAT32 formatted SD card (format key for proper file recognition). Then power off and go directly into hboot...for us that involves holding volume down while pressing power button. At this point, the phone searches for and finds the file on SD. Then use volume up to load it after prompted. It seems you would name your file PG32IMG according to some info I noted in the Inc s forum at XDA.

    Edit: ignore the "thumbs down" symbol. Must have accidentally ticked it and i can't get rid of it with an edit.
  3. dewmaster07

    dewmaster07 Member

    s-OFF is off.
    I zipped the new recovery.img with the android-info.txt and named it PB31IMG.zip as you said.
    Booted into HBOOT.
    Hboot asks if I want to upgrade.
    I say yes, and then it said
    Update failed - PU
    I reboot device and go back to Android.
    Custom recovery did not work.
    Any other ideas.
  4. iowabowtech

    iowabowtech root@android:/ #

    As I mentioned, yours needs to be named PG32IMG. Each device has its own recognition filename. You used the one for the original inc. Sorry if i confused the matter, I meant to use ours as an example only.
  5. dewmaster07

    dewmaster07 Member

    renamed zip file to PG32IMG.zip
    rebooted to HBOOT and update was not found.
  6. dewmaster07

    dewmaster07 Member

    I tried again using PB31IMG.zip
    This time it said the recovery was updated successfully
    However now it just stays on the htc incredible screen.
  7. iowabowtech

    iowabowtech root@android:/ #

    You may not need to add the .zip in the filename. Depending on how your computer handles file extentions, it will already know its a zip. So just call it PG32IMG.

    Yeah you don't want to use the filename for our phone or any other except your own. It wont work.
  8. dewmaster07

    dewmaster07 Member

    PG32IMG does not work. It is not detected.

    PG31IMG does not work. It needs the .zip extension.

    PG31IMG.zip is detected. It asks to update the recovery.
    I tried one recovery and it said update was successful but then the phone rebooted and hung at the HTC Incredible screen.

    When I tried a diff recovery it would detect the PG31IMG file, say that it was updating and then come back with an error -PU

    I don't think HBOOT is going to help me.
  9. iowabowtech

    iowabowtech root@android:/ #

    That's strange, its a pretty universal method for android. You sure your recovery.img is a verifiable download. Did they provide an md5 so you can check file integrity?
  10. dewmaster07

    dewmaster07 Member

    Some of the recoveries have an md5. Some contain a folder called META-INF.

    What do I do with the md5 file or META-INF folder?
  11. iowabowtech

    iowabowtech root@android:/ #

    I'm speaking of the file you downloaded for your new custom recovery, the zip. Many times, the developer will post an md5 so you can check it post download and make sure it matches. If it does, that rules out an incomplete download, etc. All I can say is to download the original file again and retry producing the flashable zip. Make sure you only have one IMG on your SD card at any time and I'm assuming you have already formatted your card to fat32 as mentioned earlier since you didn't indicate otherwise. If all that fails on a subsequent effort, I'm afraid I'm out of ideas. I'm simply not knowledeable enough about your phone or this custom recovery to know any of the glitches you may encounter which may be specific to this setup.
  12. iowabowtech

    iowabowtech root@android:/ #

    Also, are you sure its not already packaged for flashing? Maybe all you have to do is rename it? I've been posting from my phone all day so I havent had the chance to download a file from your linked thread and check out its contents.
  13. dewmaster07

    dewmaster07 Member

    Checked MD5 and file is good.
    Tried a diff recovery again and same result. "error - pu"
    Someone has got to have a solution.

    If I instal Android revolution using clockwork mod 3.0.0.8 the phone just sits at the HTC incredible logo.
  14. iowabowtech

    iowabowtech root@android:/ #

    Ok so now I got to a PC where I could investigate better. Looking at the 4EXT recovery thread, it appars to me without reading through a huge thread that you can flash it from within your pre-existing recovery, is that the case? I haven't seen that option to change recovery before but are they just talking boot into CWM, then install zip from sd, choose zip from sd, and load it that way? Intersting if so.

    The other method seems to be to simply install the one click to the PC, then hook phone into PC via USB cable, enable USB debugging, then run what appears to be a reflash utility similar to the unrevoked tool. Only stipulation there I'm assuming would be the correct USB recognition driver for your device. You're clearly far deeper into this that myself but it seems like the adb route isn't necessary.
  15. dewmaster07

    dewmaster07 Member

    Tried "runme" I get a remote error and recovery does not flash.

    As far as installing the 4extrecovery within clockwork mod recovery this also fails. I go to select zip and select the recovery. It says something about a write error and then aborts.

    If I put the recovery in a zip called update.zip I can select the instal "update.zip" option in cwm and then the 4extrecovery will come up.
    However if I reboot the device the old cwm recovery comes up.
  16. iowabowtech

    iowabowtech root@android:/ #

    I see. Re: the "remote error", are you sure you have the USB drivers installed. Because you're using ADB, I'd have to guess the answer is yes but just making sure. What we used to recommend was temporarily loading HTC sync to the PC which autoloads the device driver. No need to actually run the program, you can opt out at the last minute but by that time, the driver is already in place.

    Just kicking rocks here. Also, depending on which version of Win you have, perhaps try running as administrator. And you're in "charge only" mode when hooked to PC right? I'm guessing that's the interface you need for the utility.
  17. iowabowtech

    iowabowtech root@android:/ #

    One more thing, how big is your SD card and how much free space do you have on it? Also, check how much space you have on your internal phone storage.

    The reason the fastboot method failed is because it'll only work whe running the ENG bootloader, same as our device. Both the earlier methods you tried gave a lack of space error. There will likely be some temporary files that need to be written to, I believe, the SD card. Just thought I'd add to check the internal space since I'm not 100% on the write location.
  18. dewmaster07

    dewmaster07 Member

    I am using Windows 7 Ultimate 64bit
    I did not do HTC sync to get the drivers but I am sure I have the correct drivers installed.
    I will try "Run as Administrator" again and let you know my results.
    My SD Card is 8gb Class 6. I have 6.5gb free but have formatted completely and tried with no success.
    I have internal memory of 8gb.

    What are these temporary files you speak of?

    Off topic but I just tried MIUI.us rom 1.92 and its awesome.
  19. dewmaster07

    dewmaster07 Member

    Results of "Try as Administrator"
    = Did not flash
    It said flash_image not found. That only makes since becuase I just recently updated my rom to MIUI.
    I do not remember the correct commands to push flash_image to the device. Even then I do not believe it will work.
    Any ideas?
  20. iowabowtech

    iowabowtech root@android:/ #

    You clearly have plenty of cardspace so the insufficient space notifications are puzzling. It's my belief that the pc flash tool would likely write some temporary files to the card during the flash process so you may need a little more card space than the size of the recovery itself. That's a non issue in your case though because you have tons of space available.

    The only one that seemed to almost work was the fastboot flash but again, it will fail unless you use the engineering bootloader and thats a lot of work for a maybe especially when all the other avenues have failed. Sorry I couldnt be more help man.
  21. dewmaster07

    dewmaster07 Member

    I followed this tutorial on installing ENGhBOOT and everything went smoothly. However when I reboot into hboot it looks as if the hboot did not change. My hboot does not look like the one in the screenshot even though everything worked fine.

    After it was installed I tried using hboot to flash the recovery using the PB31IMG.zip file. It said recovery was installed successfully however upon boot into recovery it hangs at the htc incredible logo screen.
  22. iowabowtech

    iowabowtech root@android:/ #

    I strongly believe it won't work with that filename. Besides, if you loaded the ENG hboot, retry the fastboot commands from your first post. If it took, you shouldn't get the remote not allowed error this time.
  23. dewmaster07

    dewmaster07 Member

    Using fastboot still results in a "remote error"
    I am trying to flash another hboot
    Will report back.
  24. dewmaster07

    dewmaster07 Member

    Hboot 0.96.2 installs but upon reboot my hboot stays at 0.92.0

    How do I change my hboot.

    I'm going nuts.
  25. iowabowtech

    iowabowtech root@android:/ #

    I've always changed hboots right in the bootloader. Again, its an IMG file. Same deal as before but different contents to flash bootloader. I'd hope there's a thread somewhere for your phone that contains the various hboots, radios, etc. They're all flashed the same way unless your phone is vastly different from anything I've seen before. Be careful though man, you're doing a lot of security off flashing. I don't want to see anything irreversible happen to your phone.

Share This Page