Flashing and rooting overview


  1. Cougar

    Cougar Well-Known Member

    Or, "how I learned to stop worrying and love the root".

    As discussed elsewhere, I've been a Galaxy owner since release day on O2 UK and have been following the forums here for a while. I've had all the usual problems (NPS being useless, etc) and found the forum to be invaluable, so thank you.

    I wanted to update the firmware, but found there's almost too much information around. Lots of updated / contradictory information, and some of it requiring convoluted hacking of text files etc. I eventually took the plunge, and made notes as I went. Hopefully, this will be of help for other new users.

    After reading, I decided there were two stages to this. First, back up the phone so if it all went west I could roll back. Second, get the firmware on it.

    Booting in various modes:

    With the phone off:

    Fastboot mode - call + power
    Recovery mode - vol-down + call + power (hold home + back to exit)
    Download mode - vol-down + ok + power

    To enable root and back up the phone: (update - this method appears to have been blocked as of firmware rev. II5, should still work for IH8 and earlier)

    To enable root and back up the phone:

    Get recovery image from http://www.megaupload.com/?d=8SAFKOIN (see http://forum.hdblog.it/showthread.php?t=3995 for details)

    Get recovery flasher from Android Rooting in 1-click (limited time only… until it gets patched)

    Copy recovery.img and rectools.tar.gz files to /sdcard
    (tar.gz must be the root of /sdcard)

    copy the recovery flasher .apk to /sdcard and install it

    Run recovery flasher
    Choose "backup recovery image" just in case

    Enter sdcard/recovery.img as the path
    Choose "install custom image"

    Boot into recovery mode
    Run a nandroid backup
    Enable root if desired
    Reboot

    To flash the firmware:

    Get Odin + H7 firmware from MEGAUPLOAD - The leading online storage and file delivery service

    Get H8 firmware from RapidShare: 1-CLICK Web hosting - Easy Filehosting and unizp it to give you a .tar file. Alternatively, you can use the latest I5 firmware here, there's links to it elsewhere on the forum - I'm using H8 as an example as this was the latest when I wrote this.

    Edit the .tar file with 7-zip to remove cache.img (to remove CSC branding) - 7-zip handles .tar files in a vaguely sensible manner, unlike things like WinRAR. 7-zip can be had from 7-Zip

    Boot phone in Download mode
    Run Odin
    Follow instructions here The Chronicles of Cjeni a.k.a. Dejan Cencelj: Flash ROM Samsung I7500 Galaxy for dummies - essentially you're adding your freshly modified .tar as a one-file update, along with the orion.ops file supplied with Odin. The web page is nice and clear.

    Ooh, new firmware.

    Advertisement
  2. Rastaman-FB

    Rastaman-FB Well-Known Member

    wow, thanks for this im going to do it when i get home
  3. Cougar

    Cougar Well-Known Member

    If it works, I accept payment in most major forms of alcohol. If it doesn't work, you ain't seen me guv, right?
  4. Rastaman-FB

    Rastaman-FB Well-Known Member

    accepted

    the disclaimer is good aswell

    if it works ill just tell you it failed :p
  5. bitxboi

    bitxboi Well-Known Member

    just to made it clear, what is it 'root' for?
  6. KlaymenDK

    KlaymenDK Well-Known Member

    Awesome, I think you just sold me on the rooting thing. :D

    Only, to grab those files I'd need to sign up at that Italian forum ... unless I could convince you to edit your post and attach the files you refer to? That way, it would really all be in one place! :cool:

    Please pretty please with whipped cream and a cherry on top? :p

    Edit: I7500XXII5 file available at:
    MEGAUPLOAD - The leading online storage and file delivery service
    and Send big files the easy way. Files too large for email attachments? No problem!
  7. Rastaman-FB

    Rastaman-FB Well-Known Member

    so does this go back to normal if you reboot?

    read this

  8. Cougar

    Cougar Well-Known Member

    Sorted, sorry for any confusion.

    The downloads on the Italian forum is a text file. The text file contains the megaupload download link, which I've reproduced here. I'm not quite sure why they've done it this way unless it's to increase membership, not much use to me as I don't speak Italian.

    If this is a problem for anyone, I'll remove it. For completeness, the orginal page is here, all credit to them. UPDATE 28/08 - V3! - HOW TO - ROOT/RECOVERY IMAGE update, wipe, backup and restore! - HDblog - Forum
  9. Cougar

    Cougar Well-Known Member

    Not that I've noticed. It does reset the recovery partition if you apply new firmware though, but you still have the flasher and .img on your phone so it's 30 seconds' work to reapply it.
  10. coipu

    coipu Active Member

    it also worked for me by using fastboot flash recovery recovery.img in a command window opened from tools folder of android sdk, the flasher apk did not work on my phone for some reason.
  11. pegasus21

    pegasus21 Well-Known Member

    You should add a disclaimer that this rooting method may break in the near future since google has already fixed this root exploit in their source. A better and long term rooting process is to either replace the recovery image in the tar files or use fastboot to flash recovery.
  12. Cougar

    Cougar Well-Known Member

    Good point. And good to know. As and when that happens, I'll be throwing myself back at the mercy of the forum for help with that (-:
  13. z0mbi3

    z0mbi3 Well-Known Member

    Am I missing something here , i put the files from v3 in the root of my sd card, but the recovery flasher app won't recognize it. Just says invalid recovery image, where I'd expect to be able to click flash.
  14. pegasus21

    pegasus21 Well-Known Member

    By sd card, you mean the internal or external memory?
    /sdcard refers to the internal memory
    /sdcard/sd refers to the external memory card (ie your microsd card)

    You should be copying them to the internal memory. If you copied them to your external memory, copy the files to the other drive that shows up on your computer.
  15. z0mbi3

    z0mbi3 Well-Known Member

    ah that might be it then. 2 secs....
  16. z0mbi3

    z0mbi3 Well-Known Member

    ok getting somewhere but still not perfect. If I enter the path I get "Backup to flash custom recovery image" but it's greyed out. Backup Recovery Images is pressable, but i get a "Backup failed" error.

    This is on I5 by the way.
  17. Cougar

    Cougar Well-Known Member

    I think something may have changed with I5. Mine no longer works with the new firmware either. Arse.
  18. pegasus21

    pegasus21 Well-Known Member

    Then I guess Samsung compiled II5 with the exploit fixed. You'll have to use either fastboot or replacing the recovery from the tar file.

    Update: Ok I've decided to write up about how you can use fastboot.

    ADB and Fastboot Drivers
    ADB & Fastboot Binaries Updated with dll
    Recovery v3
    Busybox

    Note: Use adb driver from Odin instead of the ADB and Fastboot Drivers pack since that is for 1.6 which Samsung hasn't released for the Galaxy yet. Fastboot driver works fine with the pack.

    The link above is for adb and fastboot interfaces required for flashing. Each time you connect your device and there isn't a driver yet, just point it there and it should find something. If it doesn't, it's probably the modem and diagnostic driver which you can from HERE.

    1. Get all of the files above and put them into the same directory.
    2. Put rectools.tar.gz on to your phone's internal memory not the microsd card.
    3. Open up a command line interface and change directory to the place with the files.
    4. Type "fastboot flash recovery recovery.img" and press enter
    5. Off your phone and hold call + ok + power till the fastboot menu appears on your phone. Your command line should be able to upload the image if all goes well and reboot by itself after a while.
    6. Once your phone has booted up in normal mode, off it and this time hold volume down + call + power till the recovery menu appears.
    7. Select "Enable root su" from the menu and press home to confirm.

    Stop here if you do not want to use busybox or think it's too much hassle (Your copy function in file browsers will not work without busybox)

    8. Remount the mount points with read/write access by typing into the command line "adb remount"
    9. Once successful, upload busybox "adb push busybox /system/bin/busybox"
    10. Set busybox to executable with "adb shell chmod 4755 /system/bin/busybox"
    11. Next remove the cp command "adb shell rm /system/bin/cp"
    12. Relink cp to busybox "adb shell ln -s /system/bin/busybox /system/bin/cp"
    13. Optional: Install the other commands in busybox. "adb shell /system/bin/busybox --install -s /system/bin"

    That's it. You now have a working su (root), superuser app installed to manage access to su and busybox for those who go through with steps 8-12/13.
  19. tisti

    tisti Well-Known Member

    If you format the external SD card to have swap space will the H8 build use it? Last I read the build doesn't have swap support built into the kernel.
  20. z0mbi3

    z0mbi3 Well-Known Member

    Right Pegasus using your guide I've got my drivers installed, but fastboot just says "waiting for device" when I do the fastboot bit. Any ideas?
  21. Cougar

    Cougar Well-Known Member

    Good work, Pegasus.

    I've been wrestling with that driver all night. I've been using the dev driver supplied with the latest Windows SDK (.16_r1) which of course doesn't support the Galaxy. I'd managed to hack the .inf to recognise the Galaxy's Debug Mode connection by pulling the IDs out of DevMan to write the missing code, but fastboot was eluding me. How did you obtain the VID/PID for it, can I ask?

    With the fastboot driver, flashing the recovery image was a breeze. You just need to set it going before you start fastboot on the phone, the PC will wait for the phone forever but the phone only stays in fastboot mode for 15 seconds or so.

    Nice one, impressed.
  22. Rastaman-FB

    Rastaman-FB Well-Known Member

    i had this

    download the 1.5 r3 sdk
    point the the usb drivers and pick the Android test
    boot into fastboot and while its in fast book as quick as you can link that driver in device manager to the android test found in the 1.5 r3 sdk
  23. z0mbi3

    z0mbi3 Well-Known Member

    Pegasus, your downloads for fastboot and adb are missing AdbWinApi.dll. I've tried copying the one from 1.5 r3, but it just sits at waiting for device.
  24. pegasus21

    pegasus21 Well-Known Member

    I got the pid/vid from some post somewhere... i think it was receptor's blog but you can easily look up the info from the device manager. Under the device's properties (even for unknown devices) check the 3rd tab where there's the info on the hardware.

    As for "waiting for device", I'm guessing it's got to do with the driver or windows not seeing the device.

    These drivers are from 1.6r1 sdk. Not sure what's the diff compared to 1.5r3 but I decided why not just mod the inf for the latest sdk and both x86 as well as x64. :)
  25. Rastaman-FB

    Rastaman-FB Well-Known Member

    do what i did as i had exactly the same problem. fastboot does not detect the drivers. use you have about 15 seconds to point it to the test drivers found in 1.5 r3
Loading...

Share This Page