1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Flashlight apps not turning on LEDSupport


  1. surgerush

    surgerush Well-Known Member

    Just got a Samsung Exhibit II, I've downloaded Tiny Flashlight and the Brightest Flashlight, neither of them will turn on the camera LED. I checked the settings for the apps, the led thing is checked in the brightest flashlight app, couldn't find a setting for the led with the other app. Any help would be appreciated. Thanks

    Advertisement
    :
  2. mikabuc

    mikabuc Well-Known Member

    Try droidlight, I had problems with another flashlight app myself. Droidlight works for me.
  3. surgerush

    surgerush Well-Known Member

    I downloaded it, for some reason the app isn't working at all. Every time I try to open it it says "Sorry! The application blah blah blah has stopped unexpectedly. Please try again." I tried uninstalling and reinstalling it, didn't work. Any other suggestions? Would really like to use the LED as a flashlight at times.
  4. cannibal869

    cannibal869 New Member

    Try Torch - Next Generation

    I have the same phone and this is the only one that I've found that works so far.
    The only problem? after turning on for a few seconds, the program will crash (but the LED light will stay on until you force close it).

    at least it works...
  5. sohguanh

    sohguanh Well-Known Member

    The reason why some devices work and some don't with same app is because most likely the app has used some un-documented API in it's code. So while this may work for some devices, it will not work for other devices. I am giving you consumers an idea on what goes on under the hood of those apps.
  6. chanchan05

    chanchan05 The Doctor Guide

    Some flashlight apps need root access for some reason.
  7. MyTouch Slide

    MyTouch Slide Member

    Try LED Flashlight.... works for me and has a convenient widget
  8. lion7718

    lion7718 Well-Known Member

  9. surgerush

    surgerush Well-Known Member

    The only one out of the bunch that worked was the torch - next generation, but same here, it crashes after a few seconds... But that app just asks for way too many permissions for a flashlight... I dunno if I trust it to keep it downloaded.

    I hate that you can't turn on haptic feedback on this phone either... I like the phone to vibrate when I hit the hard keys, but there isn't even an option for it... I love this phone, but these little things about it keep adding up and bugging me.
  10. surgerush

    surgerush Well-Known Member

    The light won't come on for literally anything but the camera. It won't work with the bar code scanner, it won't work with the flashlights, there was something else that I can't remember now, but the camera and the camcorder are the only thing that will t5urn on the camera. I was excited this thing had an led on it, my first phone with a light, because I know I'd have a lot of uses for it, I can't believe that nothing is making this light turn on.
  11. mjmaddog

    mjmaddog Member

    " SPARE PARTS" from the market will give you end button control as well as feedback control....also extended controls paid app has cool stuff as well as a flashlight on its widget
  12. surgerush

    surgerush Well-Known Member

    Ended up trying this, haptic feedback still didn't make the hard keys vibrate, don't know what it's problem is. Love the phone so far, the little things aren't really that important, just would have been nice to be able to use. The main thing is the flashlight, that's the biggest thing that's bugging me.... Also my volume levels keep changing for some reason, they won't stay where I set them. Little things that bug you, but compared to the OV, which was my last phone, this phone is awesome.

    I actually found a couple of apps that said my device does not have a light... Why wouldn't they be recognizing the led on the phone?
  13. stedyone61

    stedyone61 New Member

    I have the same phone doing the same thing! One of the several LED flashlight apps I tried had a testing function. The only test button that activated the LED flashlight was 'autofocus looping'. Maybe the phone is too new? Released November 2011?
  14. doink123

    doink123 Member

    imhumanoid and surgerush like this.
  15. surgerush

    surgerush Well-Known Member

  16. surgerush

    surgerush Well-Known Member

    Is there any way to make it brighter? When I use the led for camcorder use, it's WAY brighter than when using it as a flash light. Might be normal, and it's definitely way better than nothing though.
  17. DeezMistaReez

    DeezMistaReez New Member

    Doink, can you explain why a flashlight app needs full internet access?
  18. doink123

    doink123 Member

    Hello Deez,
    I'm pasting you the permissions description...

    Flashlight Permissions:
    ============
    Why Tiny Flashlight needs so many permissions and how are they used:

    * TAKE PICTURES AND VIDEOS (CAMERA flashlight)
    - In order to start the camera flashlight (led flash) on some devices, Tiny Flashlight has to use a small part of the camera hardware and it needs this permission. Don't worry, I'm not taking any pictures or videos without your permission. Tiny Flashlight is just accessing the camera flashlight (led flash).

    * CONTROL FLASH LIGHT
    - This is the old method of accessing the camera flashlight on Android 1.5 and 1.6.

    *** As you know, Tiny Flashlight is free, but also is one of the best supported apps on the Android Market. Currently, this is the only app that supports almost all devices with camera flashlight (led flash) and fully supports all versions of Android (1.5, 1.6, 2.0, 2.1, 2.2, 3.0, 4.0). This takes huge amounts of time and effort and in order for Tiny Flashlight to remain the best flashlight on the market, I have to use ads inside it.

    The following permissions are required by Google's own ad provider (Admob) and Millennial Media (the biggest independent ad network). Both are respected industry leaders.

    * INTERNET
    - Used to load ad info from their servers. Nothing more.


    * READ PHONE STATE AND IDENTITY
    - Some Motorola devices have factory bugs. These devices don't have unique IDs and this became a problem for ad networks, because they can't function without it. There is a workaround for this problem by using the PHONE IDENTITY permission. This permission is used only for getting a unique id.
  19. curtis2073

    curtis2073 New Member

    Tiny Flashlight LED worked on my exhibit2
Loading...

Share This Page