Flight mode problemSupport

Last Updated:

  1. stranzer

    stranzer Member

    Has anyone faced this problem before i took my new Galaxy S2 (upgraded) yesterday from phones4u i was enjoying with the phone until the main problem got started i dont know but the flight mode is being activated on its own on the phone and my calls are being dropped and again after disabling the flight mode its being activated after 1 min...its really frustating me....when i went back to phones4u it was working fine infront of them and the told me it was my old sim card problem and it should be fine when the new sim card is activated but my new sim is activated like 2 hrs ago but im having the same problem even i tried other sim cards which i have O2..but no use..i called the phones4u tech team but they are saying that if the phone works fine in the store then it should be the network issue as he has done the basic factory restore....i never faced dropped calls with my current network Orange in my home.......:mad::mad::mad:

    any suggestions would be fine.....i will throw the phone on the face of phones4u guy if he doesn't take it back.....

  2. AhmedZubair

    AhmedZubair New Member

    I am also facing the same problem with my S2. The phone goes into Flight mode while on a call and the call gets disconnected. I also don't get full reception on my phone sometimes. Have you been able to find a solution?

  3. optio

    optio New Member

    I have exactly the same problem!
    SGS2 switches to flight mode during call. Switches flight mode again off after +- 1 minute.
  4. Zippyelise

    Zippyelise New Member

    I have this problem too. It spontaneously reverts to flight mode, though the symbol that replaces the signal bar is a 'stop' sign (circle with a diagonal line through it). It disables 3G and leads you to settings where flight mode is ticked and in mobile browsing packet data is turned off. If you change them they just revert back when you exit.

    Extremely annoying, I've only had the thing a week, it's great apart from this problem.

    I've done a factory restore and it's failed to sort the problem out :(

    Anyone else having issues?
  5. Baldi

    Baldi Member

    I had this happen a few times as well, the phone is just a week old.
  6. steslatt

    steslatt Well-Known Member

    Everyone who is having this issue post your firmware version. On the dialer press *#1234#
    It could be firmware related, there were lots of bugs in earlier firmware.
  7. JFSG

    JFSG Well-Known Member

    Thanks ^^
  8. samwaltonyeah

    samwaltonyeah New Member

    I'm having this problem too! Very frustrating. When I dial that code, I see the following screen:

    PDA: I9100XWKF3
    PHONE: I9100XXKE7
    Build Info: Thu Jun 9 18:16:44 KST 2011

    Thanks for any help you can shed on this!

    In a supplementary question, does anyone know if there's any way that you can compose texts using a standard (old-skool!) 3x4/t9 keyboard on the SGS2? You can do it with the dialer, but it would be great to use the same functionality for the messaging and browser too.
  9. steslatt

    steslatt Well-Known Member

    Only way i've seen is this app
    samwaltonyeah likes this.
  10. evohicks

    evohicks Well-Known Member

    Yes you can, because I use it for messaging, but not sure about browsing. Haven't got my phone with me right now, but I think you go into the messaging app (I use handcent, not sure if its the same) then settings, then either keyboard type or input settings, or go into phone settings/ keyboard etc.. I'm sure someone will be along soon to point you in the right direction.
  11. Peter Bong

    Peter Bong New Member

    Hi... I'm having this problem as well since I bought the phone three days ago.. And was tried the method in dialer, *#1234#, and appear some information only. Is this method by dialing *#1234# can solve flight mode problem?????

    Any one have try this method before???? Effective???

  12. lotus49

    lotus49 Well-Known Member

    You have misunderstood. The purpose of this is to establish which firmware version your phone has so that a comparison can be made with other people who also have this problem.

    Dialling *#1234# will not (and was not supposed to) solve the problem.
  13. marica.marius

    marica.marius New Member

    I've the same exact problem.
    Any solutions yet?

    PDA: I9100JPKH1
    PHONE: I9100XXKG5
    Build Info: Fri Aug 5 2011
  14. rolfkvinge

    rolfkvinge New Member

    Same problem. I updated it last week to the latest version available, still happens, both when I call and when I receive calls.

    PDA: I9100XWKF3
    PHONE: I9100XXKE7
    CSC: I9100FOPKD2
    Build Info: Thu Jun 9 18:16:44 KST 2011
  15. matttye

    matttye Well-Known Member

    I'd be heading back to wherever I got the phone from and getting a replacement if I were you guys having this problem.
  16. Gearu

    Gearu Well-Known Member

    Might have driving mode initiated aswell, I think I had something like that going on, driving mode on this phone causes random chaos.
  17. ghaziwarrior

    ghaziwarrior New Member

    I also have this problem. In my case, some calls are maintained for some duration while others are cut after just a few words. The flight mode activates and then deactivates automatically, dropping the call. When I hold down the power button, flight mode is shown to be off, though if I quickly try and call someone back, I often am refused as it says flight mode is on I presume this is because flight mode takes a few seconds to deactivate.

    Here is my firmware information:

    PDA: I9100XWKI4
    PHONE: I9100XXKI1

    Build info: 14 Sep 2011

    I did a firmware update last night from the factory firmware (which had the same problem) to the latest. I received the phone only a couple of weeks ago.

    My questions are these:

    1. Is there someway to disable the automatic switching into flight mode or another hack that can get around this problem

    2. Is this a fault that I should return the phone for service under warranty or should I just wait for another firmware update?
  18. santhosh0123

    santhosh0123 New Member

    me too facing same issue. it automatically switches to flight mode during call (receive or make call) -- hope it will be fixed by next software update.
  19. kija987

    kija987 New Member

    I had this same problem and it was getting annoying. So i did a factory reset which did not help. But then when i did a stock firmware flash it worked for me. No more dropped calls :)
  20. ihsanh

    ihsanh New Member

    I have the same problem too.

    can you tell the way of stock firmware flash ? To which firmware you updated ?

    Here is my firmware information:

    PDA: I9100XWKF3
    PHONE: I9100XXKF1
  21. marica.marius

    marica.marius New Member

  22. AndersB

    AndersB New Member

    I experience this problem on the Galaxy Nexus with Android 4.0.1. Spontaneously going into flight mode. Disabling flight mode, when it has autoenabled itself often doesn't reconnect and I have to restart the phone.


    Core system
    android-build@apa28 #1

  23. tammopet

    tammopet New Member

    copy paste it on any forum please :)

    I had same problem on my gs2 just press power button a while for the power options to pop up then hold the flight button for like 10 seconds until you feel your phone rumble, right after I did this my phone connected to my network again and I finally started getting my text messages :p hope it works for you guys aswell!

  24. Crypticfortune

    Crypticfortune New Member

    I get the same problem as AndersB on my Galaxy Nexus (stock Docomo phone running on a Softbank SIM card, if that matters). It just spontaneously goes off of the cellphone network and reports itself to be in "airplane mode." I can hit the button to "turn off airplane mode" once, but it never actually gets back on the mobile network, and then the "turn on airplane mode" button gets grayed out... I have to restart the phone to get service back. Very annoying...

    Android version: 4.0.1
    Baseband version: SC04DOMKKD
    Kernel version: 3.0.1-ge2433f2 android-build@apa28#1
    Build number: ITL41D.SC04DOMKKD
  25. Android005

    Android005 New Member

    what to do if it says phone : UNKNOWN ?

Share This Page