Flying Mouse - Keyboard: need help


  1. bthoven

    bthoven Well-Known Member

    I bought this mouse together with one of Amlogic Android TV Box. The remote works very well as cursor control and very fast response, but with two missing command keys, i.e. Home and Menu.

    Without Home and Menu command keys, I still need to keep the included IR remote which can perform those two commands.

    Anyone who also owns this remote could confirm me whether the remote really doesn't have these two command keys? (or need some key combination to make it work?)

    Thanks in advance.

    Attached Files:


    Advertisement
    :
  2. cajen

    cajen Member

    On the Enjoy TV box, F1 is Menu and F2 is Home. I'm not sure if this is the same on other boxes.
    bthoven likes this.
  3. bthoven

    bthoven Well-Known Member

    cajen...thanks. I'll try tonight when I'm at home.
  4. bthoven

    bthoven Well-Known Member

    cajen....f1 and f2 won't work for me. Whatever f won't work. Not sure can we do any keymapping?
  5. cajen

    cajen Member

    There is an app called Button Remapper for rooted devices. I have no idea if it will work with these boxes or not. It was removed from the android market, but if you google buttonremapper.apk, you should have no problem finding a free version.

    There is also an app for rooted devices called root explorer, which should allow you to see the keyboard layout files. They should be in the system/usr/keylayout directory. This shows which function each key performs. I'm not sure exactly how to, or if you can, edit the keylayout file.

    I would try these methods myself, but I am currently stuck with a bricked device while I wait for a new one.
  6. bthoven

    bthoven Well-Known Member

    cajen...thanks a lot for your advice.

    Unfortunately, I still can't root my box. Gingerbreak doesn't work with my box.

    I hope in the future, there might be someone able to root it.

    Thanks again.
  7. cajen

    cajen Member

    Have you tried Z4Root?
  8. bthoven

    bthoven Well-Known Member

    Thanks. I understand that Z4root is for rooting android 2.2?. Mine is 2.3 :(
  9. Dual_HD

    Dual_HD Well-Known Member

    No, Only Geniatech Android TV box has the shortcup support for F1-F10
    bthoven likes this.
  10. bthoven

    bthoven Well-Known Member

    Thanks. So I have to find a way to root my box in order to customize the keymapping. For now, ir remote on my left hand, and fly mouse on my right hand :)
  11. dlkorean

    dlkorean Member

    Have you find the way to root your box? i have the same box too.

    If you can root it plz tell me.
  12. walteroa

    walteroa Well-Known Member


    i have another RC brand and ider a10 with same problem... grrrrr.
    also GB without root.. grrrrr.

    did u solve the 2 RC problem?
  13. bthoven

    bthoven Well-Known Member

    Not yet..still can't root my box.
  14. walteroa

    walteroa Well-Known Member

  15. walteroa

    walteroa Well-Known Member

    bthoven likes this.
  16. AAHighlander

    AAHighlander Member

    Hi guys,
    I'm new here. This is my first post.
    I just got my Android TV os 2.3 Rockchip 2918 1.2G 512RAM 4G Flash
    Stock OS and everything.
    According to the ebay description, it support Bluetooth keyboard
    so i got the Bluetooth mini keyboard RT-MWK 100
    however, can't get it to work on the android, but it works perfectly on SONY PS3.
    Can't seem to find anything on the android setting or menu to activate the Bluetooth or to pair with a bluetooth device

    Does it really have bluetooth? If it does, how to use it?

    I've been reading many previous posts, what is 'rooting the OS'?
    what is the benefit? When do we need to root?

    By the way, i can get the Android to work on my Samsung 42" (older),
    can't get it to work on Sony Bravia EX720 55" (newer). Both support full HD.
    Is it to do with Australian Full HD 1080p 50 compare to US 1080p 60?

    thanks heaps everyone
  17. bthoven

    bthoven Well-Known Member

  18. PulseM

    PulseM Member

    While on Flying mouse issue , I have Geniatech ATV3000. The mouse can flick or slide pages sideways but Iam not able to scroll pages up and down unless I use Pg Up and Pg Dn buttons.

    How can I scroll pages up and down using Flying mouse waving action ?
  19. bthoven

    bthoven Well-Known Member

    yes, you can, just hold the left mouse button and wave up or down to scroll up or down. However, you can either scroll up or down only for each pressing/holding of the left mouse button. If you want to scroll to the opposite direction, you have to release the left button and press/hold it again before waving to the other direction.
    (I'm talking about using it with ider a10 box)
  20. PulseM

    PulseM Member


    Thanks. That is what I have been trying before writing here. It does not work on Geniatech atv4000 properly. (ICS 529 Firmware)
  21. bthoven

    bthoven Well-Known Member

    hi,

    Anyone has successfully map buttons on this remote for Android Home and Menu function? I have a rooted Android TV Bx iDer A10.

    Thanks in advance.
  22. walteroa

    walteroa Well-Known Member

    bthoven likes this.
  23. bthoven

    bthoven Well-Known Member

    Hi Walteroa,

    Thanks a lot. Seems to be a good alternative. Just wonder it will auto hide when not in use; or, say, when playing video?
  24. walteroa

    walteroa Well-Known Member

    confirmed. auto hide even when playing movies...
    auto hide timer is also configurable.

    good luck!
    bthoven likes this.
  25. bthoven

    bthoven Well-Known Member

    Tried it and it's really great. Thanks a lot.
Loading...

Share This Page