1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Flytouch 2General


  1. rocky289

    rocky289 Member

    Any feedback on these yet?

    Advertisement
    :
  2. Gianpaolo

    Gianpaolo Member

    I am too looking for some feedbacks about the Flytouch 2 (aka Superpad, Hype-pad and so on...).
    At the present you can see a review of this interestig tablet at the Android Tablet Forum Australia; you can also read some threads on the Flytouch 2 at the Slatedroid forum.
  3. rocky289

    rocky289 Member

    I have seen enough to decide I would like to get one of these.
    Next thing is to get one to my location at a resonable price.
    Are watching a few on eBay, but they are not there in great number.
  4. CameronB

    CameronB Member

    Okay, my first post here: I'll make myself useful by putting up a review. I'll save on useless niceties, and get right to work.

    I ordered the Flytouch2 from euogo.com. I've had it now for about 27 hours. So far, I must say it's a steal.

    The camera looks fairly decent. Not great, it will never replace your dSLR, but then, we aren't expecting it to are we? It has trouble compensating for poor lighting, so night shots are going to be trouble. No LED flash either.

    I'm pretty certain that the camera is performing up to spec with some of the advertised 3MP resolution. I haven't checked the resulting file size yet, I'll get to it, eventually. At any rate, in good light, it's not terrible, autofocus is... sketchy... but it's not terrible.

    It definitely has a gravity sensor, it knows which way is up. Accelerometers do work, the Tricorder app I downloaded can read the info from them... GPS reception is good with the antenna attachment. Just need a way to cache the maps now, if I ever want the world's most ridiculously huge GPS device.

    Battery Life seems short, on the order of 4 hours constant use at medium brightness. A larger battery would be really helpful, but I'm one of those weird people who want a device to work for like, 10+ hours at full tilt before needing a recharge, so I could get on an international flight, watch movies, play games, land, update my facebook, get to a hotel, check my email, watch some youtube, and then plug in to enjoy a European vacation.

    Capability wise, it eats Ipad for lunch, no doubt. Native support for USB keyboards and mice, they just work. It converts very quickly to an "Android Netbook". You can do that with Apple, but you have to jailbreak it first.

    USB thumbdrives are recognized too, and so are external USB hard drives. That is awesome. Your precious $500 Ipad's memory will fill up with a dozen HD movies, but your Flytouch2 is all about the expandability. I'm probably getting a 500Gb external just to have it. I'd love to snag a USB bluetooth dongle, that would nice to test.

    Built in Microphone, so it beats the Ipod touch there. Wifi is ready, I didn't get the 3g USB modem, sorry.

    Having a LAN port is nice too, in case the wifi configs don't go smoothly with your router.

    Using 2 memory cards is refreshing, you can load up with a couple of 32Gb cards, and you've got the Ipod's storage matched. The alignment is imperfect on those MicroSD slots, I accidentally slid my Micro card into the unit, just above the cage for the connector, but still underneath the plastic case, pulled it free with a scalpel, but I learned that you have to watch the alignment.

    My license key is apparently already "used", so I'm unregistered, which is a bummer. Support staff at Euogo have replied that they will get me a new registration key, which I'll need to update the software. I'd like to update the software.

    My unit seems to have trouble waking up from standby while a memory card is inserted into the upper uSD card slot. Popping the card free, and forcing a reboot with the power button gets the device to reactivate.

    Updating to a froyo rom image may resolve that issue, I'd love to find out... if only I could upgrade.

    I can get the android marketplace, no problems whatsoever. Youtube videos are mostly responsive, a few won't load, but for the most part, it works. Most of the free apps I've played with work without a hitch, and AngryBirds is nicer to look at on a 10 inch screen than it is on the Droid.

    Video playback is smooth, I haven't tried the HDMI output yet. Again, this option kills Apple's Ipad. I can use my tablet as an HD movie repository, and enjoy those movies on any suitably huge HDTV I want. Ipad? Notsomuch.

    All in all...

    A good buy. $205 American, plus $35 and change for s&H.
  5. molecular

    molecular New Member

    CameronB

    I got my Pad on Tuesday but then had to buy an adapter as they sent the wrong charger!!!
    All seemed O.K. until I put a brand new SDHC card into the top port. It seemed to recognize it, said preparing it, then said it was DAMAGED!!!!! Same in the lower port!

    Did you have to do anything to yours to get it accepted? I gather that there has to be a card in to get it to carry out a number of tasks?

    Any help would be much appreciated as my Chinese is limited to the Take-away meals!
  6. CameronB

    CameronB Member

    Mine worked like a charm, straight out of the box. Came with correct AC adapter, both uSD ports worked great, both USB ports also checked out with no trouble.

    The only issue I had was getting the registration to go through. The first license key was "already used". This morning I received my 2nd license key, it worked perfectly, and so I updated via the system update app.

    Nary a hint of trouble.

    Since I'm an electronics tech, I may consider getting a replacement glass screen, and I might also look into getting some better batteries. I haven't pried my unit apart yet, but some enterprising hackers have, around the intarwebz, and it looks like it's not too difficult.

    It would also allow me the chance to tweak the uSD cage, making misalignment less likely in the future.
  7. jtbnet

    jtbnet Well-Known Member

    Try formatting the sdcards in your pc for FAT32 with 4K block size... most work but a group of ones I bought didn't until I formatted them this way in the PC first... course for me the problem was with an original ZT-180 but could be same here...
    molecular likes this.
  8. molecular

    molecular New Member

    I will try your suggestion but my PC needs an adapter for the card so I have to wait till it arrives!

    Thanks.
  9. rocky289

    rocky289 Member

    Thanks for the feedback on this device. I havent bought one as yet. Waiting for a good deal on eBay.
  10. Naysses

    Naysses Active Member

    At CameronB
    When you upgraded... Is it Froyo (2.2) now?
    Is Euogo in the US?
    How long did it take from the time that you buy to get in your hands.
  11. kiddo69

    kiddo69 New Member

    Hi. I got mine yesterday, and generally I am very happy with the product, but now i have some troubles with the Android 2.1 Don't know is it the tablet or the OS, but once I logged with my account and registered with AMarket, I can't remove it, because generally i bought it for present, and want to remove my google acount from the system. I created additional account hoping it will replace the first one- no luck. Changed my password, from the pc, and then the tablet doesn't want to go to Market. Tried factory reset option, the tablet freezes, but nothing happens after that. Cleared all the cache and stuff.... dead end. Any suggestions or ideas, or anyone else with the same problem? Can't update, because can't register, didn't get a valid key yet.
    How to reset the device?
    Thanks
  12. rocky289

    rocky289 Member

  13. kiddo69

    kiddo69 New Member

    Thanks Rocky, will wait couple of days, really, don't want to flash, i am much better in drinking beer.
    Hope someone will come up with an app which resets the OS.
  14. kiddo69

    kiddo69 New Member

    I read that Zetthink has the same problem, and no clear answer yet.
  15. CameronB

    CameronB Member

    It took 7 days I think to get my Flytouch2 from Hong Kong. Fedex got it across the globe pretty darn fast, but from New Jersey to Upstate New York was slower. Of course, Veteran's day was in there too.

    I'm pretty certain that I still have 2.1 after my first update. There is another, second update available, but my tablet stalls out at the 25% mark and reboots back to normal. My current firmware is deb-r2.1.1001, the updated version is x.1170.

    I'm still trying to see if I can locate a .1170 update.zip file to toss on one of my uSD cards, but I don't think that Euogo.com is the programmer, just a dealer... I may shoot them an email.

    It's powered by WowPad, which is a useless piece of information.

    Aside from that, I simply wish the battery lasted longer, and charged more quickly. It's pretty obvious that the chinese went with lower grade power cells... but then, I expected that for a $200 tablet.

    I also find it to be a bummer that multi-touch doesn't work on my screen. There's no good reason why it shouldn't. Apparently that's a common feature among resistive screens... but it shouldn't be a problem if the engineers designed the screen intelligently... but then, they are engineers, and engineers are mostly idiots.

    I know this because engineers design medical equipment, and I hate them. They design things wrong. They always do.
    /rant

    Sorry.

    Aside from that, my little $250 tablet is pretty darn slick. I'm playing Empire Defense Light, and I hate it, because I can't beat the stupid thing... Unless there is some sort of "Level Up and become more powerful" option, I won't be getting the full version.

    Angry Birds was fun for about an hour, and now I'm at the limit of my ballistic capabilities. With out numeric power and trajectory readouts, plus timing information for the 3-way bird deployment, I'm unable to progress. Artillery gunners use Ballistic Computers, I want one too. I now also hate that game.

    I know, flame away, "It's fun", or "How can you hate such a great game?" "You should give it more time"... No, it's not fun. Flinging my birds at essentially random directions isn't entertaining, I need WAY more ammunition that what's provided. I just can't "Feel" the shot line-ups. Too many variables for my brain to solve via intuition.

    I actually paid for "Spaghetti and Marshmallows". I LIKE this one.

    I'm looking for a good (read: Good, and Free) pdf viewer, an office document viewer, and a note-taking app that I'll love. I don't even know what features I want yet, so I think that I just need to find a virtual keyboard that makes me happy first, and then everything else falls into place.
  16. rocky289

    rocky289 Member

    Does your Flytouch have the X220 processor?
    What was the range of the wifi?
  17. Rileysowner

    Rileysowner New Member

  18. kiddo69

    kiddo69 New Member

    Thanks.
    Still can't get it right though.
    Device is off> press power button+home+front pannel button> and you get a screen that says "press the required keys if you want to apply a factory reset" and you have a countdown timer. Pressing the front button together with the menu leads me to sequence of letters and numbers on the upper left, with the counter running. Any other combination interrupts the counter and the unit boots. Tried many times, cannot view the reset screen. The chinese folks stopped responding. I am changing my account password and giving it away like this. Cleared the cache etc, the only problem will be how to get the Android Market running...Fixing Android Market Access on 2.1 v1 through a Windows PC. Have to try this I guess. Well, thanks for the help. And still if any one has the key combination, can post it here.
  19. rocky289

    rocky289 Member

    kiddo69 likes this.
  20. benito65

    benito65 Member

    anyone gotten this tab to work with drm epub books from the library
  21. eprivate2010

    eprivate2010 New Member

    Hi. Just got my superpad. Had the same problem. Went to Settings, then the Privacy section and clicked Factory Data Reset. Please note that resetting will remove all downloaded apps (so back up) but not the bundled software, etc (that's what it told me) that came with the unit. It does appear that the tablet only allows one Google account at a time for a user. After resetting, I was able to access the market and appbrain sites. Please do note that the above solution may not work for you but it's an alternative. It's your choice. But I think it's better and less troublesome than flashing the unit. Hope you do fix the problem.
  22. Terry07

    Terry07 New Member

    I got my Flytouch 2 lasyt week and i am very impressed. I have one problem with it and that is the calendar. I can put an entry on the Tablet and it will update my g mail calendar. However if i put an entry on g mail calendar, it does not update the tablet.

    Any ideas?

    Terry
  23. CameronB

    CameronB Member

    So, I finally managed to locate the update.zip file to get my tablet to the .1170 firmware release. Using the System Update tool was not working at all.

    The update definitely wipes all your apps. So, I now must pay for a new version of Spaghetti and Marshmallows. The marketplace has not tracked what I paid for. Thankfully, I'd not paid for much.

    I should have known better, but just kinda hoped it would stay.

    SuperUser stayed installed, oddly enough, did not get wiped. Z4root reports that my device is rooted, but the overclock widget says otherwise... I suspect that the tablet is nand-locked in some way... the updates can access key files, but other things cannot yet. So I can confirm a 780 Mhz clock speed here.

    In my "System" app, I can tell that my build is deb-r2.1.1170, but the firmware version is 2.1, update 1, so not froyo? Kind of a bummer seeing as how gingerbread is on the cusp of release, but then, is that really a surprise?

    The tablet seems slightly snappier, but not much. So, the update may have cleared out a few snags in the coding, but it's far from jaw dropping.

    I like my tablet approximately 5 million times more than the Ipod Touch I had until recently, but since I'm bitter and cynical, I care more about what's wrong, than what's right. Thus:

    These are the wishes I have for the Flytouch 3:
    -Bluetooth Module (built in, or via expansion support)
    -Infrared Emitter, for data transfer, or BETTER YET! So I can change the channel on my freaking TV! My PalmIII could be used as a freaking remote, that was back in 1999. Why have we gone backwards?
    -512Mb minimum, so that uber android updates will run more slick.
    -Nand Unlock, for us hacker jerks who can't leave well enough alone.
    -Replaceable battery. Heck Yeah!
    -Better sensors. all those cool spirit level and compass apps? Most don't work. BOOO! We are SO CLOSE to having a real freaking tricorder here! I can tell that I've got 3-axis sensors, the tricorder app can read deflection in 3 dimensions, and my tablet clearly acts like it has a gravity sensor.

    I love the USB ports, and the support for keyboards and mice. I love the wifi. I wish certain videos would play on various websites, but I suspect flash just isn't perfect yet (or I need better than the default browser app)

    When 64Gb and 128Gb microSD cards become commonplace, my tablet will eat Ipads for lunch... but for the most part, it already does.
  24. manuk

    manuk New Member

    I got my flytouch 2 directly in China. I need help to set the GPS, because the manual is in chinese. It says I'm somewere near to Africa (actually I'm in Buenos Aires right now). If anyone can help me, I would apreciate it.
  25. eprivate2010

    eprivate2010 New Member

    The manual has a very short discussion on the gps. Am out right now but I will try to cite here the portion of the manual when i get home (got the english manual). Try getting a good gps app. Am not using it so I can't help you there.
    manuk likes this.
Loading...

Share This Page