Flytouch 3 Superpad 2 problemsSupport

Last Updated:

  1. lfc4ever

    lfc4ever Well-Known Member

    Frisco likes this.
  2. baxter61

    baxter61 Member

    i ordered from ******.com on the 1st july, and have not recieved it yet, 24th august, other people have ordred from ******, and its fine, but in my opinion, dont do it. they emailed me back, until i mentioned recieving a refund, then they stopped replying.

  3. calinmateo

    calinmateo Member

    HI ! I got my Flytouch 3 superpad2 after a bad flash vibrating !I tried to reset! nothing!still vibrating! any suggestions!!!! Thanks!!
  4. lfc4ever

    lfc4ever Well-Known Member

    Did you check which version you had before flashing?
  5. calinmateo

    calinmateo Member

    yes!I had Android 2.2-20110529!can you help me?I tried firmware from thechillahacher worked very fine,is base on 0316 ROM but I forgot the SD in and update start when the card pop out!Thanks

  6. weltall

    weltall Well-Known Member

    If reseting or holding the power button for a minute and releasing it doesnt help all you could do is wait for the battery to get depleted I think. After that you can always plug it back in power and after leaving it charge for 3 minutes try to power it on and see if it will work. If not maybe try to flash it with a different rom?
  7. lfc4ever

    lfc4ever Well-Known Member


    Hard reset is pressing in the reset button on the side of FT3. This is normally used when the unit does not respond.

    Soft reset is a factory reset by powering on the tablet holding down the power & menu & home buttons until you see the recovery screen start.

    Reflash using a new formatted sd card.
  8. calinmateo

    calinmateo Member

    I tried everything you said!still vibrating!!!What else I can do?Thanks!
  9. calinmateo

    calinmateo Member

    I tried that !still vibrating!that rom was good I used for one day and worked fine but i forgat my SD in and update start and my SD pop out!thanks!
  10. weltall

    weltall Well-Known Member

    Ahhh so it sounds like you bricked your tablet.. I am not sure what to say to that. If i was you I would just open it up, remove the battery, hold the power button for a minute and then reconnect the battery and see what happens. I would do that to make sure that the tablet would have not even the slightest ammount of energy inside to keep any bad settings.

    This is the bad thing with flashing systems and bioses. If it gets interrupted midway or is flashed with wrong firmware it does bye bye.. except of course if you are a pc expect and can fix it.
  11. calinmateo

    calinmateo Member

    I tried everything you said !still vibrating!thanks
  12. JJ2227

    JJ2227 New Member

    Ive recently purchased the superpad 2, flytouch 3,

    Model number P041, android version 2.2 V2.6: #4402, Build number FRF85B

    Battery is very poor, In some program red is replaced by blue and WIFI is very poor!

    Is there a firmware upgrade that will fix this or do I have the latest version.


  13. lfc4ever

    lfc4ever Well-Known Member

    I'm sorry to report that there is no firmware update, and the SP2 FT3 with P041 installed is a poor version of the FT3 with low end parts and low grade batteries.

    The best FT3 have disco10 installed as the firmware of choice.

    I would demand my money back and constantly complain to the supplier & paypal or credit card company until you got the refund.
  14. weltall

    weltall Well-Known Member

    Supposedly as the company mentions P041 is a newer version so it MIGHt be better .But yes for now its not that great since you cant use the uber easy modded rom that is prerooted too that tim distributes. Can you post a link of the product (fro mwhatever site you bought it) or was it a local store?
  15. rgibbsp

    rgibbsp New Member

    I got my flytouch 3 super pad 2 from china grabber, arrived 2 weeks ago, I have nothing but problems with battery power and firmware, downloaded link to correct firmware but two days ago unit showed it was low power so I plugged in power cord but no charging was started, by the way I have never had red lite while charging, just had to guess when it was charged, now with battery down and power card plugged in I can't even power on to see screen, could I have bad power cord? or battery?
  16. dart16

    dart16 Well-Known Member

    Yes and could.
    I would recommend you post this message on forum and direct it to the forum moderator as that site is sponsored by, and totally biased towards,
    China Grabber. The Admin can help you with returning it.
  17. tobynixon

    tobynixon New Member

    I have an Android 2.2 and I want to disable the celluar standby, amoung other things, my only problem with the previous solution is that mine is not disco and am having trouble finding a root program...

    Attached Files:

  18. dart16

    dart16 Well-Known Member

    another different model of FT3....

    have you tried z4root? You will need to have usb debugging enabled, have you seen if you can enable usb debugging by -

    download launcher pro
    press and hold anywhere on the desktop that is not an icon
    choose shortcuts
    choose activities
    choose settings
    choose development, then ok
    open the new development icon and
    tick usb debugging.........
  19. MiniMendy

    MiniMendy New Member

    I recently purchased Flytouch 3 SuperPad2 Android 2.2 Tablet off Ebay for my husband for Christmas. I can not get the wifi to turn on. The button is turned on and where I should be able to click ""turn on wifi" it won't mark it. This tablet has tim rom. Here are the details:
    CPU: LNX Code 11, 220 1GHz
    Board Model: DISCO10 (This pad will work with Tim's rom or other aftermarket roms)
    Android version 2.2-20110803

    My laptop and desk top hook to the wifi fine so not a wifi issue. HELP!!
  20. saugen48

    saugen48 Active Member

    I am having the same sort of problem with the wifi had been working but was having video streaming problems so did a factory reset and since then, it will not hook up to my wifi..tried the Tims update and that didnt also will not recognize the ethernet hook up when I plug in the is the DISCO10 as well
  21. saugen48

    saugen48 Active Member

    Update: Wifi connect sorted out, when trying to connect, used the Forget option than re-entered the password. Connection is now permanently great but not terribly strong reception..Have to get closer to the Wifi antenna..I did the Tim update as per there a way of confirming the update took????
    Thanks again
  22. Barbie53

    Barbie53 New Member

    Hi all,

    Im having trouble with my speakers on my flytouch 3, only one side is working and when i put headphones in only one side works again.

    Also i cant seem to get the microphone to work at all....cant even find the settings for it??? plz someone help me as it is a xmas prezzie for my mum and i want it in all working order and set up for her to enjoy.
  23. dart16

    dart16 Well-Known Member

    Proof of refurbished boards?.... thought not. Garbage then.
    Proof of higher QC?......thought not again.

    iBex...accurate adverts?? you are kidding right?
  24. pljackson

    pljackson New Member

    Were is the battery located ...... So i can replace....super pad 3 will not hold charge
  25. dart16

    dart16 Well-Known Member


    Are you sure the problem is not with the charger?

    If you are sure it is the battery then you will have to open the casing. There are some pictures HERE. Be very very careful not to damage the two ribbon cables that go between the pcb and the screen. When splitting the casing keep the bottom halves together until you can release the cables.

Share This Page