flytouch <something> DISCO 10 won't boot after "upgrade"Support


Last Updated: 2012-03-16 21:37:20
  1. wfdudley

    wfdudley Member

    Hi,

    My no-name Flytouch/superpad from lightinthebox won't boot after my attempt at a firmware upgrade.

    It used to identify itself like this:

    model DISCO10
    Android 2.2-20110826
    Linux 2.6.32.9
    Build number FRF85B

    Further, it has ONE micro SD slot and two USB ports on the right side, and the
    power suppy is 5V.

    So it seemed to me to be safe to upgrade to Tim's latest firmware:
    20111001_Tim6a.zip so I could have root on the thing.

    However, when I downloaded that file, unpacked it, put it on a 2G micro SD card,
    and booted up, I got this:


    Updating system firmware.
    Make sure your battery power is more than 70% or is connected to AC power.
    Please wait a moment...
    Updating system firmware...
    Creating partition...
    Memory size7948MB
    firmware-discovery was extracted wrongly !!!
    !!!!!error, please retry! auto shutdown after 1 mininutes!!!

    complete with the mispellings you see.

    Now, when I power up, I get the "big" green android center screen, then the little green android upper left, and then "A N D R O I D _" left center screen forever.

    attempting a reflash with this version or versions 20110712_Tim5a or 20110413_TCH does not change anything.

    Holding down "menu", "Escape", and power to "restore to factory" just leaves
    me in the same state, "A N D R O I D _" forever.

    Please help.

    Is there a known good firmware image for THIS tablet, which is obviously
    incompatible with the "real" flytouch 2 devices?

    Thanks,
    Bill Dudley

    P.S. I'm an experienced programmer and am sure I've followed the instructions
    correctly. I've been reading the forum for a few hours now and haven't found
    anything that's been helpful.

    Advertisement
  2. Rabid1

    Rabid1 Well-Known Member


    I believe LITB has a link somehwere on their website to firmware, but the TIms should work. Maybe try redownloading it and starting from scratch.
  3. wfdudley

    wfdudley Member

    As stated, I tried the upgrade using Tim's images multiple times, with identical result. Thanks for the tip on LITB website -- I checked, and NOW I see they warn against trying to upgrade the firmware, and they don't seem to supply any firmware images for these Flytouch devices.

    Bill Dudley
  4. Rabid1

    Rabid1 Well-Known Member


    Sorry the way I read your post I thought you had tri9ed multiple versions, but had not tired downloading new copies of those files. I should have been clearer as well as I meant from another source too.

    The most common fixes for this error are redownloading the files, using another microsd preferably freshly formatted, or reformat and repartition the microsd with a tool like Easeus. It is like the parse error installing apps, take the microsd to another pad and they work, then another and you get the parse error again.

    One thing I like to do (when you get the pad working again) is download the on the pad itself and unzip it to the microsd.
  5. dart16

    dart16 Well-Known Member

    Hi Bill, I think it should work with Tims image. Where did you get the files from? SuperPad2 Flytouch3 Hybrid Tim Rom is Tims homepage for his firmware.
    Use a different tf card
    Format it with SDFormatter.exe
    extract the update files from the downloaded archive onto the PC, then copy them to the newly formatted tf card & try again.

    If it still wont work....from LITB Q&A's

    Can i get an upgrade for my flytuch ?
    HI
    Can i get an upgrade for my flytuch3 or get the Os that come whit it
    By Shawn Allen 14 / 12 / 2011

    Dear Shawn Allen,
    Updating the system yourself is not recommended as it may cause unexpected errors and will void your warranty. If the system is unable to work, please log in to
  6. wfdudley

    wfdudley Member

    I was really hoping you guys were right about the SD cards. I tried another 2G card, same result. Then I tried an 8G class 4 card, first formatted as vfat without a partition table, and then the second time formatted vfat with a partition table (i.e. the normal way).

    I don't run Windoze and so am unable to run Windoze specific formatting programs, but I am confident I can format something as FAT32 correctly, I've done it many times to camera memories, mp3 players, etc.

    My brick (I mean tablet) didn't like the "no partition table" formatting and ignored the SD card entirely, but in all the other cases (2G or 8G with partition table and one partition formatted as vfat), I get the same result --

    "firmware-discovery was extracted wrongly !!!
    !!!!!error, please retry! auto shutdown after 1 mininutes!!!"

    I've tried different images downloaded from different sources, and I'm using Tim's main page that dart16 cited as the source of the image URLs.

    At this time I'm ready to declare that the physical SD card isn't the problem, and that the images are not corrupted. The same firmware image downloaded from different sources all have the same checksum. I can manually unzip and untar the contents of firmware-discovery just fine, so I know that file isn't corrupted.

    I've got a message into LITB asking for an image. I told them up front that I bricked it, I'll try being honest and see how far that gets me.

    What p--sses me off is that this unit was obviously made to decieve people into thinking it was the same as previous "flytouch" units, or else why have the build number, the "DISCO10", etc all look the same as previous units. That's why I didn't try to extract a firmware image from the thing before I bricked it. Stupid
    me.

    Eventually, somebody will upload a stock image for this thing and I'll be able to restore it. Either that, or LITB will help me out.

    Do any of you know of a pointer to a map of how the internal SD card is built? I thought I might try manually building a system on there. Perhaps the internal updater is broken and Tim's image will run if I can just get it installed?

    To do this, I'd need the output of the following commands:

    Code (Text):
    1.  
    2. df
    3. ls -R /
    4.  
    with any external SD cards unplugged, preferably on a DISCO10 running one of Tim's releases.

    Thanks,
    Bill Dudley
  7. Rabid1

    Rabid1 Well-Known Member

    If LITB voids your warranty, or if their firmware doesn't work, it is possible there is an issue with the internal microsd. If that is the case, it is fairly simple to open the pad and replace the internal microsd. You don;t seem like the rock and crowbar kind of guy so I'm confident you wouldn't have a problem with it. :cool:
  8. tommylimo

    tommylimo Member

    Hi!! I Have The Same Pad But With The froyo Os I Used Tims 6a And It Works Great!! I Think Because U Have A Linex OsThats Why Ur Getting The Error!!! Like I Said I Think Thats The Problem!!! Also When Restoring To Factory Specs It's Power/ Menu (In Shut Down Mode) Android Will Appear and Disappear!! That Tells U It is back To Fac/Settings!! Just Alittle Info!!! Nothing Else!! Tommy!:)
  9. dart16

    dart16 Well-Known Member

    PM sent Bill.
  10. wfdudley

    wfdudley Member

    Progress.

    1. LITB replied promptly with a pointer to a firmware .rar file. I unpacked it and installed it. Now unit runs, that's the good news. Bad news is that this version is dated late May 2011, whereas the original firmware was dated 20110826. The bottom 1/4" of screen is cut off. I have messaged LITB asking for newer firmware and they replied that they would contact their supplier and get back to me. I have to say that LITB have been very good about this. Rabid1, thanks for your comments; yes, I could open it, but so far, no need.

    Assuming I ever get the original firmware image, I'll make it available somehow so others can find it and download it.

    2. tommylimo: when you say "I Have The Same Pad But With The froyo Os", what exactly does that mean? I realize Froyo is an Android version. I believe that there are many Chinese factories all churning out near identical tablets, with subtle differences in both hardware and software. I don't think it's "rip-offs", so much as "cooperative engineering", where they copy and improve each other's products. But it makes it very hard to determine if two units are "identical" or not. The only way I'll believe a unit is "identical" to mine is if it's running "Android 2.2-20110826".

    3. dart16: I'll have a look at your PM. Thanks for your time.

    Thanks to all of you,
    Bill Dudley
  11. Rabid1

    Rabid1 Well-Known Member


    Bill I literally have almost 400GB of android stuff. and a ton of it is various FT firmware. Now that we know you have a working image, let me go through and look for that date.

    One thing though is if we find it I will pull any bootloader files. With the problems you were having we definitely don;t want to have you flashing any of those.
  12. wfdudley

    wfdudley Member

    Rabid1,

    That would be great if you could see if you have that image in your collection.

    Thanks,
    Bill
  13. wfdudley

    wfdudley Member

    Rabid1,

    Any luck looking for that firmware image?

    Thanks,
    Bill Dudley
  14. wfdudley

    wfdudley Member

    Rabid1,

    Any luck looking for that firmware image?

    Thanks,
    Bill Dudley
  15. wfdudley

    wfdudley Member

    Rabid1,

    Any luck searching for an image?

    Thanks,
    Bill
  16. wfdudley

    wfdudley Member

    Sometimes, even I mess up. I found that the images written to the SD card were corrupt.

    Being extra careful to format the card and then copy the images and then checksum the
    images and check against the originals, I was able to upgrade the tablet to Tim's image(s).

    The bottom 1/4" of the screen is still cut off, and using the 1Kx576 image makes the problem
    much worse, so the screen is definately 1Kx600.

    Bill Dudley

Share This Page