1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

For 2.2 Market issues, use this mod.


Last Updated:

  1. LexusBrian400

    LexusBrian400 Well-Known Member This Topic's Starter

    Joined:
    Mar 3, 2010
    Messages:
    699
    Likes Received:
    154
    For those of you having trouble seeing protected apps, I modified our fingerprint in the build.prop. What this does is spoofs the market into thinking its seeing a Droid 2 (with Froyo) It worked for me, let me know if it does for you.


    1. Put build.prop into your AndroidSDK\TOOLS folder
    2. Connect via USB.
    3. CD (Navigate) in CMD to your tools folder

    Mount your /system (adb remount) works for me
    Copy and paste this

    4. adb remount

    5. adb push build.prop /system/build.prop

    6. adb reboot

    To test if you need this before you push the build.prop fix, search the market for Us Bank. If only 2 or 3 show up, you are not getting the full market. After this fix, you should see 10 items listed when you search for Us Bank.

    Hope this helps.


    2.2 Market Fix Build.Prop -- Contains stagefright mod (faster quadrant) For non-stagefright, use the one below.


    This can also be done via Root Explorer.


    Edit: Here is a "clean" build.prop for those of you who do not want the stagefright fix (which breaks video playback) Sorry, I was not aware it did that. Thank you.

    Non Stagefright Build.prop



    For everyone flipping out about Birdmans tweet and you want the stock build.prop, here ya go
    Stock Build.prop

    You only need the stock one if you ever plan on doing a factory reset. But, you also cant do a factory reset if you have removed or renamed apps so I feel that should be mentioned. If you've done any modding and you are planning on upgrading, your best bet is to always use the SBF anyway. I dont think birdman realizes the panic he sets in with one little tweet. Factory resets suck anyway. But then again... "you decide..."

    Thanks to Jcase for giving me the original idea way back when. I just basically applied his Eris Market Fix to work with our phones.


    Beesley on IRC
    I'm currently unemployed and Donations Are always appreciated. I'll take this down as soon as I'm hired. If you dont have any money, and I've helped you... then just pay it forward and help someone else. Its the non selfish attitudes that our community has that makes it the best one around. Viva La Android
     

    Advertisement
    joshellis625, D13, eulerphi8 and 2 others like this.
  2. 4n4c0nd4

    4n4c0nd4 Member

    Joined:
    Jul 30, 2010
    Messages:
    11
    Likes Received:
    0
  3. Airmaxx23

    Airmaxx23 Well-Known Member

    Joined:
    Jun 21, 2010
    Messages:
    3,142
    Likes Received:
    1,039
    This worked for me, History Eraser wasn't showing up when I would search for it, not it's there again.
     
  4. Travisimo

    Travisimo Well-Known Member

    Joined:
    Jul 7, 2010
    Messages:
    455
    Likes Received:
    88
    Here's my question:

    Since the 2.2 leaked update is a signed version, will those copy-protected apps appear again once the "official" Froyo release is out? Or will we indeed have to modify that file and impersonate the Droid 2 in order to see those apps? I guess it depends on whether this leaked 2.2 build is the final one or not, eh? If it is, then I would hope that the protected apps would just start appearing again once the official build is out, right? I'd really prefer not to modify any additional files and would not mind waiting until the official build is out to see the protected apps on my Droid X.

    EDIT: To the OP, you might want to modify your thread title to include "protected apps issue" since there was a separate issue with the market where it was giving a network error. It was apparently an issue with the market in general since it was happening with other devices as well. At any rate, when I first clicked on your thread, that's what I thought it was about.
     
  5. shared91

    shared91 Member

    Joined:
    Jun 20, 2010
    Messages:
    18
    Likes Received:
    0
    What were the modifications you made since I have other mods in mine and would like to just change my current one and not have to make all changes again. Thanks
     
  6. user53

    user53 Active Member

    Joined:
    Nov 26, 2009
    Messages:
    35
    Likes Received:
    0
    Couldn't you simply do this with root explorer too instead of having to connect it to a computer and using adb. Seems much simpler.
     
  7. shared91

    shared91 Member

    Joined:
    Jun 20, 2010
    Messages:
    18
    Likes Received:
    0
    Yes. everytime i have changed my build.prop i use root explorer. Awesome program well worth the couple bucks. Automatically makes a backup of the file when u change something.
     
  8. user53

    user53 Active Member

    Joined:
    Nov 26, 2009
    Messages:
    35
    Likes Received:
    0
    Thanks, I thought so
     
  9. philipwelch4

    philipwelch4 Member

    Joined:
    Jun 10, 2010
    Messages:
    14
    Likes Received:
    0
    So this is the result I get when trying that:

    "failed to copy 'build.prop' to '/system/build.prop' : Read-only file system

    How do I make the /system folder read write?
     
  10. LiquidHonesty

    LiquidHonesty Active Member

    Joined:
    Jul 5, 2010
    Messages:
    32
    Likes Received:
    2
    Ok, so is there a fix for people who aren't rooted? :-(
     
  11. shared91

    shared91 Member

    Joined:
    Jun 20, 2010
    Messages:
    18
    Likes Received:
    0
    are you using root explorer?
    if so when you are in the /system folder click the "make r/w" at the top right of the screen before scrolling down at all. Make sure you always click on "make r/o" when you are done or you leave your system very vulnerable.
     
  12. shared91

    shared91 Member

    Joined:
    Jun 20, 2010
    Messages:
    18
    Likes Received:
    0
    to update you needed to be rooted so fix your root issue. I lost it during update and was able to use terminal emulator to fix.
     
  13. D13

    D13 Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    2,088
    Likes Received:
    234
    Through adv
    mount- o remount,re -t yaffs2 /dev/mtd/mtdblock4 /system
     
  14. Piiman

    Piiman Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    2,333
    Likes Received:
    153
    BTW Chrome to phone works great for stuff like this. I open this in web browser hit Chrome to phone button and bam! now it's on my phone and I can download it directly and not worry about transferring it later.

    It's magic I tell magic! :D
     
  15. humungus

    humungus Well-Known Member

    Joined:
    May 23, 2010
    Messages:
    124
    Likes Received:
    39
    Note: This build.prop has stagefright enabled, which breaks the ability to play video files recorded by the phone. You should probably release a clean one for those people who don't want birdman's tweak.

    Otherwise, thanks. This is great.
     
  16. emr25

    emr25 Well-Known Member

    Joined:
    Jun 14, 2010
    Messages:
    88
    Likes Received:
    1
    I downloaded the file, transferred it to my SD card, then used root explorer to copy it into system/build.prop and deleted the old build.prop file. I saved a copy of it on my SD card just in case, but now that I did all of that and turned my phone off, when I turn it back on it shows the Motorola logo and then nothing. No Droid or eye boot animation. Do I have to go through the process of flashing the 2.1 SBF file again and updating to 2.2, or is there an easier way to get my phone to boot again?
     
  17. LiquidHonesty

    LiquidHonesty Active Member

    Joined:
    Jul 5, 2010
    Messages:
    32
    Likes Received:
    2
    Huh? You didn't have to be rooted to install the update....

    Can't use root explorer because I'm not rooted :-(
     
  18. LexusBrian400

    LexusBrian400 Well-Known Member This Topic's Starter

    Joined:
    Mar 3, 2010
    Messages:
    699
    Likes Received:
    154
    Thank you for the tip, I uploaded a clean version.
     
  19. LexusBrian400

    LexusBrian400 Well-Known Member This Topic's Starter

    Joined:
    Mar 3, 2010
    Messages:
    699
    Likes Received:
    154

    I AM Beesley :) Check my signature on XDA.

    Beesley is my IRC name.
     
    elbacker likes this.
  20. humungus

    humungus Well-Known Member

    Joined:
    May 23, 2010
    Messages:
    124
    Likes Received:
    39
    Hey LB400, do you have the stock build.prop by any chance? When I went to disable stagefright on your (awesome) version, it replaced my backup of the stock with your stagefright enabled version.
     
  21. PurePursuit

    PurePursuit Well-Known Member

    Joined:
    Jul 5, 2010
    Messages:
    120
    Likes Received:
    10
    Can you just post the changes necessary to enable the spoof so we can manually edit our build.prop
     
  22. Mojorisen

    Mojorisen Well-Known Member

    Joined:
    Jan 6, 2010
    Messages:
    151
    Likes Received:
    12
    +1
     
  23. LexusBrian400

    LexusBrian400 Well-Known Member This Topic's Starter

    Joined:
    Mar 3, 2010
    Messages:
    699
    Likes Received:
    154
    For people who want to edit this themselves...



    After

    ro.build.fingerprint=

    Change it to...


    ro.build.fingerprint=verizon/voles/sholes/sholes:2.2/FRG01B/45394:user/release-keys



    adb remount

    adb push build.prop /system/build.prop

    adb reboot
     
  24. Candroid

    Candroid Well-Known Member

    Joined:
    Dec 15, 2009
    Messages:
    144
    Likes Received:
    10
    Thanks Man, What I did the correct the video was just change my settings to 780 x 480. and play back is just fine. just my 2. I am happy with it. I'd rather have insane quadrant and linpack scores and a phone that responds on demand!!! ;)
     
  25. humungus

    humungus Well-Known Member

    Joined:
    May 23, 2010
    Messages:
    124
    Likes Received:
    39
    Can you paste the original value?
     

Share This Page

Loading...