For GingerBread users / Rooting of Android 2.3.4 GingerBread


  1. Netas3k

    Netas3k Well-Known Member

    Hey guys.

    I thought i post this because when i upgraded to gingerbread i didn't knew how to root it and SOC (SuperOneClick) didn't work for me.

    So who upgraded to gingerbread and wants to root it follow these instructions :

    1. Download a file called upd_1.zip from here .

    2. Put this file to your main(root) directory of your SD card.

    3. Turn off your phone and boot in recovery mode by holding Home button + Power button untill it shows you the recovery mode menu.

    4. There you can't use the touch screen. So you have to use the Volume up/down keys to move up and down and home key to select. Select "Apply update from sdcard" and select your file that you downloaded upd_1.zip.

    5. Wait for it to install (It took about a second for me to install it ). And then select "reboot your device" from the menu.

    And there you go your device is rooted and you can see the superuser icon on the menu .

    This worked perfectly for me. Hope this helps you gingerbread users.

    Advertisement
    :
  2. Bas232

    Bas232 New Member

    Thanks a lot man, works like a charm:D
  3. spacebar2011

    spacebar2011 New Member

    .. removed ..
  4. roofrider

    roofrider Well-Known Member

    hey netas...
    in this method wat do u mean by placing the zip in the main directory? means to just paste it to the sd card n not into any folder rite?
    and there is a certain gingerbreak for rooting gb..how do these 2 methods wary? which do i choose, thou i think i'll root it via this method mentioned here. :)
  5. Netas3k

    Netas3k Well-Known Member

    Yes you are right about the directory. I didn't try gingerbreak. I recommend this method. Btw - did you flash the CWM ? and go for Andro - ID or CM7 you will have a custom rom and root already :) it will save you time :)
  6. roofrider

    roofrider Well-Known Member

    thanx :) no not yet...yea i know it's prerooted...but thinking,whether shud i root n experience gb n then go to andro id n cm7 ;)
  7. Netas3k

    Netas3k Well-Known Member

    Btw - If anyone has questions, problems about rooting fell free to post them here :)
  8. deezx4

    deezx4 Member

    I'm trying to root my EVO running Gingerbread... I'm having a hard time! Any ideas
  9. Netas3k

    Netas3k Well-Known Member

    Yeah... I think this works only works for GT - S5570. That's why i posted this thread in the specific device forums :)

    BTW - Post your full device name and i will find you a rooting tutorial for your device :)
    RoopeshPunyani likes this.
  10. Thanks Netas
    that wise of you, it's gonna serve better
  11. sangalaviral

    sangalaviral New Member

    It does not work anymore.
    It shows some error while flashing and it says aborted. I am using gingerbread.xxkpj 2.3.4
  12. csensitive

    csensitive Member

    Works fine with Gingerbread 2.3.4 xxxkpk
  13. chrisalle

    chrisalle New Member

    I used this to root my s5570 and it seemed to work great, but I can't change anything in the root folders. Superuser is fine and I can install apps but I can't uninstall the bloatware. I don't have Marketplace because of an Asian build and I'd rather not go through all the trouble of flashing a new ROM. Anyone have any ideas?
  14. dhruvbatra205

    dhruvbatra205 Well-Known Member

    works perfect!
    can we remove the zip files after updating?
  15. Netas3k

    Netas3k Well-Known Member

  16. Netas3k

    Netas3k Well-Known Member

    I have ideas. Well you can't change anything in the system(root) folders with a simple file explorer. Use root explorer or ES File Explorer it has that kind of option :) To uninstall bloatware you can install Gemini App Manager and with it uninstall anything you want :)
  17. mpmman

    mpmman New Member

    Thanks for this..
  18. kabonkel

    kabonkel New Member

    Worked fine for me.



    Galaxy mini Gingerbread 2.33
  19. Gage_ab

    Gage_ab New Member

    How about a Galaxy 4G t959P running 2.3.4? I haven't found any way to root this yet.....
  20. yagya

    yagya Well-Known Member

    google 'root your phone model 2.3' for more info ...
    I think it also can be rooted with Andeoid Universal Root application ...
  21. ckashy

    ckashy New Member

    Hi, I am using Motorola Fire XT311 with 2.3.4.. when I tried to root with this zip file if says signature verification fails.. can you help me with this pls..

    Thanks
  22. apisfires

    apisfires Member

    lads, please read carefully, this not ypur phone thread, so its not suitable with ou phone.. ok?
    androidyboy likes this.
  23. digi23

    digi23 Active Member

  24. yagya

    yagya Well-Known Member

    Flash the original gingerbread firmware from samfirmware.com using Odin....

    :):)
  25. digi23

    digi23 Active Member

    Ah,thank you :)

    Edit: Rooted :D
Loading...

Share This Page