Forced to Unroot, then reroot and now cannot


  1. htcevo4g03

    htcevo4g03 Well-Known Member

    Hello all,
    I rooted back in feb 11 with no issues, but then noticed other than Cm/miui that no gb roms would work.Froyo but no gb. So after researching and getting tons of advice with trying everything, I was forced to unroot and then reroot.
    I unrooted with the unrevoked s-on tool and ruu 3.70. After i completed this process, I was back to stock but was still s-off :confused:
    Even though still s-off i was given the goahead to just reroot.

    So I Went ahead and tried to reroot and I run into more issues of course.(current problem)

    After installing the hboot drivers for windows, extracting, connected evo, opening device manger, the direction say to go to "other devices" then android 1.0 under that and then update drivers. Well I noticed "other devices" does not exist in my device manger?? After I install the only thing that appears new in there is "android Phone" which is on the very top. No android 1.0 under "other devices" Not sure if this could have to do with this issue but I wanted to mention it.

    ALso install htc sync(uninstalled after but left the drivers), no doubletwist, antivirus off, usb debug on and in charge mode.

    I double click the reflash file and the unrevoked box pops up. In other vids its suppose to auto do its thing. It doesnt do that. It says: "waiting for device" Plug phone in and enable debugging. Make sure htc syn in enabled.

    Tried multiple downloads of everything. I looked to see others who have had this issue and cant find a definitive answer as to why or how to fix it.

    I been at for hours today and get the same result over and over.

    my evo:
    Supersonic Evt23 Ship S-off
    Hboot-2.10.0001
    Micro P-041f
    Touch panel ATMELC03_16ac
    Radio-2.15.00.11.19
    Oct 15 2010

    Any help would be greatly appreciated. Thank you for taking the time to read.

    Advertisement
    :
  2. Xtremedays

    Xtremedays Well-Known Member

    Being as you have s-off you can flash a custom recovery(recommend Amon RA 2.3) then wipe and flash the rom of your choice. Check the Roms sticky for links to recoveries and the current Roms.
    htcevo4g03 and ocnbrze like this.
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    you only need unrevoked to get s-off, once it is off you are almost rooted. like xtreme said just install a custom recovery. you can grab one here:http://androidforums.com/evo-4g-all-things-root/259446-clockwork-amon-ra-pc36img-files.html. i would use amon ra 2.3. it is almost error proof. clockwork mod is just to buggy for me and it never wipes well enough for me.

    that link has instructions on how to install it. if you need help with the process please feel free to ask.
    htcevo4g03 likes this.
  4. htcevo4g03

    htcevo4g03 Well-Known Member

    Hey man thAnks for the response. I appreciate it.

    Ok I did that and was able to flash Amon ra so thank you very much.

    Like I said in my op, I was not able to successfully flash most roms, only a few worked. It was very weird, I tried everything under the sun, nothing worked.SO to try and get this resolved my last resort was to unroot with Ruu 3.70 and s-on tool. Got back to stock but still was was s-off.
    Anyway so now it looks like im rooted fully again, but the whole reason was to fix the issue of why i could not flash most roms. If I did this and Im still stuck with this problem, I will be very upset, ya know what I mean?

    Hey thank you again so much for help, I will check back and let you know if everything is ok.

    take care
  5. htcevo4g03

    htcevo4g03 Well-Known Member

    I just tried a few gb roms and I just CANNOT believe the same shit is happening. OMG im so dejected. Iv been at this hours and hours the last month and a half and still the same shit.

    Sorry Im not talking it out on you guys but I just dont know what to do now.

    Iv tried every single thing ppl said to do and cant get a fix. So Im forced to run CM or a froyo rom. I didnt root to be miserable but thats what i am.

    I and others on many forums havent found an explanation as to why every single gb rom i try(other than cm7 and miui) installs succesfully yet gets stuck at the white htc screen in constant rebooting over and over and over and im forced to pull battery.

    again all your help is so appreciated, im just fed up
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    ok so you are on a boot loop. well what are you wiping when you flash a rom? have you tried the vr_superwipe? so i wipe dalvik cache, cache, and system. i wipe those 3x then i flash the vr superwipe 3x, then i flash a rom. which rom did you try?
    htcevo4g03 likes this.
  7. htcevo4g03

    htcevo4g03 Well-Known Member


    Hey man, if I came off like a d*** heatd I'm sorry. You just don't
    Know what it's like to try to find solutions to a problem for a month and a half straight with the same result : never getting past the white htc evo screen.

    Here's what I do when flashing a rom:

    Download rom and place it on root of sd.
    Boot into recovery with amon RA. The
    Wipe in this order:cache-davlik-boot-system-sd ext-data-sd secure-user data/factory
    reset (others instructed me to try in different orders & I did & it work)
    Flash the zip file by itself, reboot.
    Screen shows them familiar colored squiggly lines when you flash a rom
    Then screen is all black fora split second then to the white evo screen. Normally goes from that white screen to whichever roms splash screen. But in this situation it will show the white a screen for approx. 10 seconds, vibrates, black for asplit second then back to the white htc screen and does that over and over. IV waited as long as 30 minutes & it continues.
    This time I tried mikg & virus kingdom. Overall, alongwith those, iv tried alliance, kings revolution, leo, supersonic gb, synergy, bos, & others.

    ROMs that work with no issue: any froyo, any cm, evo deck, miui.

    No I haventetried vr_superwipe. Someone at xda did briefly mention it, but then amon RA works just as good or better and that if amon RA didn't work, then that won't work.

    IV now started to get pm's saying they have the same problem and haven't found a fix. Usually I thought there is ALWAYS a fix for a problem, yet this is becoming a conspiracy or atleast it feels that way.

    Again your time and help Is very very much appreciated.
  8. andygu3

    andygu3 Well-Known Member

    For some reason, I never could flash a rom UNTIL i used Calkulin's Format All or VR Superwipe. BTW, I'm using amon ra v2.3 and hardware version 004. I would highly recommend using one or both;)
    htcevo4g03 likes this.
  9. htcevo4g03

    htcevo4g03 Well-Known Member


    OK so what exactly should I do
    I currently have amon RA. Not sure what hardware version?.
    Do I use caulkins or vr_superwipe in place of amon or on top of?
    And if I don't have version 004 hardware, where orhow do I get it?

    Someone that had this same issue said they upgraded they're HBOOT to 0.97 and it fixed the problem. I think I currently have version 2.10, From what I understand 0.97 isn't downgradeable so that's out.
  10. andygu3

    andygu3 Well-Known Member

    Not sure if hardware version had anything to do with flashing but just thought that i would put it out there:)

    Using Amon Ra v2.3 as your recovery, do this:

    1. Download rom of your choice, a)either download to your computer and transfer OR b)download directly to your phone (If (a), then rom will be on the root of your sd card, if (b), then rom will be in your 'download' folder of your sd card)

    2. Download Calkulin's Format all zip and/or download VR Superwipe (Both can be found in the Roms and kernels download page)

    3. Boot to recovery

    4. Flash Calkulin's format all zip and/or Vr Superwipe zip (you can flash both, it won't hurt anything;))

    5. Wipe data/factory reset

    6. Wipe cache

    7. Wipe Dalvik cache

    8. Flash rom of your choice

    9. Reboot phone



    Then sign into your Google account, facebook........then set up the phone to your liking:D
    htcevo4g03 likes this.
  11. htcevo4g03

    htcevo4g03 Well-Known Member

    OK Andy of course I will try this. I'll try anything that is could possibly fix this issue. Everything iv attempted has been a #fail so i can't say I'm confident.

    The biggest question I have is why would other roms work. If it was a wipe issue or w/e kind of issue you wouldn't think anything would work. Amirite?
    You know what I mean, what could the explanation be that anything froyo, along with Cyanogen and miui flash perfectly, yet anything else I try, the result is always the same. What logic could there be in that?

    Again tyvm and i will try this today and check back after.
  12. andygu3

    andygu3 Well-Known Member

    Hope everything works out:) Not sure what the problem is, until I started using Calkulin's Format all, I could only flash certain roms and then I would get hung up on the white htc screen. Had to pull battery and try again. After using calkulin's and/or VR superwipe, not one issue flashing roms;)
  13. htcevo4g03

    htcevo4g03 Well-Known Member

    Hey andy,

    As much as I wanted to come and post that finally it worked, sadly it did not.

    Followed your exact directions, the roms i tried were Mikg(2.15) and Kindom Revolution(not sure which version), result being the typical bootlooping at the white screen.

    2 i tried and both worked Mikfroyo(4.5) and the latest CM7, no bootloops.

    This is amazing. it really is.

    Im in the process of downloading and flashing via your method, Mikg 2.3 and Vr_Kindom,revolution_B1.3-1 to seeif the same thing happens which im sure it probably will :(
    Is there a rom or 2 you could recomend me trying that from the result could tell me anything?

    One side note, i noticed that the only Gb roms i can flash are AOSP roms.(cm,evodeck,miui) Correct? Could that mean anything?
  14. XfandroidX

    XfandroidX Member

    Do you think that it might be the kernel that is in these gb roms that is bootlooping you? I mean I don't know as much as soem of the other members but I do know that some kernels will throw phones into boot loops. Maybe after you flash the rom try finding a kernel that will work with the rom and flash that after you flash the rom. IDK if it will work i'm just trying to help ya out. It probably is totally wrong but, Just want to see you enjoy some of the other roms out there. I have an Evo Shift running GB Shift Deck 2.3.4 Rom and love it. Well I hope you can figure it out. Keep us posted buddy. I wanna see if you figure it out. Try the kernel thing though if you want unless another member chimes in and tells you not too.
    htcevo4g03 likes this.
  15. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    well unfortunately, a custom kernel has not been released for the gingerbread ota for our evos yet. you can try the froyo kernels but many things may not work right if you do.

    so just to make sure that i understand, is it bootloopint (where it goes from the htc white screen to the bootanimation screen over and over again) or is just staying at the htc screen?
    htcevo4g03 likes this.
  16. htcevo4g03

    htcevo4g03 Well-Known Member

    See i was saying "bootloop" before in some other forums and they said its only a "bootloop" if it gets stuck on the splash screen of the rom. See im never getting into the rom. Its always said, flash from sd card complete, i then reboot and it shows the pink and blue squigley lines on the screen for a second or 2, then all black for a second, then to the white evo 4g screen, sits there for approx. 10 seconds, viibrates, turns all black for a second, then immediately back to the white screen. And it does that over and over never getting farther than that.
    But then when I try any froyo, cm, miui, sits on the white screen then right into w/e roms splash screen and then startrs up.

    Im in utter amazement ..........:confused::confused::confused:
  17. htcevo4g03

    htcevo4g03 Well-Known Member

    hey thank you for trying to help....Yep someone said to do exactly this. Flash the rom then a kernel after. I think it was htc #15 that I tried but didnt work.

    its about to be 2 months of this misery. I didnt root for this..:(
  18. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    what sd card do you have? not sure if that is the answer as to why it works on froyo but not gingerbread. but i heard that if you have 2g or less card, the phone may have issues flashing things.
    htcevo4g03 likes this.
  19. andygu3

    andygu3 Well-Known Member

    With some nandroids getting up to 800mb, I don't how I could use a 2gb sd card. Then, most of the newer sense roms are upwards of 300mb. You would be out of room in no time:eek:
    htcevo4g03 likes this.
  20. htcevo4g03

    htcevo4g03 Well-Known Member

    I'm using the stock 8gb that came with it....

    I'm trying to think of every possible thing I can that I haven't mentioned which maybe once you hear it, that could possibly be the reason why this is happening.

    One thing, when this shit started I was doing a wipe with amon ra and by accident I wiped the sd. What is most important though is this was an issue before I had did that but I Just Want to be sure and mention every detail. Since yesterday I still haven't tried any other rooms other than mikg and kingdom revolution so I will try a few different non aosp gb roms and see what happens. :(
  21. htcevo4g03

    htcevo4g03 Well-Known Member

    I tried to flash Mikg(2.3),Vr_kindom, and Alliance Kindom today all with the same result.
    Its becoming real that there is NO fix for this and is really unbelievable.

    I said earlier that someone else had this same issue and upgrading his hboot version fixed it. If I remember right he upgraded to .97 hboot from whichever the prior versions was. And then I heard from another person to try and downgrade my hboot to anything other than the current version. I could be way off here but im grasping for straws here.

    Anyone have anything else????:(:confused::(:(:confused::(:confused::(:confused::mad:
  22. Xtremedays

    Xtremedays Well-Known Member

    Have you tried flashing a stock rooted rom? You can find the current release here. Just download the odex version, do all your wipes, flash superwipe then flash the rom and reboot. See if it boots up correctly.
    htcevo4g03 likes this.
  23. htcevo4g03

    htcevo4g03 Well-Known Member

    Hello X, trying this now will check back.
  24. htcevo4g03

    htcevo4g03 Well-Known Member

    X, DId exactly what you said, says the install from sd card is complete, reboot, to the white htc screen, then vibrates and back to htc screen repeatedly over and over....same rotten result,.,,:confused:

    Now Im not sure if you know this but some1 said to unroot then reroot so when I did that, running the s-on tool and ruu 3.70, while it never did switch to s-on, i was able to get back to stock 3.70. So in that case I was able to get back to stock, not the latest but 3.70. I dont know, might any sense at all, just grasping at straws here thinking of any info to give you that could help me.

    Iyo, what could be a reason, any reason why aosp gb roms work fine, froyo roms work fine, but nothing else, in which its all the same exact result??(rebooting at white htc screen)
  25. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    when you wipe before flashing what are you doing?
    htcevo4g03 likes this.
Loading...

Share This Page