1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Forcing Apps to install to the SD Card without rootTips


Last Updated:

  1. El Presidente

    El Presidente Beware The Milky Pirate! Moderator This Topic's Starter

    Joined:
    Jan 3, 2011
    Messages:
    30,516
    Likes Received:
    21,332
    It's a phone thing, so the SD Card shouldn't matter :)
     

    Advertisement
  2. pablo27

    pablo27 Member

    Joined:
    Jan 20, 2011
    Messages:
    12
    Likes Received:
    0
    I tried this afternoon to run this fix on my daughter's phone. I put the mini SDk into Documents, also left the original in my downloads. I installed HTC Sync onto my desktop, although this did seem to take quite a while for some reason.
    Enabled debugging on the phone and connected in charge only.
    However once in command prompt I could not find the SDK-Tools in documants at all. I typed various commands : cd\SDK-Tools also Documents\sdk-tools plus othes that people have tried, but without success.
    When I went back to my desktop I tried running HTC Sync and it would not recognise the phone, even with debugging disabled and HTC Sync selected on the phone, could this be the reason why I cannot find SDK-Tools ?
    I also plugged my Desire HD into the desktop and HTC Sync would not connect either.I eventually ran out of time before I could try re-installing HTC Sync.
     
  3. El Presidente

    El Presidente Beware The Milky Pirate! Moderator This Topic's Starter

    Joined:
    Jan 3, 2011
    Messages:
    30,516
    Likes Received:
    21,332
    Hi Pablo, if you extract the SDK Tools to the root of your C Drive as opposed to another folder so it's located in C:\SDK-Tools, does that make a difference?

    Also, what OS are you using?
     
    pablo27 likes this.
  4. pablo27

    pablo27 Member

    Joined:
    Jan 20, 2011
    Messages:
    12
    Likes Received:
    0
    Hi EP thanks for taking the time to reply :).
    I haven't yet tried extracting the SDK Tools to the C drive, I wasn't sure how and where to extract it to really, so just put it in My Docs. I am running Vista on my desktop.
    I will re-install HTC Sync and then try connecting my Desire to see if it is ok, I then have to try and prise my daughters phone from her long enough to try the fix again, hopefully it will be sometime over the weekend.

    Can I try and find the C:\SDK-Tools without having her phone connected ?
     
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator This Topic's Starter

    Joined:
    Jan 3, 2011
    Messages:
    30,516
    Likes Received:
    21,332
    No problem Pablo! :)

    It could be HTC Sync that's the issue, I seem to recall it's problematic with Vista.

    I'll have a look around, see if I can find just the drivers (not the app itself) as you only need the drivers associated for the PC to recognise the phone.

    In the interim, fire on with extracting to the root of the C:\ drive and navigate to C:\SDK Tools.
     
  6. pablo27

    pablo27 Member

    Joined:
    Jan 20, 2011
    Messages:
    12
    Likes Received:
    0
    Okies matey, I'll give that a go .;)
     
  7. Calomax

    Calomax Well-Known Member

    Joined:
    Feb 5, 2012
    Messages:
    104
    Likes Received:
    6
    Please can you tell me how to run this in Windows 7 which doesn't have "run" in the Start Menu so I don't know how to input the dos commands.

    Also is it not possible to choose to install apps onto the sd card without having to do this sort of procedure? My old Symbian Nokia can do it if only there were some decent apps to install.
     
  8. El Presidente

    El Presidente Beware The Milky Pirate! Moderator This Topic's Starter

    Joined:
    Jan 3, 2011
    Messages:
    30,516
    Likes Received:
    21,332
    Let me know what happens. I might not be able to respond instantly this weekend, but I will get back to you.

    Is there a search box/text field in the start menu? Type cmd in there and click the icon which comes up called cmd.exe.

    You can move some stuff over, but the procedure is needed for making the SD Card the default installation directory.
     
    Calomax likes this.
  9. Calomax

    Calomax Well-Known Member

    Joined:
    Feb 5, 2012
    Messages:
    104
    Likes Received:
    6
    Thank you, yes there is so I'll try that in a few weeks when I get my phone. It's my birthday present.

    Thank you very much.
     
  10. Nauman123

    Nauman123 Member

    Joined:
    Feb 11, 2012
    Messages:
    21
    Likes Received:
    1
    Thnx man it really worke....and can u tell me that should i root my wildfire s
     
  11. rajrishi27

    rajrishi27 New Member

    Joined:
    Feb 10, 2012
    Messages:
    1
    Likes Received:
    0
    supppppeeeeeerrrrrb...@@@@@@@
     
  12. chrisbob1200

    chrisbob1200 New Member

    Joined:
    Feb 11, 2012
    Messages:
    1
    Likes Received:
    1
    Many thanks, it worked first time for me. I was a little concerned about the permission denied on exit, but it does not seem to be a problem. After I disconnected, a bunch of apps became available to app2SD and I moved them over. Now the upgrade can install. Hurrah.

    Once again, thanks for your work and time.
     
    El Presidente likes this.
  13. annem3911

    annem3911 New Member

    Joined:
    Feb 12, 2012
    Messages:
    1
    Likes Received:
    0
    Hi I have tried doing this on my HTC Wildfire S and it says that it when i get to step 4 it says that ''C:/Users/floyd/Desktop/sdk-tools is not recognized as an internal or external command. operable program or batch file'' please help.
     
  14. AndroidIsKing

    AndroidIsKing New Member

    Joined:
    Feb 12, 2012
    Messages:
    2
    Likes Received:
    0
    I've seen there is a problem when your successfully finished patching. So you disconnect your phone and try to move a app onto your SD Card. It's blacked out... So I found out you must reboot your phone. When your phone has successfully rebooted, you are allowed to move a app onto the SD Card.

    Just to point out apps you DOWNLOADED can be moved only.
     
  15. Kamzi4u

    Kamzi4u New Member

    Joined:
    Feb 15, 2012
    Messages:
    1
    Likes Received:
    0
    It worked dat was gr8 but wired headset was nt working after rooting my phone so had to unroot it....... Ny suugestions how to get the headset back to work??
     
  16. pablo27

    pablo27 Member

    Joined:
    Jan 20, 2011
    Messages:
    12
    Likes Received:
    0
    Only just gotten around to trying my daughter's phone since last week. We can now find SDK-Tools ok but can't manage any further than that !
    My Desire HD connects to HTC Sync fine, but when we try to connect the Wildfire, it cannot find or open Sync ?
    We have tried uninstalling Sync and reinstalling, also restarting everything and really are stuck and peeed off with it all now ! :mad:
    El Presidente, we need your help :eek:
     
  17. El Presidente

    El Presidente Beware The Milky Pirate! Moderator This Topic's Starter

    Joined:
    Jan 3, 2011
    Messages:
    30,516
    Likes Received:
    21,332
    HTC Sync doesn't actually need to be open for this to work, it just needs the drivers that go along with it.

    Have you tried the process at all? Does the PC recognise the phone is plugged in?
     
  18. pablo27

    pablo27 Member

    Joined:
    Jan 20, 2011
    Messages:
    12
    Likes Received:
    0
    I ad sync working on my phone before my daughter arrived, turned it off before we connected her phone in charge mode only , pc can only see the phone when disc drive is enabled.
     
  19. nataliep586

    nataliep586 New Member

    Joined:
    Jan 25, 2012
    Messages:
    3
    Likes Received:
    0
    Please help me!!! im so frustrated....i downloaded everything like it said i should...but then tried putting the adb stuff and this is what i got...??????

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.
    C:\Users\Natalie>cd C:\Users\Natalie\Desktop\sdk-tools
    C:\Users\Natalie\Desktop\sdk-tools>adb devices
    'adb' is not recognized as an internal or external command,
    operable program or batch file.
    C:\Users\Natalie\Desktop\sdk-tools>
     
  20. CafeKampuchia

    CafeKampuchia Well-Known Member

    Joined:
    Dec 8, 2011
    Messages:
    2,543
    Likes Received:
    2,787
    Try installing the full Android SDK tools using the article below and running the procedure again.

    Howto: Install the Android SDK - CyanogenMod Wiki
     
    El Presidente likes this.
  21. pablo27

    pablo27 Member

    Joined:
    Jan 20, 2011
    Messages:
    12
    Likes Received:
    0
    Managed to sort my daughter's phone at last . I did receive two mails from HTC which were quite informative, although just went over all that EP recommended . We just connected her Wildfire up to her Notebook and ran the procedure, all worked fine , even though Sync still doesn't respond .
    She's now very happy with her moby, I'm happy that she's happy , so all is good ! Thanks again for the assistance EP .
    :D
     
  22. El Presidente

    El Presidente Beware The Milky Pirate! Moderator This Topic's Starter

    Joined:
    Jan 3, 2011
    Messages:
    30,516
    Likes Received:
    21,332
    Sorry, had a pretty busy weekend or I would've responded earlier :eek:

    I'm glad you sorted it though. :)
     
  23. laimen

    laimen New Member

    Joined:
    Feb 21, 2012
    Messages:
    1
    Likes Received:
    0
    Dzieki wielkie ;) tks for help
     
  24. El Presidente

    El Presidente Beware The Milky Pirate! Moderator This Topic's Starter

    Joined:
    Jan 3, 2011
    Messages:
    30,516
    Likes Received:
    21,332
    Nie ma sprawy. :p
     
  25. starrys800

    starrys800 Member

    Joined:
    Feb 21, 2012
    Messages:
    8
    Likes Received:
    0
    Hi,

    Thanks a ton for posting this. It worked right away and now I have a lot of free internal memory..Thanks
     

Share This Page

Loading...