1. Tablet future looks bright! Read more about: Alcatel Xess | Samsung Galaxy View
    New Forums: Alcatel Xess | Samsung Galaxy View
    Dismiss Notice

Forcing Apps to install to the SD Card without rootTips


Last Updated:

  1. Sokong

    Sokong New Member

    Finally I got it. Thanks :)

    Advertisement
  2. proc

    proc Well-Known Member

    Followed all the steps ,didn't get any errors , screenshots provided look exactly what was taking place... Still it didnt work for me :(
    Tested with angry birds but it still goes to phone memory by itself.
    One thing I did do was turn off usb debugging after I had disconnected my phone.. did it not work because of this? Will I always have to keep usb debugging on?
    I am on 2.3.5 on a510e. Thanks.
    EDIT: carried out he procedure once again this time leaving it in debug mode still no luck... at least with angry birds.. will try out other apps n post.
    Doesn't work with Adobe reader as well so its safe to assume it just doesn't work on my device for some reason.. damn

    UPDATE: it has started working like a charm, disabled usb debugging n still works. ! Many thanks for this useful tutorial .
    One chore less as well as interestingly enabled moving to SD for HTC apps like quickoffice n battery widget that have been installed through HTC hub. The apps I installed which had move to SD disabled like utorrent remote n orange theme for dolphin were able to be moved :).. thanks once again.
  3. jimhwin

    jimhwin Member

    What are the limitations possible when using a Mac? Are there Mac Apps that can help? Or do you really have to use a PC for rooting? (My primary goal is to force apps from auto-booting and to remove some built-in waste-of-space apps). Other goals maybe in the future.
  4. proc

    proc Well-Known Member

    this thread isn't actually rooting the phone... it only makes the apps to install on the sd card by default (doesn't work for some which have to be manually moved) and enables moving some apps which didn't have the moving ability before, which u hav installed, NOT the built in apps.
    u shud post in the rooting section of the forum to have members take notice and possibly help.
  5. hi2011

    hi2011 New Member

    The cmd prompt isn't working for me at all...I entered it just as you said to do, and my phone is set to debugging..but it just isn't working...i'm not frustrated...just wondering why it isn't working for me...???? :(
  6. SMIGGYBFC

    SMIGGYBFC New Member

    Dont work for me can anyone help me :confused:
  7. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Could you both be a little more specific please? What's happening exactly?
  8. JJaquez20

    JJaquez20 New Member

    When ever I do it I type in adb devices and it says "adb is not recognized as an internal or external command, operable program or batch file." Please help me! I can seem to get it right
  9. JJaquez20

    JJaquez20 New Member

    When I install an app it says its on the card but it still takes up a lot of space on my internal memory. Why is this happening?
  10. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Some apps still put a portion of themselves on internal memory, that's unavoidable unfortunately.
  11. tyler3137

    tyler3137 Member

    This is what happens when I try, It doesnt change anything on my phone just spits out all that info. Any help would be great!

    C:\rootevo3dnew>adb shell
    # pm setinstalllocation 2
    pm setinstalllocation 2
    Error: unknown command 'setinstalllocation'
    usage: pm [list|path|install|uninstall]
    pm list packages [-f] [-d] [-e] [-u] [FILTER]
    pm list permission-groups
    pm list permissions [-g] [-f] [-d] [-u] [GROUP]
    pm list instrumentation [-f] [TARGET-PACKAGE]
    pm list features
    pm list libraries
    pm path PACKAGE
    pm install [-l] [-r] [-t] [-i INSTALLER_PACKAGE_NAME] [-s] [-f] PATH
    pm uninstall [-k] PACKAGE
    pm clear PACKAGE
    pm enable PACKAGE_OR_COMPONENT
    pm disable PACKAGE_OR_COMPONENT
    pm setInstallLocation [0/auto] [1/internal] [2/external]

    The list packages command prints all packages, optionally only
    those whose package name contains the text in FILTER. Options:
    -f: see their associated file.
    -d: filter to include disbled packages.
    -e: filter to include enabled packages.
    -u: also include uninstalled packages.

    The list permission-groups command prints all known
    permission groups.

    The list permissions command prints all known
    permissions, optionally only those in GROUP. Options:
    -g: organize by group.
    -f: print all information.
    -s: short summary.
    -d: only list dangerous permissions.
    -u: list only the permissions users will see.

    The list instrumentation command prints all instrumentations,
    or only those that target a specified package. Options:
    -f: see their associated file.

    The list features command prints all features of the system.

    The path command prints the path to the .apk of a package.

    The install command installs a package to the system. Options:
    -l: install the package with FORWARD_LOCK.
    -r: reinstall an exisiting app, keeping its data.
    -t: allow test .apks to be installed.
    -i: specify the installer package name.
    -s: install package on sdcard.
    -f: install package on internal flash.

    The uninstall command removes a package from the system. Options:
    -k: keep the data and cache directories around.
    after the package removal.

    The clear command deletes all data associated with a package.

    The enable and disable commands change the enabled state of
    a given package or component (written as "package/class").

    The getInstallLocation command gets the current install location
    0 [auto]: Let system decide the best location
    1 [internal]: Install on internal device storage
    2 [external]: Install on external media

    The setInstallLocation command changes the default install location
    0 [auto]: Let system decide the best location
    1 [internal]: Install on internal device storage
    2 [external]: Install on external media
    exit
    exit
    exit
    exit

    I also tried to get the install location using the command at the bottom, it said it could not be found.
  12. proc

    proc Well-Known Member

    tyler3137, the command is case sensitive, if its a copy pasted section that u posted; then the command to be given is pm setInstallLocation 2, with a capital I and L.
    It should've been a $ sign after entering adb shell though..where u give the pm command.
    Hope this helps.
    El Presidente likes this.
  13. carolynne

    carolynne New Member


    please help. i really cant get through. im having this error

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\khang>cd\sdk-tools

    C:\sdk-tools>adb devices
    'adb' is not recognized as an internal or external command,
    operable program or batch file.

    C:\sdk-tools>adb devices
    'adb' is not recognized as an internal or external command,
    operable program or batch file.

    C:\sdk-tools>


    please help me. :(
  14. carolynne

    carolynne New Member

    please help. it shows adb is not recognized as an internal or external command...ive turned on debugging and im at charge mode, still i get this error... :(
  15. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Hi Carolynne, can you check within Windows if there are any other folders within SDK-Tools?
  16. spidercles

    spidercles New Member

    Thanks so much for this, worked perfectly.

    A bit off topic, but about only being able to move downloaded apps over...
    I've moved everything I can and still only have 26ishmb left. (out of 124) Aren't the preinstalled apps meant to be on a separate partition? Or are they hogging my internal space. I don't have any photos/music on the internal, I only have 100ish contacts, only have 50txts, no multimedia ones... What am I missing? :confused: I can't get any new apps and can't apply updates cos of this measly 20mb storage.

    I know I can fix this further by rooting, but I'm worried about screwing up the phone/voiding warantee as I'm only novice at technical things like this.
  17. carolynne

    carolynne New Member

    i hope i checked it right @el presidente, i clicked on local disk c>sdk-tools>sdk-tools>(and then there's a lot in it like adb.exe, adb-mac, fastboot-linux, fastboot-windows.exe and 5 more) thats what i see here on my end. what should i do next?
  18. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    That's cool cheers Carolynne. Open the command prompt and type cd\sdk-tools\sdk-tools then press enter. You should then be able to start with the adb stuff.
  19. proc

    proc Well-Known Member

    Check under all applications whether contacts storage and internet (the default browser) are using too much space... in my case the contacts had all my facebook friends profiles downloaded consuming around 10MB of space..i stopped syncing them, just the actual contacts that mean something to me and the number has dropped to 3mb,
    furthermore i use dolphin browser but still the 'internet' app had around 5MB consumed which i again retrieved. you can also run the low storage wizard to clear up all caches.
    one more thing have you updated to the latest 2.3.5? asking this because i must've gained around 30MB just after updating.
  20. jonshaw

    jonshaw New Member


    right on!!!!!! Worked like a charm
  21. spidercles

    spidercles New Member

    I might try updating, if I can even manage to get enough space to do so. Think I read 20mb is needed? Somehow I've gone down to 15mb without downloading any new apps :mad:
  22. proc

    proc Well-Known Member

    Yes i noticed the same decreasing memory when on the older version... now i am not seeing this behavior. I believe updating is worth it.. just clear off one or two apps and uninstall the updates to some apps like maps and facebook and you'll be good to go.
  23. Beryltheperyl

    Beryltheperyl New Member

    Hi - nervous newbie here!!!

    I'm trying to free up some memory on the phone - my sd card is almost empty. I've transferred all the apps that I can to the sd card - will photos/videos/text messages etc be using up memory - if so, can I transfer them to the sd card??

    I've tried the next step on here, by downloading HTC Sync, but the problem I am getting now is that its not seeing the phone. I've got it plugged in to the pc (not that much of a newbie!!!) but HTC Sync cannot see the phone. I get the ding ding noise to say that the pc has seen there is new hardware - but although I have a new F: drive appear, when I click on it, it says to insert a disc. The phone is switched on and both ends of the usb cable are plugged in - so now I'm stumped!!

    I've been on the HTC Sync website and clicked on the General problems button, but now all the options are in Korean or some such language!!!

    Apart from throwing the phone away, can anyone tell me what I'm doing wrong???

    Thanks
    BtP
  24. tintedlenz5

    tintedlenz5 New Member

    I love it when people make things simple. taking my memory back lol:)
  25. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Sorry Beryl, tottally missed this question :eek:. Are you still having issues?

Share This Page