Forcing Apps to install to the SD card without rootTips

Last Updated:

  1. protocolsierra

    protocolsierra New Member

    Worked like a charm on my Galaxy Y as well....Thanks man...:)

  2. dnoble13

    dnoble13 New Member

    does this work only for htc phones? couldnt find anything like this on the alcatel thread, im using the ot glory and its internal memory sucks -_-
  3. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    It should work for any Froyo or GB handset. :)
    naivenitin likes this.
  4. siripurapugopi

    siripurapugopi New Member

    when i enter "adb devices" its shwng "list of devices attached"
    after enterng "adb shell" its shwng "error:devices not found"

    plzz help me
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Have you definitely enabled USB debugging?
  6. loghete

    loghete New Member

    Thanks for the guide, but it didn't change anything. I can't move any more apps to the SD card than I could before. I followed all the instructions without errors and I have a lot of spare room on my sd card.
  7. Juxxize

    Juxxize Active Member

    how did you get it to work on your galaxy y, i think i'm missing a driver or something because my phone isn't showing as connected, but it is showing as connected elsewhere on my PC like in kies. any advice?
  8. mosiddiqi

    mosiddiqi New Member

    Worked a treat, thanks!
  9. chandr

    chandr New Member

    thanks man, it works. u deserve 10000 thanks
  10. maxcoolp

    maxcoolp New Member

    i am having the same problem with my galaxy y please help!
  11. lunatic59

    lunatic59 Moderati ergo sum Moderator

    If you are connecting in Kies, then most likely you are in "Kies" mode. I haven't used GB or FroYo in a while but i think you can change that in menu>settings>applications>usb utilities (i might have the exact location wrong, it's a little different on every phone/version). You can set the mode it connects when you plug it in. "Prompt on connection" would be your safest bet.

    As long as you have the proper drivers for your phone and the ADB tools installed, enable USB debugging and then plug in your phone. Your phone shouldn't prompt you for a connection, but the drivers should install. Then just follow the rest of the instructions as written.
  12. Prasadp

    Prasadp New Member

    Thanks a ton for this post CafeKampuchia...
  13. chirag03

    chirag03 New Member

    thanks a lot man....
  14. siripurapugopi

    siripurapugopi New Member

  15. pradeepnani

    pradeepnani New Member

    as default pico has option to move apps if i follow this method will i get any new feature beyond or is it a same feature ????????
  16. talldad

    talldad New Member

    I have done all, includeing using HTC Sync to get updated drivers installed.
    However, here I stop:
    4. Type adb devices and press enter. You should then see the serial number of your phone displayed on screen. If you don't check, that USB Debugging is enabled and you're connected in Charge Only Mode.

    All I see is the adb help screens, too many, and they scroll off so I can't see the early parts (even after changing the console size with MODE CON).

    How do I tell if I am logged in as or NOT logged in as Administrator?
  17. Zoomer369

    Zoomer369 New Member

    Hi bro, Thanks a lot for your post. For once I thought I have found the best solution to my storage problem. However, it just lasted for some minutes :(
    Coz for example when I install apps which are sized around 10mbs, I am only able to move 5mbs of its space. The rest stays on the internal memory which again causes the same problem. If such high amount of space will remain in the internal memory, then how it will be possible to get rid of this problem completely ? :S
  18. catterbutts

    catterbutts New Member

    Trying to apply to my ancient Google Nexus One (where such a solution is desperate - not even the mandatory 'system' apps will now fit internal memory!) I thought I was being a bit thick as I couldn't find this option to connect?

    However a quick Google appears to suggest that feature has been lost in recent Android upgrades (Nexus is on 2.3.6)?

    Could you confirm this - and perhaps suggest a work-around?

  19. lunatic59

    lunatic59 Moderati ergo sum Moderator

    It will work on a Nexus One with 2.3.6. When CK says "Charge only" mode, he means don't mount as storage. And you'll need to enable USB debugging (menu>settings> ...trying to remember where that is located on the N1 and failing miserably, but it's there). You'll also need the drivers for the N1 before adb.exe will connect.
  20. catterbutts

    catterbutts New Member

    Thanks for the prompt reply.

    Must be the drivers - will un-install HTC Sync and try again paying more attention to the install messages this time.
  21. sampatti

    sampatti New Member

    hi... it isnt working for mine... says adb is not an internal or external command
  22. lunatic59

    lunatic59 Moderati ergo sum Moderator

    adb (android debug bridge) is part of the Android SDK toolset. Once you install it, I believe in the new version you find it under platform-tools.
  23. brindapoojary

    brindapoojary New Member

    worked like a charm..thank you sooooooooo much :D
    lunatic59 likes this.
  24. Shpahla

    Shpahla New Member

    Thanks a lot for this :) though it does work, as you said, a certain portion app does remain on the phones data partition, so it's still a bit of a nag, but nonetheless it helps. Thanks :)
  25. HHyBriDD

    HHyBriDD New Member

    Hi I have done every single thing of the guide correctly but i still cant install the app straight to SD.

    can anyone help please?

Share This Page