Format SD card after Flashing CM7?


  1. csavage82

    csavage82 New Member

    I am totally new to Android rooting but have found my way around pretty well. The issue I am having is after I get CM7 on the nook, the instructions say to "Power down and remove the sd card, put the sd card in your computer and add the Gapps file". I have tried several builds of CM7 including all of the stable ones , whenever I put the sd card back in my laptop it says "you must format the sd card to access it". Am I missing a step? also in CM7, I have found none of the apps seem to work, I can connect to wifi but the browser just sits there etc. Any help for this noob would be greatly appreciated.

    Advertisement
    :
  2. colchiro

    colchiro Well-Known Member

    "Power down and remove the sd card, put the sd card in your computer and add the Gapps file"... doesn't sound like one of my guides. My guides say to copy the rom and gApps to the card and flash the gApps right after the rom.

    Browsers need the sdcard to download files, but not sure if you need them just to browse. Usually they complain if they need the card present.

    If you format the card in your android device (phone, Nook, whatever), your computer will not be able to see it and will offer to format it like you describe. That's why you want to format it your computer then flash it so both can read it.

    Were you able to see the card when you flashed the rom? I assume you made your card bootable, then copied the rom to it. What did you do after that to make the computer not see it? :D
  3. csavage82

    csavage82 New Member

    "Get the one suitable for your cyanogen version (CM7 is the latest for now). The file is named gapps-....zip
    shutdown your nook and take the SD card out, insert it into your computer.
    Copy the gapps-... file to the SD card on the first partition (titled boot) without changing the file name."

    Am I reading this wrong? after my initial boot up and connect to wifi, I power the nook down and remove the sd card. I put it in my laptop, from the point forward the only thing I can do with it is put it in the nook and run a non working CM7. It wont even let me format it from the laptop at all. I have to boot the nook in stock OS and format the card and then format it from my laptop and try again.
  4. stef7

    stef7 Well-Known Member

    I might not be understanding what you are doing exactly.

    On your PC you might try going into Device Management / Disk Manager and assign the SD card a drive letter.


    Otherwise, I think you can format the SD card using a program like SDFormatter.

    I followed the guide on AddictiveTips
    Install CyanogenMod 7 Android 2.3 Gingerbread ROM on Nook Color
  5. colchiro

    colchiro Well-Known Member

    Are you installing CM7 on your sdcard?
  6. TopDogAndroid

    TopDogAndroid Member

    Hi, I'm also a noob - just did this yesterday and I had the same issue.

    The problem was that I had to use a daily build - the stable build didn't work. The other issue was that the stable build didn't allow me to dual boot the nook.

    I formatted the card, got the latest daily build, and the instructions worked as listed.


    Having said that, I am having a related problem - when I put the SD card in my laptop (either in slot, or in USB reader) Windows XP sees the card but thinks there is 0 space on it. As a result I can't copy files to the SD card.

    Can someone advise?

    Should I have formatted the SD card differently when I started all this? (I formatted it in my laptop using FAT32).
  7. colchiro

    colchiro Well-Known Member

    Yes, you need to use fat32 so both Nook and computer can read it. NTFS and only computer can see it, if formatted in the Nook, only it can read it, not your computer.

    What are you trying to do? Sounds like you already have CM7 installed.

    Are you sure you have the sdcard inserted the correct way? If you're using the usb adapter, you have to remove the adapter and reinsert it, not just the card.
  8. TopDogAndroid

    TopDogAndroid Member

    Yes, I have CM7 and GApps installed and running on the NC.

    When I access the SD card (16GB Sandisk Class 4) through my computer, it shows the folder structure but everything has size of 0 bytes according to Windows XP.

    And it won't let me copy files to the card, saying there is no space.
  9. colchiro

    colchiro Well-Known Member

    What happens if you try to access the sdcard with your Nook plugged into your computer? (Choose usb mode via status bar.)

    Can you boot into recovery and fix permissons? (advanced menu).
  10. stef7

    stef7 Well-Known Member

    One thing you can do is go into Administrative Tools, Disk Manager, and see if you can assign a drive letter to the SD Card.

    If you want to re-use the card, why don't you download and run SDFormatter to format the SD Card?
  11. TopDogAndroid

    TopDogAndroid Member

    Do not want to re-use the card - goal is to put some movies on there so I can watch 'em. :)
  12. colchiro

    colchiro Well-Known Member

    Then try plugging your NC into your computer, enable usb mode on your Nook's status bar and copy away.
  13. stef7

    stef7 Well-Known Member

    I'm merely saying if the Nook doesn't recognize the SD Card as storage, you have an issue. You'd want to put it in an SD Card reader / writer and then use something like SDFormatter to format that uSD card.

    But assuming the uSD card IS formatted, and all you want to do is put movies on it, may I make a suggestion? You don't need to use the USB cable to move files between the PC and the Nook.

    Download SwiFTP server from the market onto the Nook. Download FileZilla from the web for the PC. Use the FTP (File Transfer Protocol) over WiFi and drag and drop files from your PC to the Nook, but without the cable.

    This is a good way to put .MP3 content on your Nook as well.
  14. TopDogAndroid

    TopDogAndroid Member

    Tried that - I see

    MyNookcolor(E: )
    It is a 1.0GB capacity drive.

    and

    boot (H: )
    This is a 115MB capacity drive.

    I don't see my SD card at all.
  15. TopDogAndroid

    TopDogAndroid Member

    I think I am starting to get some more useful information.

    I put my 16GB SD card in a USB card reader and put it in my laptop.

    I only see one drive letter for the card:
    boot (E: )
    It contains:
    .android_secure
    B&N Downloads
    LOST.DIR
    My Files
    --Books
    --Documents
    etc.


    Q: Is this the stock NC software from B&N?? How did it get on my SD card?!


    Okay, I went into Administrative Tools > Computer Management > Disk Management

    I see my normal HDs and I see a partition for the card.
    I also see three other partitions:

    Partition Basic Heathly (Unknown Partition) 463MB with 463MB free.
    Partition Basic Heathly (Unknown Partition) 965MB with 965MB free.
    Partition Basic Heathly 13.32GB with 13.32GB free.

    I tried to assign a drive letter to the 13.32GB partition and got this:

    "The operation did not complete because the partition or volume is not enabled. To enable the partition, restart the computer."

    Q: Do I just need to use a partition manager program to enable the partitions?

    Or do I need to format the SD card and start again?

    (Do I need to enable partitions after formatting the SD card and before installing CM7?)
  16. colchiro

    colchiro Well-Known Member

    This is your stock Nook drive: MyNookcolor(E: )

    "boot" is the first partition of your sdcard. Windows can only see the first partition by default for the sdcard.

    Windows by default can't read the android file system so you'll have trouble adding drive letters for many of the partitions there without a special program.


    That's your sdcard where you would normally move your movies, but it's too small.

    Now when you install a rom to EMMC (replacing the stock B&N rom) and you have a 16 gb card, you have most of that 16 gb available for movies. When you use a 16 gb card and put your rom on it, along with all the system partitions, you end up with just a fraction of that space for movies, maybe 8 - 12 gb if you're lucky, depending on how it's partitioned.

    When you saw your sdcard in computer management -- disk management, was the entire card partitioned, i.e. 4 partitions using the entire card?

    Or was there unpartitioned space (space left over)?
  17. TopDogAndroid

    TopDogAndroid Member

    See above post - I saw 4 partitions on the card in total including these 3:
    I also see three other partitions:

    Partition Basic Heathly (Unknown Partition) 463MB with 463MB free.
    Partition Basic Heathly (Unknown Partition) 965MB with 965MB free.
    Partition Basic Heathly 13.32GB with 13.32GB free.
  18. TopDogAndroid

    TopDogAndroid Member

    I must be missing a step.

    I reformatted the SD card and reloaded CM7. Can you check the steps I took?

    Formatted SD card with SDFormatter, used Wipe.
    Formatted as FAT32, 32K clusters, 14some GB available.
    Removed card from computer.
    Put card back.
    It shows boot (E:) and that's all.
    Copied cm_encore_full_177.zip to the card.
    Remove card from computer.
    Boot NC.
    CM7 loads (lots of text). It reboots itself.
    CM7 starts.
    Set up WiFi settings.
    Shut down NC.
    Remove card and put in computer. Still see only one drive E:, 115MB.
    Copy GApps .zip file
    Put card back in NC and boot - hold Home key - get to boot menu, then select recovery mode.
    It unzips the GApps and then screen goes black.
    restart NC, register Google, all is well.
    Shut down NC and put SD card in USB reader in laptop.
    See only the boot E: drive.
    In EASEUS I see 4 partitions. It looks like all 16GB are allocated to partitions, with the boot partition active.

    Is this as expected?

    This is pretty much the same result as the first time I did this. Its very cool btw, I am LOVING the NC...

    BTW Android shows 13.xx GB available storage space on the SD card - I just don't know how to put stuff onto it. :)
  19. colchiro

    colchiro Well-Known Member

    Sounds like you've done everything right. Formatting the 4th partition as fat32 is correct. I don't understand why you can't see the 4th partition when you plug your usb cable into your Nook and choose usb mode from the status bar. It works ok when the rom is emmc (replacing stock rom).
  20. TopDogAndroid

    TopDogAndroid Member

    That's one missing piece to the puzzle. I hadn't been doing that.

    I have not formatted the 4th partition - I formatted the entire SD card when I started. I suspect that is the problem.
  21. TopDogAndroid

    TopDogAndroid Member

    I'm still stuck.

    I can't get at the big partition on my 16 GB SD card.

    I formatted the 4th partition using EASEUS but it hasn't helped anything.

    With the NC connected to my XP laptop with the cable, I see 2 drives - one is the Nook boot drive and the other is the Android boot drive.

    I don't see the 13.7 GB partition so I can't copy any movies to it.

    Same thing if I put the chip in a USB reader and plug it into my laptop.

    What the hell have I done wrong????
  22. TopDogAndroid

    TopDogAndroid Member

    Some more information on this.

    I put my 16GB card in a Linux machine (chip in USB card reader) and the machine was able to see the large partition (13.7GB).

    If this is a Linux partition of some sort is that why it is not readable in my XP-based laptop?

    Can others running XP see the large partition on their SD Cards?

    Thanks for any replies.
  23. colchiro

    colchiro Well-Known Member

    Xp, Vista, Win7... none of these can see a partition on a sdcard that was formatted in an Android device. They should be able to see it in usb mode tho. That's why I suggest formatting as fat32 in a computer and not formatting it in your phone/tablet.

    When you formatted with Easeus, did you have the option of formatting as fat32?
  24. TopDogAndroid

    TopDogAndroid Member

    Yes, I did. It said it was already formatted as FAT32.

    At what stage of the install process should I be formatting the large partition?

    After writing the image with Win32ImageWriter, there are 2 partitions - the boot, and the rest is unallocated.

    Then I put CM7 on the SD card and boot the NC with the card in it - this installs CM7 and creates the 3 partitions.

    I pulled the card right after this when it shut itself down and formatted the large partition then - but it was already labelled as FAT32.
  25. colchiro

    colchiro Well-Known Member

    I've tried a sdcard install (too fragile, too much work to create :D, and more work to update to a newer rom).

    My understanding is you flash your sdcard. If the last partition doesn't use all the remaining space, you delete it and recreate using the entire space and format as fat32, but like I said, I've never been there.

    What guide are you using (link?) and what happens if you don't "format the large partition"... ie. just follow the guide?

    Have you tried a different guide (like the one here)? There are several people here who use the sdcard method and it works for them (but not always the first time :D). I have no use for a reader so have never seen a need for the sdcard install. Besides you can replace your stock rom with CM7 and still read books with only a few missing features (like talking books).
Loading...

Share This Page