Free Sprint Internet/Wifi Tethering, Foxfi etc.General

Last Updated:

  1. brickrick

    brickrick Member

    Just got s3 on sprint, got pdanet working for usb tethering, but need wifi tethering as well. i installed foxfi, and it does broadcast, but i cant connect to it with either my pc or other phone.

    anyone having success with this? any suggestions for getting this done without rooting?

  2. rkkeller

    rkkeller Well-Known Member

    Sprint blocked that app and that's why its not in the app store. I doubt you can get wifi tethering without rooting.
  3. Atrix757

    Atrix757 Well-Known Member

    when i downloaded last night i saw something in the notes for the app about how to go around the block, here is the link for it

    link for foxfi for sprint
  4. brickrick

    brickrick Member

    yes i know it was blocked from the store. thanks for the link, that's the one i used to install. i would think that the app would work, seeing how the makers are making it specifically available for sprint users like they are.

    anyone having success with foxfi or any similar app on sprint?
  5. rensign

    rensign Member

    So I have this build installed,

    I can activate the hotspot, and it will broadcast, but I can not connect win7 machine, it will also sometimes reset the phone... almost like it reboots, but not a full shut down... the sprint animation plays like it's shutting down, then the launcher reloads, and foxfi is no longer active. I have yet to try bluetooth as I do not have a machine with it. Going to go to pick up a cheap bt dongle and see if it makes a difference.
  6. rkkeller

    rkkeller Well-Known Member

    Sprint blocked the USE of the app. It can not access the correct settings it needs in the phone unless rooted.

    I tried it and a couple other free wifi apps and one app actually explained what happened with a pop up that Sprint is not allowing the use of some setting it needs to work. That setting can't be accessed unless rooted or Sprint turns it on when you pay for tethering.
  7. eversontx

    eversontx Active Member

    Yes I am having the same issue with FoxFi. I downloaded the app from the web as instructed. The computer will see it but not connect. Stupid Sprint!
  8. rensign

    rensign Member

    yeah, figured it was something like that... minor setback, this phone still rocks with this build. S2SG, not S3... I'm poor :(

    still have the wifes EVO for the free wifi neway :D
  9. mak916

    mak916 Well-Known Member

    I was hoping to use this app when I got my phone.
  10. brickrick

    brickrick Member

    ah ok. thx for expl. it seems everyone is having the same experience.

    if anyone has a non-rooting workaround of any kind, post away!
  11. Evo 5oh

    Evo 5oh Well-Known Member

    Well i dont know anything about rooting....but i want free internet. If i root i dont want third party launchers/designs whatever you guys call those complicated technical stuff....I want it to be rooted but stock makes sense?
  12. rensign

    rensign Member

    installed pdanet on the phone and pdanet on laptop and the tether works fine, i tried the hotspot while it was not connected to the laptop and couldnt get it to work, maybe you have to turn it on after you tether it, idk, free wifi is free wifi, tether is ok for me :D

    here is a link Download PdaNet

    first phone i have "modded" with no root, and i couldnt be happier... but when someone finds a root for this build, i will most likely give it a go.
  13. JohnGalaxyS3

    JohnGalaxyS3 New Member

    pdanet will work fine. I don't mind tethering.

    I wish FoxFi would work on the GalaxyS3 with Sprint. I noticed that it needed to be updated to work with other phones as they came out. Any chance of an update for the S3?

    Also, I prefer using FoxFi over pdanet, but I don't want to lose the Samsung interface. Can you just root that little part of the phone or do you have to install a full CyanogenMod on it? Cyanogen for the Evo was good, but I really like the Samsung GS3 experience.

    I wouldn't mind paying the extra for 4g or LTE if I had it....Since I pay for it and haven't had either in my service area, ever... I feel paying the extra 30 bucks a month for a hotspot without either Wimax or LTE is WRONG!
  14. JohnGalaxyS3

    JohnGalaxyS3 New Member

    From Foxfi:

  15. valestij

    valestij New Member

    I also tried the bluetooth tether that is built into android between two android devices and got the Sprint Error 67 which basically means sprint blocked that way to tether as well.

    I tried to do Wi-Fi direct between my tablet and phone as well; but that didn't seem to share the internet connection.
  16. brickrick

    brickrick Member

    whats the diff between using foxfi as is, and using "FoxFi over pdanet"?

    i sent foxfi support an email about it not working w s3, they said they are working on it.
  17. Thechidz

    Thechidz Well-Known Member

    He is saying he prefers foxfi compared to pdanet
  18. rensign

    rensign Member

  19. brickrick

    brickrick Member

    anyone know if foxfi is currently working with sprints other new big phone the evo lte?
  20. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    When ever i have the issue the op is reporting with a tether app, it has come down to dns. If the app has the option to set a dns, then dl terminal emulator and do
    Code (Text):
    2. getprop|grep dns
    (su not needed for the command)
    It will spit out your dns, set it in the app and see if it works.

    Shot in the dark, but couldn't hurt to try
  21. pjacobs76

    pjacobs76 New Member

    [HOWTO] Easy Root Instructions (Sprint or T-Mobile) [Updated 24 June 2012] - xda-developers

    This is a link to root our U.S. Sprint Galaxy S3's. This will root your S3 and still keep your ROM stock. As of now, there are no custom ROM's out there. I will be installing FoxFi and see if it'll work now that I'm rooted and post whether it works or not.

    Just downloaded FoxFi, with S3 rooted, and same issue as everyone else. It broadcasts, but unable to make a connection. Tried with my Windows7 laptop and HP Touchpad running Cyanogenmod.
  22. brickrick

    brickrick Member

    wow, thats a trip, not even working rooted
  23. watox69

    watox69 Member

    S3 Foxfi not working:( but does work on EVO 4LTE both my phones on Sprint? hope to see update for our S3's
  24. Them8rix

    Them8rix New Member

    I have a photon and have ran pdanet very successfully for quite some time now. I just added Foxfi this week and had no problems whatsoever. Clean install, and worked like a charm with my Windows 7 machine. My speeds on Foxfi do seem a bit faster and more stable.
    benreaves likes this.
  25. sparksd

    sparksd Well-Known Member

    I was able to get Fofi working over Bluetooth on my Sprint S3 coupled with pdanet running on my Xoom tablet. But with the S3 on 3G it was a slow connection.


Share This Page