Free VoIP Calling Using Google Voice + Sipdroid

Last Updated:

  1. Krasik

    Krasik Member

    Okay. This is my setup. I'm currently using a Verizon phone without a plan. I'm piggy backing off of my bro's skype account and have set GV on my phone to have his skype number. Not my Verizon number. I am using the newest Sipdroid and did the auto setup with my GV number. Here's the thing. I can make calls and send texts no problem. But when someone calls, it rings on my phone and on my bro's skype but when I answer on my phone. It doesn't pick up AND his skype is still ringing. I have my GV to forward to my google chat and his skype number. Any suggestions? I had this setup the long way before. Going through SiptoSis with a cmd window connected to skype. Thankfully, this new setup doesn't require my laptop be connected to the net AND that window up. Now my bro just has to maintain his skype subscription. Running on LG Ally with hacked Froyo rom.

  2. riffdex

    riffdex Well-Known Member

    Currently, I am using a combination of SIPDroid, Google Voice, Gizmo5, and GV Callback to accomplish WiFi calling. Are you telling me theres a better way to do it now? A method of WiFi calling that does not require Gizmo5?
  3. lexluthor

    lexluthor Well-Known Member

    Yes, exactly. No Gizmo5 or GV Callback required. Refer to the first post.
  4. Krasik

    Krasik Member

    All you need is an activated GV account/number and sipdroid :) have fun!
  5. riffdex

    riffdex Well-Known Member

    Me too... I am trying to set this up and I cannot get it to work. I think it has something to do with Google Chat, as I really don't even know what it is... But I do have Google Voice Settings set to forward to it...
  6. Krasik

    Krasik Member

    Its not really google chat so much as its google voice and sipdroid. The only thing you do with google chat is making sure its checked under voice settings/forwarding. Are either of you two on android 2.0+ at least?
  7. grimloch

    grimloch Well-Known Member

    I installed sipdroid a million times and the button never showed up. I have google voice through my google apps email account (not

    I added a gmail account to Android (Evo 4G running CM6.1.2) and then and only then did the PBX account button show up after installing sipdroid. Hope this helps anyone who may be having the same frustrations.

    After I set up the new PBXes account through siproid I then logged into and changed the gtalk trunk info to my google apps info. I also changed my email contact info under the Personal section.
    bunklung likes this.
  8. kkc0123

    kkc0123 New Member

    Concerning the original post, I think there may be some confusion about changing settings in one's Google Voice account. Some may think you are referring to the Google Voice App rather than the actual online account settings. I believe the app is not involved in this setup at all, correct?
  9. riffdex

    riffdex Well-Known Member

    I have been trying to get this set up for the past few days but I can't seem to get it to work no matter what. I think this has something to do with Google Chat. I don't even know what Google Chat is, and don't use it. I think I must have Google Chat setup incorrectly or maybe my pbxes account is not set up right. I have my Google Voice set to forward to Google Chat but do I need to DL Google Chat to my phone for it to work or something? What do I need to do to setup my pbxes account? I don't know anything about pbxes I just created one using the button in SIPDroid and I logged in, but it doesn't seem to work. I have been using SIPDroid/GV Android App/GV Callback app/Gizmo5 for the past few months and I had it working fine with Gizmo5. But it was sort of unreliable and sometimes I would be at home with my phone connected to WiFi, and the circle at the left of the notification bar would be green (indicating everything was working fine), but if I tried to call my GV number, it simply would not ring on my phone. Other times it worked perfectly. At times the circle would turn red or yellow for a few seconds but would reconnect and go back green, but this didn't happen a whole lot. I was hoping to get this pbx thing set up to simplify the whole process and eliminate some of the variables. I think I have a better chance of this thing working consistently if I don't have to depend on so many different services functioning perfectly all the time. If anyone has any idea why it might not be working please let me know your thoughts :/

    EDIT: The problem is definitely not from Google Voice. I can call my GV number and (if I have Gmail open), it will start ringing on my computer. There seems to be some problem getting from GV to going through Google Chat or the PBX acct. Also I just realized the notification circle at the top left is red now. It was green earlier, but it still didn't work then. Anyone know why it would be red and how to try to fix it?

    I am on 2.2.
    I have Google Chat checked as my only number to forward to, so if you are saying that's the only thing I need to set involving Chat, then that's probably not the problem. The problem is I have no idea exactly what component of this whole thing is not working out right. GV works fine (I can dial my GV number and it rings on my computer when I have Gmail open), and I have been using SIPDroid with Gizmo5/GV/GV Callback for a few months so I figured SIPDroid is working okay...

    EDIT: One weird thing I have noticed is, when I set up the acct linked to my GV acct (I did this by clicking the button in SIPDroid when I opened it), I created the username "". But after it set everything up, if I drag down the notification bar it says "
    If I go to Settings and click "SIP Account", it has my acct input as "riffdex-200". It makes no sense because if I go on the website on my actual computer, I log in with riffdex, not "riffdex-200". I have tried to log in as "riffdex-200" and it says it's not even a valid account. So obviously my account is riffdex, not riffdex-200. But it has my Username input as "riffdex-200" and it says "Registered" with a green circle at the top; Which would imply all the info is input correctly. I even tried to change the Username to riffdex and then the circle went red and it didn't work at all. I had to change it back to riffdex-200 to even get the circle back green. This doesn't make any sense to me, and I've had trouble even trying to explain it to you guys, much less understand why it is doing that...

    Here's a SS to explain it:
    Sorry it's bad quality picture (taken with an ERIS)... It makes no sense that it would say "". My username is I go to the website on my comp and log in as riffdex and it works, and if I try riffdex-200 it says invalid username/password. So my username is obviously riffdex so why would it say riffdex-200? It just makes no sense :/
  10. jacjb0x

    jacjb0x Member

    200 is your extension at pbxes. login to your pbxes account and click on extension in the left hand pane. hope this helps.

    - jack
  11. Krasik

    Krasik Member

    I figured out how get received calls to answer. You must go check Auto-Answer in use and Auto-Answer on demand in Sipdroid Call Options. Not sure if both have to be checked but I can answer calls now. It rings once or twice then picks up. :)
  12. riffdex

    riffdex Well-Known Member

    ok thanks for clearing that up

    Just tried this but SIPDroid still will not ring when I call my GV number. :/ I've set this up/switched back to Gizmo5 so many times I should be a pro at this... but it never works :/
  13. Krasik

    Krasik Member

    If I'm not mistaken, you need to have your cell number and Google Chat forwarded in Google Voice on the website, not the app. That's how I have mine set up.
  14. riffdex

    riffdex Well-Known Member

    Yes, I enabled Google Chat forwarding through the Google Voice settings under the website. I haven't changed any settings under the android app at all since I have been trying to set this up. Btw I just replied to your PM.
  15. drdoom

    drdoom Well-Known Member

    For people that have this working fine, have you noticed any glaring flaws?
  16. Krasik

    Krasik Member

    Flaw no, occasional down yes. Sometimes, I have to try and make a call, hang up, and do it again. As of lately, it hasn't been too bad. Works everytime.
    drdoom likes this.
  17. PSkeptic

    PSkeptic Well-Known Member

    The only thing I've seen is that when driving and trying to use a 3G connection, the call is VERY spotty.

    Other than that? None. The app integrates with the google dialer and address book very well, and PBXes runs Asterix so no issues there.
    drdoom likes this.
  18. chichen

    chichen New Member

    So I have been attempting to use this on my VM intercept. I've found that when google voice is forwarded to the cell number I am being billed minutes on my account. This is more than a little concerning.

    If I disable forwarding to my cell phone I am no longer being billed but the call quality is terrible. I can hear the incoming calls quite well but on the other end there are echoes and/or other people on the line. This is on both 3g or wifi (at multiple locations including at work wifi-->T1).
  19. lexluthor

    lexluthor Well-Known Member

    You must have somehow been answering through the phone and not sipdroid. That's the only way that could happen.
  20. riffdex

    riffdex Well-Known Member

    I have never been able to set this up still. It makes no sense why it would not work as I have done everything exactly how it says to. I managed to set up SIPDroid/GV/GV Callback/Gizmo5 for VOIP use, and it seems like this should be a lot easier to set up. I don't think I am doing anything wrong in the setup. Does anyone have any ideas..
  21. comprocket

    comprocket Member

    This has stopped working for me in the last few days. I even deleted my PBX account and re-created one and it still fails. Every call says that it cannot be completed as dialed.
  22. PSkeptic

    PSkeptic Well-Known Member

    It is now. All you need is SIPDroid + Google Voice (Don't really need the Google Voice App).

    1) Download Google Voice (The real Google Voice App).
    2) Make sure your google account has google voice enabled.
    3) Download SIPDroid.
    4) On first run, tell it to set up PBXes for Google Voice.

    All done!

    I know the Google Voice trunk was broken for a bit... Works fine right now though.
  23. yumms

    yumms New Member

    I've tried everything. Can't get the registeration button to show up.

    I've installed, Google Talk, Voice, using my gmail account as the main account on the device.

    Uninstalled/installed Sipdroid countless times...nothing. :(
  24. RanT476

    RanT476 Member

    Sup people, i finally got this working well and been using it for a bit but a few things, it only rings 1 time and then it ends the call and goes straight to voice mail sometime, i cant even get up and get my phone or i pick it up from when the phone is rite next to me and i miss the call. and my Bluetooth worked on 2 calls so far, i can always hear them but they cant hear me...if those 2 are solved everything will work perfect.

    lexluthor i sent you a message u never answered me i figured it out on my own but plz help me on this one, so i can get it to ring as long as a regular phone does and if u can help me on the bluetooth situation that would be great also thx all hope to hear some feed back. and thx for putting this up its the best!!!!!
  25. riffdex

    riffdex Well-Known Member

    That is exactly the steps I have taken for the (seems like) 20th time now, and it never works. SIPDroid does not ring when I call my GV number. I have GV set to forward to Google Chat, and I have my PBX acct set up in SIPDroid and it says registered.

    I was just reading this page:
    :: p b x es :: your virtual PBX and CRM on demand
    It says that "Starting today all paid users may register their Google Voice trunks from their PBXes... [cont.]"
    Does this mean this will not work unless I am a paid user for PBXes?

Share This Page