French X10Support


Last Updated:

  1. Koyanishi

    Koyanishi Well-Known Member This Topic's Starter

    Joined:
    Apr 17, 2010
    Messages:
    64
    Likes Received:
    7
    I've been trying to connect the Xperia x10 that I recieved yesterday to T-Mobile data network but no joy. Everything else works ok except for the t-mobile data connection.

    I have tried everything, setting apn manually - even have reset the phone etc.

    In the mobile networks menu the Auto Internet Settings option is greyed out.

    This is a French phone that I got from Expansys US internet vendor. The manual is in French and its got a french wall plug. I had no clue I was buying an import as the web cite does not specify that it is an import and in the discussion with salesman it was never mentioned that it was an import but he assured me it had a us waranty and was able to connect 3g to t-mobile therefore I assumed it was a US phone.

    Sony Ericsson tells me this phone is not yet released in US.

    Do US owners of this phone have imports or does any US owner have a 10xa phone?
     

    Advertisement
  2. Koyanishi

    Koyanishi Well-Known Member This Topic's Starter

    Joined:
    Apr 17, 2010
    Messages:
    64
    Likes Received:
    7
    Update:

    I called Expansys sales rep to get RMA but as it turned out he knew more about the phone than did t-moible tech support.

    Upshot is that I can now connect to t-mobile data network. Seems that I have legacy plan from t-mobile so the apn settings were different than from what 3 different t-mobile representatives told me they should be.

    On another topic -

    So far, I have no issues with the loudness of the phone and the stock keyboard seems just fine.
     

Share This Page

Loading...