Frequent notifications when plugged into power?Support


Last Updated: 2010-12-11 15:09:25
  1. theredkrawler

    theredkrawler Active Member

    G'day,

    Running Galaxo 1.6.3.3 and while its an absolute dream and blows the stock 1.6 build out of the water, theres one tiny issue that I wouldnt mind solving...

    When plugged into power (either USB or AC), the notification alert goes off frequently and as far as I can tell, after random periods of time. To clarify, if I put it on charge when I goto bed I'll get woken up 5 or 6 times throughout the night for the notification tone playing to say its now on charge. If I check battery usage, it says its only been plugged in for a few seconds so as far as the phone is concerned, it was unplugged/replugged in.

    It does it whether its via USB on the PC, my car charger or wall charger so its not a specific charger.

    My current solution is to put the phone on silent before going to bed which is fine so long as I remember to do it, but since I'm on call for work every 4-6 weeks (but not exactly the same time period every 4-6, so I cant use a scheduler to automagically silence it at specific times/dates) I *need* the phone to ring during the night if theres an issue.

    Did anyone else have this problem, and knows how to fix it? :\

    Advertisement
  2. zaniku1

    zaniku1 Member

    I got the same problem.
  3. Kamala

    Kamala Well-Known Member

    Same for me. Also would like to add that sometimes it gets really hot.
    Btw Solution can be that you add some "no sound" ringtone as notification sound, so you dont have to turn off all sounds in your phone. ( or just silent all notification sound )
  4. gil1

    gil1 Active Member

    It is caused by the lowest CPU frequency, 19Mhz, it is not enough to support the usb connection.
    download SetCPU or any other overclocking app and set the lowest cpu frequency to 120Mhz.

    It should solve the problem.
    theredkrawler likes this.
  5. qwerty100

    qwerty100 Well-Known Member

    I would see this kinda happening with the 1.5 builds, though 1.6 looks (sounds) like it adds a notification beep when charging.

    What i think is happening

    1. You plug phone in and go to bed.
    2. Phone charges
    3. Phone gets to 100% charged, stops charging
    4. Some time lapses and battery drops to say 98%
    5. Phone decides It will start charging again, and plays the bloody notification - goto step 2.

    Like i said, with 1.5, I would leave it face up (but off) and every now and again, you'd see the phone light up, just like you've plugged the charger in.
  6. Rastaman-FB

    Rastaman-FB Well-Known Member

    this fixes it
  7. theredkrawler

    theredkrawler Active Member

    Well, that certainly is an answer that makes sense.....

    But surely raising the lowest clock frequency to 120Mhz will negate one of the bigger gains in battery life provided by Galaxo?

    Or does SetCPU allow you to set the minimum frequency when plugged in seperately to unplugged? I may have to revisit that app if that is the case.

    In the short term I've used 'Profiles' to make a night time profile that turns off notifications while leaving the ringtone and message tone intact (... apparently - tonight will be its first test) so I'll roll with that if SetCPU can only change the lowest frequency accross the board.

    I'm too used to having 70% battery left at the end of a working day now :p
  8. MichaelW

    MichaelW Well-Known Member

    I believe the default min frequency is 250MHz, so it's still an improvement.
  9. master darko

    master darko Active Member

    Woo hoo! Sounds like problem solved to me. I normally put my phone on silent at bed time so the notification sound did not annoy me much but what used to really annoy me was losing USB connection on the pc during file transfers.

    Enabling charging profile on setcpu with min freq of 245MHz seem to have fixed it. I still have sleep profile enabled with 19-245MHz range. It looks like charging profile has a priority over sleeping one. In other words as long as the phone is plugged in, charging profile is active regardless whether the phone is asleep or not.

    Sent from my Galaxy using Tapatalk
  10. theredkrawler

    theredkrawler Active Member

    I thought I should update this...

    SetCPU fixed my problem. I'm now running 3 profiles:

    Priority 50 Powered: 245Mhz -> 614Mhz, performance
    Priority 40 Screen Off: 19Mhz -> 120Mhz, ondemand
    Priority 30 Battery < 100%: 120Mhz -> 614Mhz, ondemand

    Works a treat and no more annoying notifications when its on charge. 120Mhz maximum when the screen is off seems enough to keep things like K9's IMAP IDLE commands ticking over too.... I had it on 'powersave' profiling and they kept FCing, so I must be pretty close to the minimum possible speed that things will keep operating at.
  11. bresslau

    bresslau Well-Known Member

    I used the overclocking widget and that also did it for me, setting the minimum CPU speed to 120Mhz.
  12. qwerty100

    qwerty100 Well-Known Member

  13. bresslau

    bresslau Well-Known Member

    I have a few questions:

    - What is the reason you don't go all the way up to 710MHz?
    - When you write "powered", do you mean the option "charging/full"?
    - Do you use the option "set on boot" on the first screen? Do you know what it would do?

    All the best,
    Fernando
  14. theredkrawler

    theredkrawler Active Member

    I dont use 710Mhz because of battery life. I found 710Mhz had a noticable impact on battery life, whereas 614Mhz didnt. I could probably enable it on the charging profile I suppose, but normally when its on charge I'm in bed anyway :)

    Yes, "powered" = "Charging/Full"

    The main screen option is your main profile. Set on boot just makes sure the settings are applied each time you turn on. I've changed my setup slightly so I no longer have a 'Battery < 100%' profile - I just let it default to whats set in main profile now.
    bresslau likes this.
  15. T75

    T75 Member

    PROBLEM SOLVED ! NO COST !
    I saw this suggestion in another forum and it WORKS, so I'm passing it on !
    Set the global notifications to SILENT.
    Set the notification on Gmail to any ringtone, NOT DEFAULT.
    Set the notification on messaging to any ringtone, NOT DEFAULT.

    You'll still have a tone when you 1st plug the phone in to the charger, but NO tone when it's fully charged.

Share This Page