Froyo 2.2 update fail (yellow exclamation point)Support


  1. Billkwando

    Billkwando Well-Known Member

    Use the one in the zip provided by pasta. Don't unzip it, mount your phone and copy the zip from your computer to the root of your sd card. Rebot your phone into recovery mode and click on the update.zip
    adamtrott likes this.
  2. adamtrott

    adamtrott Member

    thanks!!!!!!!!!!!!!
  3. Billkwando

    Billkwando Well-Known Member

    No prob! Make sure you unmount your phone before unplugging it from the computer.
  4. adamtrott

    adamtrott Member

    did you happen to get rid of the email app?
  5. Billkwando

    Billkwando Well-Known Member

    What??

    I've learned that getting rid of anything before 2.2 is installed just causes a huge headache. If you see my post above, I'm gonna have reformat my phone and do a factory reset before I can install it.

    Edit: Besides, with the 2.2 speed (and size increases due to App2sd), we may not have to remove anything anymore.
  6. adamtrott

    adamtrott Member

    factory reset doesnt reinstall deleted apps. ive allready done that lol. im redownloading all the stock apks
  7. Billkwando

    Billkwando Well-Known Member

    I think that means you want to return to stock using the steps provided in the one pastapost. The one with the update.zip

    Edit: If you have a better idea though, I'm all ears. I haven't gotten an answer back yet on how to backup all my app settings.
  8. adamtrott

    adamtrott Member

    mine keeps failing :-(
  9. Billkwando

    Billkwando Well-Known Member

    Please be more specific, so we don't have to clog up teh thread. Or just add me on yahoo im: Billkwando

    Edit: We did take this to IM. If we come up with any nifty ideas, we'll post back.
  10. dpsc8306

    dpsc8306 New Member

    Thank you! I already had the RMA # to send my phone to samsung. I figured I would try this as a last resort and it worked. Downloaded the update.zip, saved it to a microSD, Booted into recovery mode and selected install sdcard/update.zip. I really can't thank you enough.
  11. Billkwando

    Billkwando Well-Known Member

    Yay! Congrats, homie. :)
  12. mikeybee95

    mikeybee95 Member

    Welp, im po'ed
    I really dont feel like going thru all this bs to get back to factory to get to 2.2, im about to just go to a sprint store
  13. longlost

    longlost New Member

    1. Power down the phone. Press and hold the volume down, send, and end keys. The Samsung start up logo displays. Continue to hold the buttons down until the recovery screen displays.
    2. Using the volup/down button, highlight wipe cache partition. Press the center button on the optical joystick to complete the action. The display returns to the Android system recovery screen.
    3. Use the optical joystick to highlight wipe data/factory reset. Press the center button on the optical joystick to complete the action.
    4. The Wiping cache screen displays. Press the volume up key to continue.
    5. download your update.zip from Froyo 2.2 DL05 update for intercept

    6. Use the optical joystick to highlight apply sdcard:update.zip. Press the center button on the optical joystick to complete the action.

    good luck
  14. Billkwando

    Billkwando Well-Known Member

    To be clear, those instructions do not apply if you have rooted/temp-rooted and deleted any of the stock crapware.
  15. Billkwando

    Billkwando Well-Known Member

    After literally ALL DAY messing with it, I just got 2.2 installed, using that link (and the various links that branch off from it). I'll try to write up a clearer guide soon. Right now I'm cradling my brain and massaging my sanity.

    I'll probably never root again. LOL
  16. Android25

    Android25 Well-Known Member

    Where can I get the azonmp3.apk? I don't want to have to do anything drastic to get my phone to look like when I bought it (as noted in the link above), considering all I did was temp root and remove the amazon application, nascar, and football (I think that's all...I can't even remember now, but the updater is only asking for azonmp3.apk so far).
  17. Android25

    Android25 Well-Known Member

    Well, I think I have amazonmp3.apk (unless it has to be some specific version), but how do I get it to the apps folder? Do I have to try to re-temp-root? I can't remember how as ES explorer says copy failed when I try to manually move it to the apps folder.
  18. Billkwando

    Billkwando Well-Known Member

    Here's my simplified version of the instructions, specifically for folks having problems due to rooting or temp-rooting. Get the downloads from the original links. I just provided the exact file names so there's no doubt that you've downloaded the right things.

    Everything after Step 1 is from the link Pastafarian posted here. The instructions from page 4 (for VM users) really helped spell it out for me. I just thought I'd try to write it up a little easier.

    1. Backup everything on your phone with My Backup Pro from Market (free version has 30-day trial). Do both apps and data.

    2. Go ahead and install the Intercept drivers from the Samsung site here. Also, make sure you already have update.zip at the root of your SD card. Get update.zip here.

    3. Download and install SWUpgrade (SamsungMoment_Update.exe) & reboot if requested. Download it here (some versions have been problematic, so I uploaded the one that worked for me). Then install the patch (SDX Samsung Updater Patch.exe). Get the patch here.

    4. Then browse to C:\Program Files\Samsung Electronics\SWUpgrade\Models\Binary and delete the SPHM900 file in there. Not doing so may very well perma-brick your phone. Do NOT delete the SamsungPST_SPHM900.dll that is one folder up. I made that mistake and it hung me up for like an hour.

    5. Download SPH-M910_MR_DF27_REL_156.tar, which will be your stock update file you'll be flashing with. You can get it from SPH-M910_MR_DF27_REL_156.tar.zip (courtesy of "adamtrott"). Make sure you rename it and remove the .md5 file extension, so it's just "SPH-M910_MR_DF27_REL_156.tar". Copy it to the binary folder.

    6. Time to get down to business. Put your phone into download mode (shut down, then hold Vol Down + Camera + End Call) and hook it up to the USB. Start up SWUpgrade, maximize it, & accept the agreement.

    Ignore all the onscreen instructions. If you followed these directions, you've already done everything it wants you to do, and you get to just hit "Next" like an angry monkey until it starts flashing the phone, which will bring up a blue loading bar that will roughly correspond with the one on your phone's screen. Wait till it completes (it will pop up a box for you to OK out of). Pow!

    7. Final step. Reboot into recovery (Vol Down + Call + End Call), and select "apply sd card :update.zip".

    Watch your phone flash (the "Updating Modem" step takes the longest, so don't panic) and enjoy some sweet sweet frozen yogurt! Make sure you always read the ingredients though, and avoid anything with "carmine" in it. That's the mashed up bug asses (and eggs) they use for coloring. True story, bro. Google it.

    After you're done, go to the market and redownload MyBackup and restore your apps and settings. Do "check all" but be careful to read any prompts as they come up before blindly clicking. I lost my Angry Birds save, but I really don't give a crap at this point. If I ever decided to temp root again, I can prolly slap it back on with the backup I made from Titanium Backup.

    Hope this helps someone!

    PS, Big thanks to adamtrott for brainstorming with me on this thing with me for literally 10 hours.
    latinmaxima and adamtrott like this.
  19. adamtrott

    adamtrott Member

    works like a champ!!!!!!!!!!!!!! and thanks billkwando for all your help thru im!!!!!!!!!!!!!!!!!
    Billkwando likes this.
  20. Billkwando

    Billkwando Well-Known Member

    You're welcome Adam! Let's not direct link my email for all the spambots though, shall we? :p
  21. posicat

    posicat Member

    Mine was perm-rooted, and it was locking up on verification of playlogo, fortunately the root instructions I followed had backed it up as playlogo-orig, I renamed the orig back to playlogo, and I'm most of the way through "updating modem" ... here's hoping.
  22. posicat

    posicat Member

    Yay, I'm up to 2.2 now, thanks for all the details in the forum, they helped me troubleshoot what was sticking my upgrade. I lost root in the process of course, but I'm sure someone will figure out how to root the 2.2 Intercept in short time. Thanks again!
  23. adamtrott

    adamtrott Member

    yea sorry bout that hehehehehe
  24. Ejarboe

    Ejarboe Member

    So my GTALK app isn't in the place it's supposed to be. I re-downloaded the .APK after doing a temp root to remove the bloat, but since I temp-rooted I didn't get the .APK back in the system/apps folder.. I just got it on my phone so I could use the market and not get that silly force close error every 5 seconds.

    Will the steps above work for me if I follow them, or am I going to need to do yet another temp root to put GTALK back into the "correct" folder first? I'm downloading the stuff as we speak, but haven't gotten started yet.

    Thanks in advance!!

    My first post/question, btw... Go easy on me. :)
  25. Billkwando

    Billkwando Well-Known Member

    I'm not sure I fully understand. Couldn't you just put the apk into your download folder (for example), then install it from your file manager? Wouldn't that put it where it belongs? By "the steps above" do you mean the ones to install 2.2 on your phone? Does your phone already have 2.2?
Loading...

Share This Page