Froyo 2.2 update fail (yellow exclamation point)Support


  1. mikeybee95

    mikeybee95 Member

    I called my local sprint store. They said my phone "fried" Bring it in, i'll take about 40 minutes. Hopefully they dont notice i rooted my phone :p
    Ill let ya'll know how it goes (getting it done tomorrow)
  2. johnadon

    johnadon New Member

    I've posted this on the sdx forum, but I think I posted this in a thread which has gotten lost in a pool of VM Intercept users interested in updating their carrier's Intercepts to 2.2. This thread is exactly on topic with my problem. I'm going to copy and paste a bit from my other post. This is sort of a hybrid-semi-quasi-cross-posting so anyone who's seen the sdx posting, please be patient with me. :)

    I got the 2.2 update OTA, but it failed. Subsequently, I downloaded the 2.2 update zip, booted into recover mode, attempted to install the zip, but was unable to do so. Everything goes fine up to a point where it appears to be looking for the Sprint Zone app to patch. I had uninstalled previously the Sprint Zone app by going into temporary root with z4 (i've never done permanent root) and deleted that app along with Nascar and Amazon mp3. Upon next reboot, I found an apk of the Sprint Zone app and installed it even though I found it in another forum for another phone and the program is old, perhaps a version released in July? Sprint is my carrier.

    I did a backup of my files prior to deleting the system files, but apparently I didn't something wrong or the backup failed because I the system files are not in the backup, only the apk's I installed myself. It looks like there are problems with not having the original system apps

    Does anyone know where I can download the original Sprint Intercept system files? Or anyone willing to post a backup of their own? :-D I guess more importantly, will this even help me? I think even if the OTA update comes through again, the update will fail in the same way since I no longer have those files.

    Thanks for any help!
  3. Ejarboe

    Ejarboe Member

    No, I'm trying to get to 2.2.

    What happens is that before trying to install the 2.2 file I clear the cache partitions and then wipe the device, so when 2.2 tries to install it gets hung up saying it can't locate system/apps/GTALK because it's no longer stock.. it was installed from a .APK file. I accidentally deleted it during a temp root. Whooops! My bad.

    I'm kinda stuck.. hahaha.
  4. Billkwando

    Billkwando Well-Known Member


    This is your thread. Everything here applies to you. You're having the exactly same problem I did, so just follow the instructions in the previous posts (Pasta's or mine) and you're golden. You're gonna have to wipe your phone and restore it to stock, then install the update.
  5. Ejarboe

    Ejarboe Member

    This is EXACTLY the problem I have to a T... except that mine is Talk, not Sprint Zone.
  6. Billkwando

    Billkwando Well-Known Member

    Should we edit an earlier post to make it easier for folks to understand that the answers are already here, or did you understand and were just hoping there was a simpler way? I'm not being sarcastic, so please don't think that.
  7. Ejarboe

    Ejarboe Member

    Nope.. I just wanted to make absolute SURE that this was going to work for my situation. :) No sarcasm detected.

    Only problem is, when I run the SWUpdate and get to the part where it's supposed to start copying files, it says "Cannot open bin file!"

    I've followed your instructions (which are awesome, BTW) twice but for the life of me I can't figure out what's happened.
  8. Billkwando

    Billkwando Well-Known Member

    The bin error means you have the wrong version of swupdate. Adamtrott had the same problem. We struggled with it for hours before he figured it out.

    I'm uploading the right one to Mediafire right now for you. Please check back in a moment.

    Edit: Here's the link! :)
    http://www.mediafire.com/?rytir9aliigx7az

    Please let us know how it goes, and sorry I didn't mention it in the instructions (glad you like them!). I'd hoped Adam's case was a fluke.
    Ejarboe likes this.
  9. enfuego44

    enfuego44 New Member

    Anyone having GPS issues since update to 2.2? Mine will not lock on location now and I can't use either navigation (google or sprint). Anybody else see this?
  10. Ejarboe

    Ejarboe Member

    Billkwando... (wow. I think I suddenly developed a slight case of dyslexia. I beg your forgiveness for the terrible misspelling!!)

    It is people like you who make the world of do-it-yourself-ing cell updates possible. Thank you for taking time out of your Sunday to help me figure out how to put 2.2 on my Intercept. I'd love to send you a Christmas ham... hahaha ;-)
  11. Billkwando

    Billkwando Well-Known Member

    LOL Billwanko, huh? That wouldn't be the first time I've gotten that, and probably won't be the last. I probably have a black belt in Taewanko by now. :p


    Let's wait till it works first! ;) I'm actually pretty new to this whole cell phone thing, but I do really like helping people. Need drivers for a homemade H-shifter controller for driving games? Got an old EZbus digital mixer you can't find the install files for? Need to hook your Rock Band instruments up to your computer? Need to use your Steel Battalion controller on PC? I'm your guy!
  12. Ejarboe

    Ejarboe Member

    Currently downloading the SWUpdate software you linked to. Is the patch that I found over at SDX that Pasta linked to the correct patch for this software as well?


    And can I seriously hook up my RockBand instruments to my PC... that would be sick!!! :D

    EDIT: Still working. I'm gonna stay here until I get this done tonight so I can be the guinea pig. My phone is fully functional on 2.1 right now with a few (slight) mods such as removal of bloat and addition of LauncherPro but I'd really, really, really love to get 2.2 on here if only for the capability to store apps to the SD card. :-D Besides, if I can do it... then so could a kindergartener.
  13. Billkwando

    Billkwando Well-Known Member

    It should be? Honestly I'm perplexed at how it happened, so I figured the best way would be to provide the one that worked for me.

    Yes, why yes you can!

    Rock Band Instruments on DTXMania
  14. Android25

    Android25 Well-Known Member

    So there is no way to get it to work by replacing the apps rather than the whole (scary) flash technique? I did re-temp root, dropped AmazonMP3.apk in the apps folder (though it may be a problem that its not the original?), but the update process still fails on 'system/app/amazonmp3.apk cannot be found. I was hoping to avoid a full wipe if possible. I think ''m only missing that and nascar and football.
  15. Ejarboe

    Ejarboe Member


    I just finished downloading that one and applying the patch. Same issue. Couldn't open bin file. :S


    OH WAIT!!! Here it goes!!! Woooo hooooo!!!!!
  16. Ejarboe

    Ejarboe Member

    Damn. Phone won't turn on at all. :(
  17. Billkwando

    Billkwando Well-Known Member

    I don't believe there is any other way. I backed all that crap up with Titanium Backup and it wouldn't reinstall right.


    Awesome! Be patient, and don't interrupt the process, no matter how long it takes.


    Did you forget to delete the old binary from the folder? Did you try pulling the battery?
  18. Ejarboe

    Ejarboe Member

    Nope, deleted the old binary and replaced it with the correct one.

    Pulled the battery. Phone seems to be ON somewhat but the LCD is completely black. If I push the END button the softkeys light up.. but that's it. I get some haptic feedback if I touch the screen, but no light :(
  19. Billkwando

    Billkwando Well-Known Member

    So you re-deleted it after reinstalling? Can you get into recovery or download mode?
  20. Ejarboe

    Ejarboe Member

    I'm not sure what I'm into. The LCD won't light up. I deleted the Samsung Moment binary and replaced with the Samsung Intercept binary before I DL'd the software. Wish I could get it back into download mode at least and try again but I have no clue where it is... black LCD screen. :S Any ideas?

    EDIT: Held keys down to try and enter download mode again but the SWUpdate won't recognize that the phone is connected to the USB anymore.
  21. Billkwando

    Billkwando Well-Known Member

    Reinstalling the software puts it back. That sucks dude, I wish I could be more help. Can you take it to the sprint store and plead ignorance?
  22. Ejarboe

    Ejarboe Member

    Sigh. I wish. Nearest one is about 40 miles from me. :( The phone IS powered on. I can hear that little sound it makes when the signal kicks in/out. There's just no LCD.. it's black. Something tells me it must be running Moment software or something really, really weird. Like I said, softkeys light up with I press the end key, and every now and again the screen will vibrate when I touch it, but that's it. CRAP! Hahaha!
  23. Billkwando

    Billkwando Well-Known Member

    I'm really sorry. I should've reminded you to delete that file again. I think you're exactly right.
  24. Ejarboe

    Ejarboe Member


    I checked it twice. I think I may have accidentally moved to Intercept file to the wrong program file since I'd downloaded the wrong software the first time. Fudge. I'm on the phone with their advanced support.. maybe I can guilt someone into sending me a replacement? :S

    EDIT: Warranty replacement will be here in 3 days. I'm 40 miles from a store. This is going to be a long 3 days... lmao. Live and learn!! The more failures, the closer I am to success!!!
  25. posicat

    posicat Member

    Try doing the steps you remember before from memory, just put the right version on this time. Or maybe you can connect to it via ADB?

Share This Page