Froyo, Moto Droid (1) - USB screen


Last Updated:

  1. tjoebgen

    tjoebgen Well-Known Member This Topic's Starter

    Joined:
    Dec 27, 2009
    Messages:
    101
    Likes Received:
    4
    First - wow... is there anyway to convert that stickied master-thread of all bugs and stuff for froyo into different topics? It's impossible to follow since there are quite a number of compliants. Hence why I'm putting mine separate.

    Okay - my phone sits on my desk most of the day with me (tucked right below my monitors), plugged in to the usb cable. Keeps it charging and awake so I can see if I have new messages, see the clock, and the weather. When I want to access the SD card as a portable device, I just swipe down and turn on USB storage. Nice and easy.

    Froyo update is really annoying me (for several reasons, but....) because every time I plug in to usb, it pops up a full screen announcement that I just plugged in a usb cable. Great - I knew that already... I preferred the old method of a little banner in the status bar that went away quickly. This thing doesn't go away - it sits there, requiring me to press the Back or the Home button to get back to my stuff. I looked around for a new setting that will stop this but didn't see one. I looked at the various Android boards and nothing there either (so, obviously, I must be the only one that is bothered by this). I just want it the way it was. It's bad enough that this update has hosed a couple of other favorite apps, but it has to remind me about it every time I return to my desk.

    And, often when I unplug now, it turns my screen OFF. Turning it back on, it isn't locked or anything - exactly where I left it. But I don't want it turning the screen off.

    Is there an app that can get me into deeper settings? I already use Quick Settings, but USB notifications isn't in there.
     

    Advertisement
  2. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,416
    Likes Received:
    1,919
    Enable USB Debugging - then it doesn't automatically notify you to mount or not mount.
     
  3. tjoebgen

    tjoebgen Well-Known Member This Topic's Starter

    Joined:
    Dec 27, 2009
    Messages:
    101
    Likes Received:
    4
    Thanks for the tip, but...

    That's a pretty scary warning screen:
    "Allow USB debugging?
    USB debugging is intended for development purposes only. It can be used to copy data between your computer and your device, install applications on your device without notification, and read log data."

    So, I tried it, and now I have another icon (debug mode) taking up space on the status bar.

    I know I'm difficult to please. I just want stuff to work. BOO to Froyo! Except for finally fixing the Bluetooth voice dialing, I didn't need the rest of this forced down my throat, ruining how I finally had this device set up, and costing me time to try and recover some of the functionality I had in 2.1.
     
  4. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,416
    Likes Received:
    1,919
    Boo it all you want - it is working, just not working the way you want it to.

    The workaround I gave you is pretty much the only way to do it unless you're rooted.

    No one company can please 100% of the people 100% of the time - so, in this case, you're going to have to 1) explore other alternatives if they exist, or 2) just deal with it.
     
  5. tjoebgen

    tjoebgen Well-Known Member This Topic's Starter

    Joined:
    Dec 27, 2009
    Messages:
    101
    Likes Received:
    4

    typical
     
  6. RyanB

    RyanB Guest

    For those of us rooted, what are our options?
     
  7. droiiiiid

    droiiiiid Well-Known Member

    Joined:
    Nov 9, 2009
    Messages:
    88
    Likes Received:
    1
    I'm surprised there's no option to disable connecting to the computer. You only plug it in to draw power, right?

    Is there not a setting for "Do not connect to other devices via USB"? Or maybe even an app?
     
  8. shadowdude777

    shadowdude777 Well-Known Member

    Joined:
    Nov 8, 2009
    Messages:
    1,842
    Likes Received:
    122
    ROMs built from source (Cyanogen and Sapphire) have the option to enable USB debugging without having the icon in the status bar.
     
  9. tjoebgen

    tjoebgen Well-Known Member This Topic's Starter

    Joined:
    Dec 27, 2009
    Messages:
    101
    Likes Received:
    4
    and now it's worse...

    Not only is it becoming quite tedious to have the stupid full screen USB Storage message interrupting my normal flow (having to hit the back button every time I get back to my desk and plug in), now it has started to immediately go into Storage In Use mode! Requiring me to turn OFF usb storage, wait for annoying green guy to show up (twice) and then press the back button.

    What would cause Droid (original, no roms or mods) to go into Storage In Use mode directly upon being plugged back in? I've power-cycled numerous times. Nothing had changed from when it was just the annoying green droid full screen message and now when it is giving annoying orange droid.

    The pre-2.2 method of usb notification was so much better - clean, efficient, PROFESSIONAL... I just want a setting option that kills the big screen altogether.

    Helpful comments (or if having similar problem) are welcome. If you are a fan-boy and only want to tell me things like "that's the way it is, get use to it", please move on to a different thread. If you have a real fix or workaround, or even a real link to a real site where my "suggestion/question" can get real results, please post.

    Thank you
     
  10. Frank Grimes

    Frank Grimes Well-Known Member

    Joined:
    Aug 4, 2010
    Messages:
    56
    Likes Received:
    11
    I agree it was better before the full screen guy showed up in the Froyo update but like johnlgalt said, you're going to have to deal with it.

    If you're now having problems with it going in to Storage In Use mode, give Verizon a call and play Russian Roulette trying to get a "certified refurbished" phone sent to you that doesn't have problems worse than a screen popping up and you have to take half a second out of your day to hit the home or back button for.
     
  11. BmanCV60

    BmanCV60 Well-Known Member

    Joined:
    Jul 19, 2010
    Messages:
    60
    Likes Received:
    7

    Are you using WinAmp? Found the answer for me in this thread:

    http://androidforums.com/motorola-droid/204197-usb-dock-auto-connects.html
     
    Fifty9Dunes likes this.
  12. Fifty9Dunes

    Fifty9Dunes Member

    Joined:
    Mar 12, 2010
    Messages:
    14
    Likes Received:
    1
    Thank God you found that BMan -

    I'm a rooted user and spent the weekend trying to run scripts to stop automount - I thought I had caused the action due to messing around.

    ...damn you Winamp...it really does whip the llama's ass, though.
     
  13. RyanB

    RyanB Guest

    OP, I hate to be the bearer of bad news, but I've got a feeling that you aren't going to find a solution, at least on stock Froyo. (If you decided to root, there may be a custom ROM that does away with it, or you could always go back to Eclair).

    Here's what I found that seems to confirm my suspician:

    1. XDA developers' lack of response, which indicates to me either lack of desire, or lack of something exploitable in Froyo (Disabling the USB Connection Prompt on Froyo - xda-developers)
    2. Google doesn't appear to be interested in changing it back (Issue 9088 - android - Enable the ability to suppress the "Mount USB mass storage" screen on Froyo - Project Hosting on Google Code). Notice in this thread that it was the SECOND time someone opened a complaint about it, though I believe it was the same person both times.
    3. I found nothing relevant on Appbrain for you, and next to nothing regarding USB mounting to begin with
     

Share This Page

Loading...