1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Froyo - Verified Successful Root...


  1. magohn

    magohn Well-Known Member

    I finally took the chance to attempt rooting my Intercept today. I wanted to root back in December but waited for the official update before doing so. I used this tutorial - easy, quick and straight-forward.

    YouTube - Root/HotSpot Samsung Intercept 2.2.1

    Note: The phones screen turns black for a few minutes- leave it alone and watch the PC screen as that will tell you status etc. Took about 5 mins total.

    I went ahead and installed Titanium Backup Pro and backed up the whole phone.

    More details can be found in the threads here:

    https://www.facebook.com/pages/KHX-Developers/217075261642244

    Works great for me but, of course, proceed at YOUR OWN RISK! :)

    This is not my work/videos/files - so if something happens to your phone, your on your own. All I did was follow the info on the facebook link. That's as much as I know...

    Advertisement
    :
  2. beefers

    beefers Active Member

    You didn't have to change the content of the .sh files? Did you turn on USB debugging while it was rooting? I read EdandInn's post on another thread and it uses the same files to root but does something else with the files. Thus, I am utterly confused as to which I'm supposed to do.
  3. Misterre

    Misterre Active Member

    My phone says Froyo 2.2.2 and Froyo.EC07

    Will the root still work?
  4. magohn

    magohn Well-Known Member

    As does mine - Im not really sure what a different EC# would mean to rooting but I went ahead anyways and followed the instructions in the video. I had zero problems. The only worrying moment was when the phones screen went dark for approx 3-5 minutes but I guess this is expected - it then came back to life as the phone rebooted. If you attempt this root, watch the screen on the PC for feedback, not the phone - leave the phone alone.

    Again, perform at your own risk. Ive been itching for root access and so thought I would dive into this method. Super-easy and so far everything is perfect!

    Beefers - I changed NOTHING in the files. I did have debugging turned on.

    Im loving root. Titanium Backup Pro is excellent....
  5. loop6719

    loop6719 Member

    I noticed in video..you had a sprint intercept...would this affect/work with the VM intercepts or do we even know yet?
  6. magohn

    magohn Well-Known Member

    That's not my video - just a "How To" video that I followed (listed in the provided links) and it worked for me. I had a stock VM Intercept that was upgraded to 2.2.2 via the official update. I waited for the official update before rooting as I really wanted the fixes in 2.2.2 and did not want to confuse anything by rooting before I got the update.

    As I said, its not my work - Im just reporting this guys method worked for me...
    loop6719 likes this.
  7. Misterre

    Misterre Active Member

    I followed the video. Mine went through and said it was complete but never rebooted the phone and did not work.
    I tried it with both changing and not changing the .sm files.
    I did copy the files to the root directory of the phone (that is just the directory you click on in windows right)?
  8. magohn

    magohn Well-Known Member

    Did you copy ALL of the .sh files to the root of your SD card ? Did you copy the 'busybox' file to the root of your SD card ? Did you enable debugging?

    To copy the files I used my PC's card-reader and took the SD card out of the phone - copied the files to the ROOT OF THE SD CARD and put the chip back into the phone.
  9. Misterre

    Misterre Active Member

    I moved 3 .sh files over and the busybox and playlogo.
    I enabled debugging.
    This time it rebooted but Barnacle still says it is not rooted.
    Weird
  10. magohn

    magohn Well-Known Member

  11. I'm a little confused I thought people had problems keeping the root permanent? I just got my update as well and I'm ready to root my phone. I rooted my Eris with the 1click app and flashed a shweet rom from xdadevelopers.com but as of right now I'm unable to find a thing for my VM intercept. What roms are you guy using? Or are you guys keeping your phones stock? I just want to delete all the bloat-ware if anything. Yet, any information is greatly appreciated.

    Thanks
  12. magohn

    magohn Well-Known Member

    As stated in the first post, my phone was completely stock and with the 2.2.2 update. I used the linked "root" method to successfully root. I had never rooted an Android before. This was my first attempt and it went perfectly with no issues...

    Verified by using root only apps and also "root checker" from the Market:

    [​IMG]
  13. fozzy501

    fozzy501 Active Member

    i need help mine sais device nt connected i need help
  14. magohn

    magohn Well-Known Member

    You need drivers and PC->Phone communication before you can attempt a root.
  15. fozzy501

    fozzy501 Active Member

    where can i get all that??
    can you give me like a link??
  16. magohn

    magohn Well-Known Member

    Here's what I did:

    Installed PDANet - https://market.android.com/details?id=com.pdanet&feature=search_result

    I believe it comes with a compatible driver as the app is about USB tethering.

    You also may want to try plugging the USB cable into different ports to see if you get a connect. For some reason the connection did not work on my rear USB ports but was fine on the front ports.

    Then once you have connection, go ahead with the root if you wish...
  17. caaron

    caaron New Member

    I can +1 that this worked for my completely stock VM intercept as well (Froyo 2.2.2 and Froyo.EC07). I had read many threads regarding this, and EdandInn's post about changing stl5 to stl9 did NOT work for me.
    I tried that twice and it didn't work, and then switched all the .sh scripts back to stl9 and it worked the very next time. So in the end, I ran it just as I got it from the zipfile.

    I had a real hard time getting the proper USB drivers such that adb would recognize the device.
    The suggestion in installing PDAnet solved that, then the start_root script worked, and according to the root checker app, it is permanent.
  18. fozzy501

    fozzy501 Active Member

    okay so with this root i csn now install a custom rom rite? and alll i need it titanium recovery?? and just flash the rom or wat do i need to do??
  19. magohn

    magohn Well-Known Member

    I have no idea. I successfully rooted my phone using this process. Other than that, you know as much as I do :)
  20. This works!! word of advise make sure you have everything turned on USB debugging and usb transfer, also make sure to install drivers from the Samsung website. Be patient it took my phone 3 times for it to go through and took way more then 5min leave the phone alone and keep checking the computer screen for instructions.
  21. antibrownie7

    antibrownie7 New Member

    I tried this, and i ran into some problems i was wondering if anyone else had who tried it. First off I want to mention i have everything stock, and the official 2.22 vm update on my phone, usb debugging is on, and it's never been rooted.

    The problem I'm having is i noticed while running start_root, either the usb connection disconnects or it stops at the point where it asks me to wait '5 mins for a response'.
    I've copied all the files to the root of the sd, and my drivers are updated. The usb never shuts off other than when i'm performing the start_root.
    Thanks in advance.

    EDIT: Alright, I messed up a lot on the setup of all of this, I actually just finished rooting my phone properly. I thought i had to just copy the files to the root of the sd, and run the start_setup, but after MANY failed attempts I did some researching and found i had to run it from my comp, not the root of the phone...

    It took 2 tries, but it worked, I can now use Barnacle haha.
  22. magohn

    magohn Well-Known Member

    I thought the steps of running the bat file from the PC was shown in the video?
    I followed the video and did not have a problem....:confused:
  23. This method worked for me. There's a great post somewhere on this forum with a top ten list of rooted apps. Some really useful stuff there. Also, any word on getting Flash to run on a rooted Intercept yet?
  24. teedoe

    teedoe Member

    Glad it worked for you but mine just hangs up at the exploit stage. I waited at least 10 minutes and nothing happens.
  25. I didn't time mine but it took way longer than the recommended 5 minutes. What sort of tether are you using, Samsung drivers, PDAnet?
Loading...

Share This Page