Froyo WiFi problem fixedGeneral


Last Updated:

  1. bikercr

    bikercr Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    49
    Likes Received:
    6
    Some folks, including myself, developed a problem holding onto a WiFi signal after the Froyo update. After Froyo, I was getting a good connection intermittently, sometimes for only a few seconds before it was lost--the phone was switching to 3G and then back again, over and over. This disrupted downloads, browser connections, etc. I'm using an Airlink101 wireless-N router on the Comcast network.

    The fix: I changed the router settings from G+N to N only. No more disconnects. Seems that the two protocols were conflicting with each other--fighting for a connection to my phone. My connection speeds went way up immediately (12-13 MPS download/3+ MPS upload). My wife has an Eris that does not have wireless-N capability (only G). I set up a secondary channel for wireless-G and gave it a different SSID name. This did not conflict with my phone--I didn't manually set up the login for that channel so it's just being ignored by the DInc.

    Not sure if this is necessary for some wireless-N routers but it definitely worked (so far) for the Airlink.
     

    Advertisement
  2. Dream

    Dream Well-Known Member

    Joined:
    Oct 26, 2009
    Messages:
    431
    Likes Received:
    82
    Wow wicked nice internet speeds you have there.
     
  3. DodgerinNH

    DodgerinNH Well-Known Member

    Joined:
    Apr 2, 2010
    Messages:
    208
    Likes Received:
    23
    just curious, I've posted this problem before, but no one seemed to have it, and I'm not even sure if it's a problem. But since the update, my connection speeds are all over the map. Sometimes they're up at 54 (using wireless G router at home) but other times, it will be down to 19 or even as low as 6!

    I just ran a speed test and got 10 down 2 up, so I know I'm ok there, but am concerned about these fluctuating connection speeds. Haven't noticed any considerable browser page load issues, I did notice when I'm at work, which has a Wireless N router, my boss' Droid 2 is sitting at a steady 65 mbps, while I was standing right next to him, and was only at 19 mbps!

    I've considered doing the factory reset, but for one reason, namely a version of swype which has a voice button (from the XDA website, so don't lecture me, mods!!) , I haven't, because I'm afraid I'll lose it.

    Any suggestions?
     
  4. Pretkomel

    Pretkomel Well-Known Member

    Joined:
    Nov 8, 2009
    Messages:
    230
    Likes Received:
    13
    Glad to hear that you solved your problem. I am also a comcast user and I get 18 Mbps down and 5 Mbps up.
     
  5. bikercr

    bikercr Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    49
    Likes Received:
    6
    The connection speed you'll see when you tap on the connection box in WiFi settings is affected by signal strength from your router, which is affected by your distance from the router. The highest speed you can get from a wireless-G router is 54 Mbps. Wireless-N is up to 300, but I've only been able to get connection speed up to 72 or so--maybe a limitation of the phone, not the router.

    Your fluctuations at home may have to do with poor signal output from your router, interference from nearby wireless phones (that work on the same 2.4 ghz band), or from some problematic setting in your router. Try setting the router only to G (not B+G). Or, get a new router with wireless-N: faster and better signal strength at a distance. Routers are pretty cheap nowadays.
     
  6. mstarbear

    mstarbear New Member

    Joined:
    Aug 21, 2010
    Messages:
    2
    Likes Received:
    0
    How do you change the channel that you are on? I am running on channel 6 but analyzer shows 1 and 2 with much better signals. I have a wireless-n router but I never get more than 54 mbps. However I have noticed that it has always been 54, never lower. I use wi-fi all the time at home as I have a very weak cell signal. Network seems to be very fast, but even faster is always better!
     
  7. bikercr

    bikercr Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    49
    Likes Received:
    6
    You should be connecting at faster than 54 which is the ceiling for wireless-G (N has a 300 maximum but the Incredible tops out, I think, at 72). I think you're stuck on G because of settings in your router. You have to log onto your router via your browser via a specific IP address. In the wireless settings you can specify N only. You can also choose a specific channel rather than auto.
     

Share This Page

Loading...