"Fully Charged" at 80-85%?Support


Last Updated:

  1. howetechnical

    howetechnical Well-Known Member This Topic's Starter

    Joined:
    Aug 21, 2010
    Messages:
    455
    Likes Received:
    88
    Hey all,

    Haven't seen this yet on the forums for the Galaxy S devices. Yesterday and today, my device has been saying it's fully charged when it's only between 80-85% charged. This happens when plugged into the USB cable attached to my PC, haven't noticed it when plugged into a wall charger (such as when I wake up in the morning...it's 100%). Yesterday it would cap off at 85% when the double-tweet alert says it's fully charged, today it registers fully charged at 81% (just now). If I unplug it and plug it back in, it will start charging again like normal (it may even continue charging on it's own without unplugging it, but I'm always next to it when it happens, so I'll try leaving it the next time it alerts).

    I called T-Mobile yesterday about it, they didn't even want to troubleshoot it, and with no questions asked they sent me a new battery (If this is a software issue, that means I got a free OEM spare battery, sweet).

    Anybody seen this happen, or know if it? Hopefully it's just a 2.1 issue that will be fixed at the end of the month with Froyo.

    It's not really a huge problem, as every couple of hours I have access to charge my device at least 30 min (even while working, I drive about 150 miles per day, so It's on the car charger 30% of the day), but it's annoying.

    EDIT:

    Ok, this is weird. It just happened again (10 minutes later), and I left it plugged in, unlocked the screen, and BattStatt said fully charged. Even the device's "about" section said 100%. I then unplugged it, and it immediately dropped to 83%. Then I plugged it back in, it rose to 85%, and dropped back down to 83% a second later. I don't think it's the battery, as in my 2 years designing battery packs about 7 years ago, I've never seen one discharge 17% instantly. Gotta be a software issue.
     

    Advertisement
  2. PlowRox

    PlowRox Banned

    Joined:
    Jul 31, 2010
    Messages:
    116
    Likes Received:
    4
    hmmm I bought a $4.99 car charger at walmart because the charger cable was usb and had the correct plug for the vibrant. I use it exclusively to charge the fone from my Linux box's usb and I use the usb cable that came with the phone to transfer files over from my ms xp box. Other than the noted battery level issues I haven't had any charging problems. maybe cus its a dumb usb no data lines interfering ???

    Good Luck

    :)
     
  3. howetechnical

    howetechnical Well-Known Member This Topic's Starter

    Joined:
    Aug 21, 2010
    Messages:
    455
    Likes Received:
    88
    I left it plugged in for a while after the last time it indicated a false fully charged notification, and it did get to 100%. It's evacuating the power at the normal rate, too, so it must be an issue with Eclair. I don't have any other apps interacting with the battery level besides battstatt, which is a plain "dumb" reader of the about screen.
     

Share This Page

Loading...