Fully rooted but still with S-ON! How?

Last Updated:

  1. Nagrom

    Nagrom Well-Known Member

    Hi Kids.

    So I was reading up on some terminology. Mainly what the hell S-OFF, and S-ON mean. I now know they refer to the security settings in the HBOOT of HTC phones.

    I read that if the phone is fully rooted using Unrevoked, then the phoen will then be fully S-OFF. However mins is still reading as S-ON in the HBOOT screen.

    How is this possible, and how do I become fully S-OFF?

    Thanks in advance


  2. Hadron

    Hadron Well-Known Member Contributor

    Unrevoked only provides S-Off on CDMA Desires, and even then not all of them.

    For S-Off on a GSM Desire (which is what you have) you need to pay a visit to alpharev.nl. There's also a tutorial thread in xda-developers desire-android-development forum, linked from SUroot's root memory FAQ (look under "alpharev partition tables").
    Nagrom likes this.
  3. Nagrom

    Nagrom Well-Known Member

    Hmm. That all looks alot more complicated than just rooting it. Might have to give that a miss. Took me months to pluck up the courage to root. Knowing me I'd brick my phone. Thanks anyway mate.
  4. Hadron

    Hadron Well-Known Member Contributor

    It's actually pretty similar in complexity to rooting - you make a bootable disc from the alpharev iso, and once you've done that the actual S-Off is pretty much a one-click operation.

    But you shouldn't (IMO) do it just because you've read someone say that it's a good thing to have. You should think about what else it makes possible, and if those are things you want to do then many of us here have done it and will be happy to advise.
  5. Nagrom

    Nagrom Well-Known Member

    Okay so what I gather it free's some space up by resizing the partitions, and switches off the HBOOT security features making it easier for unsigned roms to be installed, but I've not seen anything about any other effects. What else does making the phone S-OFF with alpharev offer?

    Thanks for all this info.
  6. Hadron

    Hadron Well-Known Member Contributor

    The other thing is that bypassing the NAND security lets you write to the system partition while the phone is running Android, so you can e.g. add init scripts without flashing, or use Ti to unistall system apps (or use it's option to integrate updates to these into the ROM).

    You also gain the option to flash radios via fastboot rather than recovery (should be safer, and the only option if you have a reduced size cache partition).

    The main attraction is however resizing the internal memory partitions to waste less space and make more of it available for user apps.
  7. SUroot

    SUroot Well-Known Member Developer

    The security is not in the hboot. It's in radio nvram. They can't change that do they devised a special hboot to ignore it. Technically security is still on. Just ignored
  8. Nagrom

    Nagrom Well-Known Member

    Hadron. The space saving advantage is a great appeal to me. I might just consider doing this. Thanks.

    SUroot. Thanks for clearing that up. I'd say I'm about 50% there now with all the tech' droid stuff. I'm still learning the more advanced side of things. Any tips, advice us greatly appreciated.

  9. SUroot

    SUroot Well-Known Member Developer

    Ask anything here you need. We're here for you *cheesy smile and double finger point with thumbs up, buddy Jesus style*

    Youve been on this forum for aged now. You may call me Dan
  10. EddyOS

    EddyOS Well-Known Member

    It's actually 'Buddy Christ' ;)

  11. SUroot

    SUroot Well-Known Member Developer

    We could go either way with this ;)

  12. Nagrom

    Nagrom Well-Known Member

    Does doing this affect the ROM? What I mean by that is will I need to reinstall GV? or does it just resize the partition the same way that Partition Magic on a PC does. I might well take the plunge tonight. Be interesting how much space I'll claim back.
  13. SUroot

    SUroot Well-Known Member Developer

    If were taking about hboot partitions, totally different. It's just changing where all the software thinks the partitions are. Should be.ok so long as Rom is smaller than system. Take a nandroid backup via recoveryfirst though
  14. Nagrom

    Nagrom Well-Known Member

    Okay colour me stoopid, but I'm lost already. I've downloaded the Alpharev iso, and burnt it to CD.

    I cant get the PC to boot from this CD, as described in the guide. I'm REALLY lost with this now....

    Do I put the alpha.zip file that's now on the CD onto my SD card, and install that?

    Sorry to be a pain guys. I realy cant get my head around this alpharev thing after all.



    I've also just set up my PC to run fastboot as per SUroot, sorry Dan :) described in his guide here http://androidforums.com/desire-all...fastboot-windows-updated-1st-june-2011-a.html
  15. Hadron

    Hadron Well-Known Member Contributor

    You need to burn it to CD as an iso, not just copy the data. Not much of a windows user, so can't name a utility off the top of my head, but SUroot has posted this a couple of times, so a quick forum search should bring up the answer.

    As for flashing different memory table, when you are S-Off you can follow the instructions on alpharev.nl. In essence you take a nandroid, update the hboot, wipe, restore the nandroid, but there are step-by-step instructions just under the download links for the various tables.
    Nagrom likes this.
  16. ducky1979

    ducky1979 Well-Known Member

    You have to tell your pc to boot from cd, f8 I think during boot to enter bios, when there change the boot sequence so its cd first. Then when you reboot it should boot straight from the cd and that's it, s-off is very simple, don't install their clockwork mod, deselect that, and if your anything like me you will be shitting it for a few minutes then your done. Good luck.
    Nagrom likes this.
  17. shauny13

    shauny13 Well-Known Member

    sounds like you have just made a data disk. The alpharev should be an image that you burn to disk and then thr pc boots from it, what software did you use to burn the disk? Try using this.

    Free ISO Burner
    Nagrom likes this.
  18. Nagrom

    Nagrom Well-Known Member

    Hmmm maybe you're right. I used Deamon tools to burn the CD. When I looked at it, there was only two files, and a zip folder. I thought it didn't look like a bootable CD. I'll have another look tomorrow.

    Thanks guys.
  19. SUroot

    SUroot Well-Known Member Developer

    Yeah you need to burn it as an iso. Essentially a clone from the image.
  20. Nagrom

    Nagrom Well-Known Member

    Okay I'm still struggling with this. I've burnt two images with Free ISO burner, and one with Afterburner lite, and, another with Active@ ISO burner, and all four show EXACTLY the same files, and are none bootable. Tried three differant downloaded AlphaRev ISO files incase one was corrupted. Nothing.....
  21. SUroot

    SUroot Well-Known Member Developer

    Can you confirm you can definitely boot to other CD's?

    Theres a more long winded way around this...

    Download and install VMware player
    VMware Player 3.0

    You need to sign up, but thats fine.

    Once you have installed vmware player:

    Open VMplayer
    click "create new virtual machine"
    Select "I will install the Operating system later"
    Select "other" and again in the drop down.
    Set name as "CD bootable" if you like or leave as is.
    The machine will take up a small amount of space, so ensure you are happy with teh location.
    Store virtual disk as single file
    Set disk size as 0.5 or something
    "Customize hardware"
    highlight CD drive in left and in right, "use ISO image". Browse to your allpharev.iso or alpharev.iso or whatever.
    The machine will start up in a new window. If it does not, you can play it from the main window.

    Plug your phone in. Look at the bottom edge on the right of the window. You should hover over the icons as one will be your phone. Click on it and select "connect to guest" and thats it. Go through the process
  22. Nagrom

    Nagrom Well-Known Member

    Okay, first of all. I'm a dick LOL.

    I've got that many drives attached to my PC that every time I tried to boot from the CD, I kept clicking on one of the HDD to boot. No bloody wonder it wasn't working.

    So in bed last night, I had a flash of inspiration, and realised this.

    Got up and tried it. Low and behold the CD booted fine. Linked up the phone, and ran the AlphaRev HBOOT utillity.

    After getting to stage three, and the screen readinng, waiting for flashing to complete, I waited........and waited........and waited.......and you guessed it, I waited.

    After three and a half hours later, now now 02:15 this morning, the phone STILL hadn't done anything. Now comes the brown trouser moment, I picked up the phone, and caught the USB cable. Countless read/write errors came up on the screen. OH F**K I thought, I've bricked my phone.

    Thought, I might as well turn the PC off now, since my phone is screwed, but just out of curiosity, I booted it. STILL read the old HBOOT with S-ON, but thankfully I was able to recover the backup I ran before I tried this.

    How long does this process take. I'm shocked that after 3 hour's nothing had happened.

    I REALLY want to try again, but I don't want to wait that long. Most nights I end up in the spare room, as my 3 year old ends up in our bed. The PC is in there, and it'll keep me awake. So running it through tyhe night is really a no no.

    Thanks for the advice again.

  23. SUroot

    SUroot Well-Known Member Developer

    Shouldn't take more than 10 minutes....
  24. Nagrom

    Nagrom Well-Known Member

    So I'm guessing three and a half hours is on the L O N G side? LOL

    I'll give it another go now.

    Wish me luck :)
  25. Hadron

    Hadron Well-Known Member Contributor

    Good luck!

Share This Page