Functions shut off when talking on phone.General


  1. Sandbob

    Sandbob Member

    When I am talking on my Galaxy s 111, my cheek will randomly shut off functions like mobile data, sound, driving mode etc. Samsung live chat says that this is how it is. Is anyone else having this problem, and what can be done to resolve it. They asked me to do a factory reset, but I did not opt for that because I think it's just a flaw in the design of the phone. Please help...I am missing calls because I don't now that functions are turned off. I hope I am not going to have to check the functions after each call.

    Advertisement
  2. gcam333

    gcam333 New Member

    I am having the same issue with my SIII. A few years back a I owned a Samsung Saga, Windows based phone, and fought the same problem for 2 years. A smart phone that is too dumb to know that the touch screen controls at the top of the machine should be off during a call. I suspect that with the SIII this could be linked to a problem with the Gyroscope.When I first noticed the problem, re-calibrating the Gyroscope seemed to solve the problem, then I started to calibrate multiple times per day. Now nothing helps. Verizon is sending me a new phone, If I experience the same with it, I will return it and change to a different phone. I swore after the 2 years of hell with the Saga I would never own another Samsung phone. I got sucked into the hype. Oh, did I mention the Echo problem ???? Buyer beware.
  3. s73v3

    s73v3 Member

    i kept turning on the speaker with my cheek, quick fix I found was just press the screen lock button after answering the call or the call recipient has answered. When the call terminates the phone automatically shows the call stats and the end of call screen but you must unlock it again first.
    I know its not the best but maybe it will save some of the stress.
  4. martyn357

    martyn357 Well-Known Member

    No, it's NOT the gyroscopic sensor. This phone has a proximity sensor, try adjusting that instead...:rolleyes:

    Look down the list on this site and it tells you what sensors are on this phone:

    http://www.gsmarena.com/samsung_i9300_galaxy_s_iii-4238.php
  5. Sandbob

    Sandbob Member

    Go to the screen where you would make calls, go to settings, make sure "Auto screen off during calls" is checked. This worked for me.

Share This Page