G2 and EAP-TTLS (PAP) wifiSupport


Last Updated:

  1. Artemis68

    Artemis68 Active Member This Topic's Starter

    Joined:
    Oct 19, 2010
    Messages:
    32
    Likes Received:
    0
    My college has a REALLY weird wifi security thing going.

    Basically, it's 802.11x EAP-TTLS with PAP inner security. The wifi network does show up on my G2 but it's showing as having "WEP" security, which isn't really true because it's the one I stated above.

    Any way that I can connect? I correctly fill out the security information when I go to set up a new network, but it tells me that its not in range, only the wifi network with WEP is.

    I'm really stuck here. My college's IT place is absolutely no help, especially when it comes to cell phones. They already have difficult comprehending that *gasp* printers can work wirelessly...they have little to no knowledge on cell phones either. I confused them with my Blackberry last year...which, by the way, can't connect to the wifi.

    Please help! Thanks.
     

    Advertisement
  2. DaWeav

    DaWeav Well-Known Member

    Joined:
    Nov 13, 2009
    Messages:
    343
    Likes Received:
    53
    College IT knowing anything? Isn't that an oxymoron?

    802.1x is 'Enterprise' level security. So, forget the fact that it's showing up on the list as 'WEP'. Simply go to Settings, then Wireless & Networks, and Wi-Fi Settings, but instead of selecting what's the phone thinks is being broadcast as shown on the list, scroll down to the bottom and select 'Add Wi-Fi network'. Put in the SSID of the college network then change the security type to '802.1x Enterprise' from the popup listing. Then put in a security password which is not the wireless network password, but rather a secure credential storage password that protects anyone from getting into your wireless credentials on the phone which can be setup and/or changed in Settings/Security. Once you hit OK, you will then see all the 802.1x settings that include the EAP method for TTLS and authentication credential settings which you should be able to setup with all the credentials provided. Now, if they are using Certificate based authentication, you have to have loaded your certificate on your phone before hand in Settings/Security/Install from SD card. Note that you cannot use smartcard based certificates since Android doesn't have any bluetooth smartcard readers yet that it can pair with that I know of. Hope it works...
     
  3. Artemis68

    Artemis68 Active Member This Topic's Starter

    Joined:
    Oct 19, 2010
    Messages:
    32
    Likes Received:
    0
    Nope it didn't work. I got in and typed in all the credentials, but it keeps telling me that its not in range. The college ssid saying its "wep" is still showing up though.
     
  4. vega_dj

    vega_dj New Member

    Joined:
    Dec 13, 2010
    Messages:
    1
    Likes Received:
    0
    I have exactly same problem. My added profile acts like another wifi, in fact it must be same as the broadcasted one. We can not solve the problem.
    Here is the things we tired;
    1-) Your wifi station is forced to encrypt by Wep. (also mine is encrypted as wep; and use 802.1x ttls-pap) We removed this web encryption and tried to connect like that but it didn't work.
    2-) My device is loaded Android 2.1, we tried in android 2.2 but it didn't worked again.
    3-) Android wants .p12 extension certificates. I thought maybe the certificate is not working and load .cer certificate of the wifi which is perfectly working, but it didn't work again. (There is a guy that made useful, easy method that can install .cer extention to android using php codes)

    Thus, please someone help to solve the problem. We get stocked .
     
  5. fangorious

    fangorious Guest

    Try searching the market for LEAP. There should be a couple apps that will let you edit the config of the detected network.
     
  6. Bennyboy1979

    Bennyboy1979 New Member

    Joined:
    Apr 29, 2011
    Messages:
    1
    Likes Received:
    0








    Programs -> Settings -> wireless controls -> turn on the Wi-Fi ->
    go to, Wi-Fi settings -> select, Add Wi-Fi network
    -Enter the name of the network,
    -select, 802.1x, EAP (Enterprise)
    - "identity" Whole username
    - "password" Your password

    This worked for a high-security network. :)
     
  7. timbower

    timbower Member

    Joined:
    Feb 27, 2011
    Messages:
    7
    Likes Received:
    0
    This worked for me... thanks for the help!
     

Share This Page

Loading...