Root GalaxHero v1.1 and Recovery v4.3 are out!

Discussion in 'Android Devices' started by buntoid, Nov 25, 2009.

  1. buntoid

    buntoid Well-Known Member
    16

    Nov 1, 2009
    48
    2
    16
    Wiltshire, England

    Advertisement
  2. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
    Excellent! Downloading now...

    Many thanks Drakaz, I will look at sending a donation later.
     
  3. pegasus21

    pegasus21 Well-Known Member
    36

    Aug 26, 2009
    253
    1
    36
    Someone should inform him about the K1 kernel source.
     
  4. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
    K1 kernel source??

    Edit : ah I see the other thread now, anyone checked if an update is available with sephail's FUS downloader? I can't check from here.
     
  5. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
    Posted this over on HDBlog too but I've just applied the new update.zip over the top of my existing GalaxHero 1.0 without doing a factory reset/wipe, then restored the g.apps, and everything is looking fine.

    There's also no need to reflash the recovery just overwrite the RECTOOLS.tar.gz file with the new one.
     
  6. m4j3r

    m4j3r Member
    15

    Sep 14, 2009
    19
    0
    15
    Is there any noticeable improvement compared to 1.0?
    1.0 was very slow on my device and after few mods posted on this forum is now working great...so is it worth upgrading?
     
  7. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
    I never had any performance issues with 1.0, you've not got compcache enabled have you? That does slow things down noticeably.

    No huge changes in this, just some improvements/fixes. Changelog from the HDBlog thread...
     
  8. tisti

    tisti Well-Known Member
    36

    Sep 20, 2009
    145
    5
    36
    Thanks drakaz. The Galaxy wouldn't be as awesome as it is without this rom. :D
     
  9. m4j3r

    m4j3r Member
    15

    Sep 14, 2009
    19
    0
    15
    yeah, I did have compcache enabled :D
    Well...since it is so easy to upgrade, I will give it a try.
    Keep up the good work, Drakaz
     
  10. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
  11. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    just the update.zip or did you do gapps aswell as mine has been booting for 25mins now but it doesnt look like a loop

    i think you were lucky as now my phone is borked and ill have to start again from the beginning :(

    EDIT: Fixed, i had to restore gapps as well as apply update.zip not just update.zip
     
  12. Andronix

    Andronix Well-Known Member
    63

    Aug 31, 2009
    676
    16
    63
    has the compcache been fixed on 1.1?
     
  13. UKLooney

    UKLooney Well-Known Member
    16

    Sep 20, 2009
    79
    1
    16
    Software Dev
    UK
  14. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
    Yes I did restore the g.apps again too, I wasn't sure if that would be needed sorry, should have posted.
     
  15. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
    I've been playing around with compcache enabled today and it seems faster than 1.0 was.
     
  16. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    you should always make sure you give advice based on EXACTLY what you did as otherwise it results in further problems like i experienced, lucky for me i a bit more versed in sorting problems with galaxy but alot of users would panic and start messing up other things
     
  17. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
    Well as I stated I was installing over the top of an existing GalaxHero 1.0, surely those people would be well aware ;)
     
  18. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    indeed, but you said "i just applied update.zip"
    so i did just that, i ended up in android screen for almost an hour.
    because you said "it worked" i didnt think i needed to apply gapps as it was already on from the previous install.

    i had to pull the battery, boot back into recovery, re apply update, apply gapps and then it worked

    its good to be specific in what you did
     
  19. tisti

    tisti Well-Known Member
    36

    Sep 20, 2009
    145
    5
    36
    I did the same mistake as Rastaman-FB. No harm done though, only needed to reboot back into recovery and reapply :p
     
  20. Gizmo306

    Gizmo306 Active Member
    16

    Oct 9, 2009
    30
    1
    16
    I just done it (GalaxHERO1.1) over Galaxo1.0, no wipe. and it working smooth, every thing i know still there. just need to reinstall CIME & remove something I don't need.:eek:

    I would say one thing is must have,:D
    - Home app is now locked in memory to avoid reloading of it
    Like keeping the OS/UI standby for my input all the time, not me waiting for it.

    one question:
    did anyone know where can I find this option,:thinking:
    - Add an option on AdvancedLauncher to activate/deactivate haptic
     
  21. i32547

    i32547 Active Member
    15

    Oct 15, 2009
    28
    0
    15
    rastaman... please can you give me a step by step guide... i done the galaxo before with the help of kam,, but hes no longer here,,is he?.. remember i had problems on my laptop? and i had to borrow a friends.. well firstly..do i have to borrow his llaptop again, or can i do it on a mac? im currently runnin the original galaxhero... i remember doin the flash ting in command prompt..then doin rest on the phone in different mode.. doin back ups, then update or sumthin like that,,then restores... pleade sort out a step by step please
     
  22. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    KAM is still about i think

    eitherway as you already have galax0 1.0 all i did was
    1 put the new update.zip on the phone mass storage
    2 replace the old rectools with the new one from the v4.3 recovery
    3 download the system img from the htc site calling it HTC.zip and put it onto the mass storage
    4 check that II5.tar is still on the phone mass storage
    5 boot into recovery and notice its now showing 4.3
    6 do a nandroid backup
    7 apply update.zip
    8 restore gapps
    9 Restore LibHGL
    10 reboot

    i didnt need to use any ADB commands or Fastboot
    this worked for me in exactly this order however if it doesnt you maybe required to borrow someones machine
    personally i would recommend doing it when near a windows pc just incase something does go drastically wrong you can flash it with odin

    i think it will be just fine though
     
  23. screaminbug

    screaminbug Well-Known Member
    36

    Nov 4, 2009
    102
    2
    36
    Croatia
    Can anyone please upload google apps backup. I'd be very grateful. I've messed things up, and now I can't restore them. Haven't been very careful and forgot to put new rectools, so the update wasn't succesful. I had to wipe. Now I get this when I try to restore g.apps:
    -- Restore Google apps
    -- Press HOME to confirm, or
    -- any other key to abort..
    -- Restore started...
    .Erreurs : le fichier de mise
     
  24. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
     
  25. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
    Press menu button on any home screen
    Select more
    Select extended
    Select sensor based parameters
     

Share This Page

Loading...