Galaxy Ace 2 and Link2SD - sudden issue overnightSupport


  1. happy37

    happy37 Member

    Hello everyone,

    Good morning. First time post and poster on these forums.

    [FONT=verdana, courier new,courier,tahoma,sans-serif]I am in desperate need of help with my new Samsung Galaxy Ace 2 phone with a Link2SD issue that occurred out of the blue last night.

    I had managed to transfer my saved data and SD card from my previous phone (Samsung Galaxy Y) to the new phone and all had been working well with no problems until late last night, as I said.

    I switched the phone on and I got an error message from Link2SD stating "Mount Script error". Mount Script cannot be created. Mount: Invalid argument.

    I had initially used MiniTool Partition Wizard Home Edition as suggested by the developer of Link2SD to format my SD card as FAT32 and primary on both partitions.

    If I remember correctly, both of these partitions were set as FAT32. I have looked at the SD card using MiniTool Partition Wizard Home Edition again this morning. The larger partition is showing as FAT32. It is 5gb in size and says 8% used. The other partition which I think is the one that now does not get mounted when the phone starts up now says 2.28gb and "Other" as the file system.

    Is there any possible way to get this error corrected and fixed so that I can start using my phone again as it was before please? I am not sure if there is any data on there?

    Can I possibly try and recover the data from the partition marked as Other, save it to a folder on my PC, reformat the partition as FAT32, and then copy the data back? Could this work?

    Can you please help or advise please as I urgently need to get my phone working again. Some of the app icons on my phone such as SuperUser, Play Store and so on have now been greyed out due to this error.

    [/FONT][FONT=verdana, courier new,courier,tahoma,sans-serif][FONT=verdana, courier new,courier,tahoma,sans-serif]I must also add the fact that I cannot download Link2SD again from Google Play as it says that it's already installed on my phone. It's not. Is it possible to re-download Link2SD so that I can try and get things working again?

    [/FONT]
    [/FONT][FONT=verdana, courier new,courier,tahoma,sans-serif][FONT=verdana, courier new,courier,tahoma,sans-serif][FONT=verdana, courier new,courier,tahoma,sans-serif]Many thanks in advance. Please advise as plainly as you can as it's my first time messing around with Android phones, Link2SD and the rest of the stuff. I am so unhappy right now.

    Please help!!!
    [/FONT]

    [/FONT]




    [/FONT]

    Advertisement
    :
  2. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    Hi,
    I experienced the same problem long time ago... And I learned not to save link2sd on the second partition again.
    *If you can't open link2sd to correct the problem?
    - Open "settings", select "app manager" in the phone menu and scroll "all" apps until you find the "grey icon for link2sd" and delete it.
    -next visit the "play store" and download it again.

    After that open link2sd and check if it works...
    If it displays the same error message?
    - just follow the instructions it provides.
    - or just select to recreate the scripts. And the extension should be the "second extension".

    Remember to save crucial apps like link2sd or supper user in the phone.

    Hope this steps are enough to fix the problem.
    Good luck
  3. happy37

    happy37 Member

    Hi Smokey,

    Nice to hear from you. Link2SD is not on the phone any more as I have just checked. It is certainly not in the "All" apps list on the phone.

    There us no "app manager". All I have is Applications under Settings. Is that the one?

    Is that why I can't see the partition any more? The SD card is not corrupted is it?

    Anything else I can try please. And thanks!! At least I am getting some help to get this sorted. Your advice is really useful.
  4. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    Hi @happy37,
    If Google play store claims that you have it? Than it should be in "apps".

    If you can't find link2sd in your phone?
    Try removing the SD card first and than reboot the device.
    Hopefully in that way the play store will let you download it again.
  5. happy37

    happy37 Member

    Will try that now Smokey.

    I have removed the SD card and rebooted. Should I not put the SD card back in and just download Link2SD on to the phone?
  6. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    Yes.
    The first thing you need to do is to find a way to reinstall link2sd again.
    After that it will be easy to fix the problem.
  7. happy37

    happy37 Member

    Just tried it now and it seems that the phone has just frozen and does not want to do anything Smokey. I had already removed the SD card and have not put it back in yet.

    Any more thoughts?

    Thanks.
  8. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    Press the power button for about 10seconds until you fell a little vibration than release the power button and let the phone reboot
  9. happy37

    happy37 Member

    All done again. Google Play says "Installed"

    Not only that, the Ace 2 is greyed out under the install button. It won't let me install it.

    Huh!? :-(
  10. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    If says that you have it, than you really need to look again in the phone "settings" / "apps".
    It should be there in downloaded or all...
    You mentioned you could see a greyed icon. And that is what you need to delete.
    If you can't than try to mount the SD card again.
    And if no luck ?
    Than the last option is for you to save and backup all that you can and perform the painful factory reset... :(
  11. happy37

    happy37 Member

    Looked again. If I want to do a factory reset, how will I ensure that I can save my stuff on the SD card to the PC? That might be easy I think. By just putting the SD card into a reader and copying the stuff over. The most important stuff are my text messages? How do I save those please?

    Can I do the hard reset without having the SIM card in the phone or not? Please advise.
  12. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    Yeah, just back all that you can.
    The messages can be backed up by a dedicated app or maybe with Kies.
  13. happy37

    happy37 Member

    OK thanks. Can I reset the phone without putting or keeping the SIM in there?
  14. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    Keep the SD card out.
    The purpose of the phone reset is only for you to be able to install the link2sd again in your phone to try and salvage the stuff you already have in your SD card second partition.
  15. happy37

    happy37 Member

    I am backing up now using Kies. I will keep the SD card out as well as the SIM card when I do the hard reset. What's the best hard reset method? Can I use *2767*3855#?
  16. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    Keep the SIM card in when you do the factory reset.

    -Boot your device in recovery mode. Press (Power+home+volume up). Release the keys when you see the green Android.

    * 1- select the option "clean partition" (or something like that).
    * 2- select perform factory reset.
    *and finally select boot the device.
  17. happy37

    happy37 Member

    Hi Smokey.

    Thanks for all the help last time. It all worked ok.

    But today I find that the Google Play Store and some of my other apps are greyed out yet again!?!

    Link2SD is working okay. What's the best and non destructive way of getting my apps working again please?

    Link2SD is installed on the phone itself.....not the external memory as you had suggested in your replies earlier in this posting.

    Thanks.
  18. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    Hi @happy37,

    Open link2sd and open settings button on the bottom left side of the screen.
    Select more...

    Attached Files:

  19. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    Follow this steps:
    1- Relink all application files.
    2- Relink library files.
    3- Link dalvik-cache files.

    If that didn't work?
    Than try this:
    1- Recreate mount scripts.
    And reboot your device.
    (Sometimes you need to repeat that same process again to take effect)

    Once you have successfully fixed the problem than follow this steps:
    1- Clean up the 2nd partition.
    2- Clean up the dalvik-cache.
    3- Clear all app caches.
    4- and Reboot your phone.

    Please note that:
    I am not affiliated to link2sd and also I am not affiliated to Android Forums in any shape or form.
    The same as you, I am only a participant user on the forum with the good intentions in trying to help other users.

    If you would like to thank me in the case I successfully managed to help you?
    Than please just press the :thumbup: button. As is there for some strange reason...

    Thank you in advance
    And good luck to you.
  20. happy37

    happy37 Member

    Hi @Smokey,

    Good morning.

    Done and followed all your instructions to the letter.

    I had even put the SD card into my PC, copied the data across into a folder. Re-formatted the partiton as FAT32.

    IIRC, both partitions are meant to be FAT32 and Primary?

    Once I had done that, I copied the data back over.

    It still does not work?

    I recreated the mount scripts inside Link2SD. That gave no error message.

    If I try the other oprions - I get:-

    /data/sdext2 mount not found

    What's next to get this fixed please?

    Thanks again.

    Regards.....
  21. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    If is giving you the message /data/sdext2 mount not found than you need to select (recreate mount scripts and reboot the device as instructed by the app. And maybe need to repeat that same step again...

    If no luck still than maybe with Temporary CWM and select fix permissions in 2nd partition.
  22. happy37

    happy37 Member

    Is it possible to use a brand new memory card and make 2 new partitions?

    I would copy and save my data onto both partitions.

    One partition would have all my data and apps on it, and the other would have all the scripts and other bits for Link2SD.

    Would this work or not as I don't think my current memory card wants to play ball.

    Please advise - I will use MiniTool Partition Wizard as that is what people have used before and it has worked in the past.

    Can this be done without losing any of my data?

    Thanks.
  23. happy37

    happy37 Member

    Back again to say that I had managed to copy my data onto my PC from the first partition. So, that's safe. But I had not managed to copy the 2nd partition with all of the dalvik cache files and so on from Link2SD.

    Secondly, looking at my SD card in Mini Tool Partition Wizard, it says "Bad Disk". Looks like the SD card has snuffed it??? :-(

    (See attached JPEG screenshot.)

    Can I now use the new 16GB card and set it up in the same way as before? I had 2 partitions with FAT32. One was 2GB, and the other was 5GB.

    Once I do this using Mini Tool Partition Wizard, can I copy the data back onto the 5GB partition and then use Link2SD to reinstall apps and links etc?

    Please advise as to correct steps please. I need to get my phone working again.

    Many thanks.

    Regards.

    [​IMG]

    Attached Files:

  24. Smokey Mc Pot

    Smokey Mc Pot Well-Known Member

    :what: The dalvik cache files and all the files in the 2nd partition are vital to make that same apps you lost to work.

    Why didn't you try temporary CWM to fix the permissions for the 2nd partition on the first external sd card ?
    That was all you needed to do in the first place...

    I explained to you before that you shouldn't never save any important apps on the 2nd partition.
  25. happy37

    happy37 Member

    Smokey - apologies. I am a complete novice when it comes to do this sort of stuff as I am only following instructions, that's all.

    So, what now? How do I get out of this mess?

    :( :(
Loading...

Share This Page