Galaxy Ace S5830i Recovery mode Cannot openSupport


  1. Alexis Skouris

    Alexis Skouris New Member

    Hello , i am here because i have a problem with my Samsung Galaxy Ace S5830i .
    I had installed some roms for my phone and one day i changed...
    I try to install ace-i-sure rom for my phone...but this time i didn't wipe data/factor e.t.c...
    I always wipe data/factory and then in ClockWorkMod , i wiped the dalvik in advanced settings and wipe factory e.t.c...
    But because of i didn't wipe the factory and data at first...,i only wipe the data in CWM , install the rom and reboot my phone!
    But it stucked in the background that says: "Samsung GALAXY Ace GT-S5830i"
    Ok. i had the same problem some days ago! But i open recovery mode and fix it.
    This time is different,i can't reboot / open the recovery mode or download mode.
    I pressed the Vol Up+Home+Power button ----> recovery mode but nothing ...it is stucked! I also pressed Vol Down+Home+Power button ----> download mode but again nothing!
    Please tell me any ideas . I don't wanna pay for resetup the system and pay 25 euros :( :( :( I WILL DO EVERYTHING FOR MY PHONE!!! :)

    Advertisement
    :
  2. ayush29k

    ayush29k Well-Known Member

    Try to force the phone into download mode and flash a fresh stock firmware via Odin.
    This is for S5830 so follow this procedure but use your own files and key combinations of S5830i.
    abdiemiru likes this.
  3. bsquirrell

    bsquirrell Well-Known Member

    I have managed to get my phone into download mode, it says ODIN MODE, I am tryingto recover the phone as it has lot its Imei number and I want to re install the stock rom. At the moment it is on Jellyblast v3.03. The problem I am having is when it is in downlaod mode Kies cant connect to it. How do I fix this problem please, I am getting just a little desperate.
    I tried to recover the Imei using glaxy toolbox and HEx editor, but couldnt do it, there was no backup showing, just efs backup, and that didnt seem to do it. Hope I am making sense to someone Help!!
    I am talking about the galaxy GT-s5830i
  4. amozz

    amozz New Member

    same.. same..thing has happned with me bro... plz tell me what should i do in this condition
  5. Jeffers

    Jeffers Active Member

  6. ayush29k

    ayush29k Well-Known Member

    Flashing a fresh stock firmware via Odin will solve your problem. It requires the phone to be able to access the download mode, and as long as that's running there is no need to worry. Just flash it and it'll be as good as new.
    Follow the instructions carefully or you might just damage it permanently.
    Use the link posted above by Jeffers, its a good tutorial.
  7. Jeffers

    Jeffers Active Member

    Ayush,
    Is this efs folder a samsung only requirement? :confused:
    Will flashing a stock ROM restore my lost efs file with my correct IMEI number?
    When I flashed my ZTE Blade with CWM I did not get any lost IMEI problems :)
  8. ayush29k

    ayush29k Well-Known Member

    Don't know about the efs requirement you are talking about, and also i have not used any other brand phones much so i really cannot answer that for you.
    Imei losses are very unpredictable, they can happen due to several number of reasons, although i have seen several S5830i users getting this problem while flashing some jellybean lookalike roms.

    Flashing stock firmware via Odin is just a full cleanup and reinstallation process, its better than flashing via CWM, no previous code or files are left behind to cause problems. But flashing stock rom via odin usually does not help in restoring lost IMEI but in some cases it has helped, very rare cases though. Although for S5830i there are methods to backup and restore efs partition through galaxy toolbox but its not available for the S5830.
    If you are a victim of lost IMEI on S5830i then lookup this toolbox. Some people who did not have a backup prior to the loss were able to recover their imei number using this toolbox and a hex editor, look it up there are some tricks available.
  9. Jeffers

    Jeffers Active Member

    I have since been told that the Galaxy Ace does not use the efs folder to store the phones IEMI, which is why when I open my efs folder it is reported as empty!
    Don't know where IEMI is stored on the Ace, but once phone was recovered including IEMI I downloaded Galaxy Toobox, backed up my IEMI and when I checked the backup contents it has my IEMI correctly stored in it. Just hope it works if I have to restore it again.
  10. ayush29k

    ayush29k Well-Known Member

    Fortunately the galaxy toolbox works for the s5830i model. Also the most reports i have heard about imei lost is by the S5830i users, mostly by installing some rom name jellyblast, usually flashing stock firmware seems to have resolved the problem. But its wise to keep a backup just in case because imei loss is really a huge problem, renders the phone quite useless.
  11. Melelek

    Melelek New Member

    Hi guys I have a problem with my Galaxy ace 5830i I rooted it and it was successful. I felt I needed a new rom so I tried Installing a CWM recovery 5.0.2.6 it finihed and said DONE!!! now the problem Came when I rebooted the Divice. it just booted to the point that Reads SAMSUNG GALAXY ACE..... but wot go beyound there. When I go to recovery mode it reads --Appling Multi-CSC--
    E:failed to mount/system (Invalid argument.
    I'm Very new in this thing! Could this has been the consiquence of the. DO IT AT YOUR OWN RISK????
    PLEASE GUYS I KNOW THE ARE GENIUS! HERE pLEASE DIRECT ME ON HOW TO REVIVE THIS BRICK IF ITS IT ALREADY!!!!!
    HELP ME!!!!!
  12. ayush29k

    ayush29k Well-Known Member

    Are you certain that use flashed the correct recovery file? as in the one that was built for s5830i and not s5830 or any other variant.
    If you cannot access recovery mode anymore than you will just have to flash the stock firmware back via Odin. This should not have happened if the file was correct and you followed the instructions properly.
    Melelek likes this.
  13. Melelek

    Melelek New Member

    Thank but where do i find this Odin?? and please If you can. Help me find the correct site for the clockworkmod for gt 5830i
    Please!!
  14. ayush29k

    ayush29k Well-Known Member

    Melelek likes this.
  15. Ogzxftw14

    Ogzxftw14 New Member

    Help i keep getting the same thing when i try to factory reset i do the steps but when i hold the buttons it comes up with the samsung logo and some sort of box that says ramdump mode (arm9 mode) can u plz help me

    Attached Files:

  16. ayush29k

    ayush29k Well-Known Member

    You are either not pressing the buttons correct or are pressing the wrong combination.
    Try again
Loading...

Share This Page